IRangeX 4in1 Plus fw flashing.

Need some advice? Trying out a new idea? Fancy a beer?
Join us for some general banter and good times.
User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Wed Jan 17, 2018 6:00 pm

I hope to in more detail, discuss how to flash a bootloader and new fw, as well as how to modify the code for changing channel order and any other defaults that may be required.
The latest plus version 4in1 (stm32) supports ppm or serial ( serial allows menu control with ersky9x or opentx).
It’s fw can be updated via the onboard usb connector or via the latest ersky9x fw.

This statement needs to be clarified/updated by anyone that is more informed. MikeB being one I hope will come on board.

The 4in1 is shipped without a loaded bootloader to support flashing using the onboard USB port or a tx running ersky9x(9xR pro).

So first step is to successfully load a bootloader.
There is a GitHub dedicated to these steps as well as several YouTube videos.
GitHub
https://github.com/pascallanger/DIY-Mul ... g_STM32.md

YouTube
This one is in German but has subtitles and seems to cover the plus version 4in1 directly.
https://youtu.be/qKsoTQQfy_4.

The requirement to flash the bootloader for usb from what I have gathered are

HARDWARE
Read the GitHub page on the sym32 flashing.
Have a usb FTDI programmer.

Have a 9xR pro with the latest ersky9x or a Frsky X9D or plus or Qx7 with the latest otx2.2.x or I believe ersky9x 9x loaded.

3ea female to female programming jumpers.

Install in the 4in1 the required male header pins needed for connecting the FTDI programmer.

SOFTWARE
latest Arduino IDE program
Notepad++
Multiprotocol .ino from the GitHub page.

https://github.com/pascallanger/DIY-Mul ... g_STM32.md

Anything linked to on the GitHub page.

To view the code or modify it in the _config.h file, I found useful a free pgm called Notepad++ for windows allows me to read the hidden comments and make changes.

With all this, I haven’t been successful in programming the bootloader as these exact steps are for me, not detailed enough? Try as I have with what I believe are the exact hardware, software, and step by step, I don’t see or get, the same results trying to burn the bootloader.
At this point I may have trashed (not damaged) the pre loaded fw code by trying.

This is where an experienced, patient, mentor, would be appreciated to walk us challenged but motivated diy’ers thru the process in more detail.
I hope MikeB is reading this as he’s been my savior all these years.
I’ve learned so much and when I can, pass it on.
Anyone however, is welcome to join in and share their knowledge (João).








Sent from my iPhone using Tapatalk Pro


User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Wed Jan 17, 2018 6:47 pm

I just followed the instructions on the Github page and the bootloader flashed fine. Just the 6 steps to follow:

1. Install the BOOT0 jumper as described above
2. Switch on the transmitter
3. Verify that you have selected the desired upload method under Tools -> Upload Method
4. Verify that you have selected stm32flash (FTDI) as the programmer under Tools -> Programmer
5. Verify that the USB-to-TTL adapter is correctly connected to your module and you have selected the correct port under Tools -> Port
6. Click on Tools -> Burn Bootloader

You did not mention you did item 1, needed to get the STM processor to run the internal, ROM based DFU loader.
I missed item 4 the first time I just tried it!
When you connect the USB-to-TTL adapter, make sure you cross over Tx to Rx and Rx to Tx.

I've been using a STM provided PC program that flashes code, so I hadn't used the Arduino IDE for the bootloader before.

For information, I'm working on a single bootloader that will do both the USB flashing and "Flash from Tx" methods. The "Flash from Tx" bit is working, but as my STM module doesn't have the USB connection (0.8 rev board), this part is being tested by others.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Wed Jan 17, 2018 7:29 pm

Thank thank you Mike for helping me sort this out.
It’s difficult finding anyone to work on these projects locally, believe me I try that first.
I seem to be the go to person and as we know, I struggle with it but learn a lot.
I have no idea why it shouldn’t go as planned?
I’ll take time and try again if my 4in1 is still ok.
All flashing was done without the vcc from the ftdi connected and in a 9xr pro( same used for the orange multi flashing), or my Qx7 for power.
I understand that tx to rx, rx to tx, and ground is the correct connections from ftdi to the 4in1 and I’ve done that.
Where I get into trouble is I see my 4in1 and ftdi (com2) as a choice in IDE drop down, and I have the stm32 multi sketch loaded as well as anything else the GitHub page says to, but when I select burn bootloader, I get read text in ide showing s link yo s google site?
I believe red means it failed?
I’ll go they the steps again and grab screen shots as I go.
One question is I see a bootloader folder in the multi .ino I downloaded. They are .bin files. Do I somehow select them or does the burn bootloader find the correct one and load it?
If I haven’t trashed this module form flashing attempts, it should be reprogrammable still.
I do have s new 4in1 I believe is a stm32 version that works with ersky9x and opentx via the multi menu, no knob.
I’m open to trying it as a second learning option.

Maybe something simple to verify I’m doing it correctly but put it back to Stock if it survives.
When you walked me thru the orange multi you had me use Arduino IDE and flash a bootloader into a mini pro from a sketch. I’ve never used the bootloader option in IDE to see what should happen.
As for you simplifying this whole process, I’m on board.
Such that I’m will to finance a new 4in1 plus module for you to work with!
Just pm me if you decide.




Sent from my iPhone using Tapatalk Pro

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Wed Jan 17, 2018 9:19 pm

yes I have the boot0 jumper on.
Will this help?
The full error message (W7) I receive in red when I select bootloader is this;

c:users\my computer\app data\local\arduino15\packages\multi 4in1\hardware\stm32F1 1.0.3\bootloaders\(bootloader file): No Such File or Directory

"my computer" I changed the name for this post.

The bootloader files I can see is in in the zip file I downloaded from the posted link and extracted are both .Bin?
Zip file was from github link on this page.
https://github.com/pascallanger/DIY-Mul ... g_STM32.md

" Download the Multiprotocol source and open the project
1.Either ,Download the zip file with the Multiprotocol module source code from here and unzip and copy the source code folder Multiprotocol to a location of your choosing."

It would seem the arduino Bootloader is looking for a file location or file it cant find. I saved my arduino pgm and stm multi in my downloads folder btw.
if I can get the bootloader to find the file it's looking for, this may solve it?
Attachments
bootloader 2.jpg
looks correct?

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Wed Jan 17, 2018 10:13 pm

You currently have the Upload method as "Upload via Serial(FTDI)". This uses the ROM based DFU loader, so means no bootloader is selected.
Try selecting the Upload method as "Upload via USB", then try flashing the bootloader.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Thu Jan 18, 2018 12:45 am

That seems to have worked, I swear the videos never showed that selected but makes sense being the ftdi is usb. Great catch Mike. One down.
I then via the usb connector tried to flash my ch config with TAER. Boot0 jumper off, Radio off.
I did see a reference to dfu mode and com 15.
Still with “upload via usb selected” I tried a upload of the multi sketch.
I had the original _config.h replaced in the multi folder with the one I edited with TAER as the ch order on line 43.
It seemed to go ok but I can’t bind to a dsmx receiver now in position ppm 6.
I can’t get a green led mode either?
I’m using the Multiprotocol.ini and if I’m correct, it calls up the _config.h file that has the original ch order in it.
I’ve restored that original file but doing a flash still doesn’t allow me to bind?
I do see a error message:
Resetting after download:usb_reset: could not reset device, win error: the system could not find the file specified.

I can do a “get board info”read that says 4in1.


The module does light up a red led now that starts rapidly flashing and then goes solid red.
Trying a bind at power on, button pushed, it does the same thing.
I could try a flag from the 9xr pro and it’s sd card with a little advice.
If I can restore it to working again to verify nothings damaged, then maybe I can work backwards to use the USB port and change the ch order again.
Is there anyway to read the fw or download it to see what’s actually there?
I hope I’m getting closer and fir sure I’m making notes on this.
This is a camera shot of what I see before trying a sketch upload.
Tomorrow I guess. You should be sleeping now.
Image



Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Thu Jan 18, 2018 1:24 pm

Have you installed the "Maple USB" drivers?
I shall have some trouble helping as I don't have a USB connection on my module, so can't test this method and check any settings/drivers needed.

It looks like I do now have a "universal" bootloader working that does both the USB flashing and the "flash from Tx" methods.

I use a program from STM to access the ROM DFU bootloader, downloadable from here: http://www.st.com/en/development-tools/ ... stm32.html.

This would let you read the entire flash memory to see what is in it. You can also flash firmware to the processor.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18890
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: IRangeX 4in1 Plus fw flashing.

Post by jhsa » Thu Jan 18, 2018 1:30 pm

This is the program I normally use to flash the STM32 chips that I am using on other projects..

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Thu Jan 18, 2018 4:09 pm

Thanks guys for your help. Yes Mike a did load the maple drivers and when I plug in the usb I see Maple DFU show up in on my Windows lower right corner as loading.
For now I’m open to using any means that lets me load a working multi fw again. Knowing I’ve only done fw damage and no actual hardware damage will be comforting. I’ve been very careful about not connecting vcc lines from the ftdi, only using the 9xr pro for module power, and also not being a connector pin off that happened to one orange module, R.I.P.
I’m open for now, to either usb, ftdi, or flash from my 9xr pro with what ever latest ersky9x fw if I need it.
I have to check but I’m still running the ersky9x version you had me load to flash the orange modules if that’s ok.
One thought is because I couldn’t read the original 4in1 + fw, is it possible the GitHub version of the multi doesn’t support this new module? It does have the ppm switch and serial option unlike the version before it that’s serial only.
Maybe you can look at the Multiprotocol fw and tell if it supports it.
I’ll do the same but I’m a work in progress.

I’ll install the program you’re recommending and hopefully can see what’s loaded in the module now.

Also, is there a way to verify I have a bootloader installed now? Seeing the Maple DFU message and the module showing up now may say yes?
That didn’t happen before the flash.
If so, then the Boot0 jumper I removed after the bootloader flash attempt isn’t used again unless I attempt another bootloader flash attempt?








Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Thu Jan 18, 2018 4:33 pm

If I'm reading you correctly, you have the 16-way dial at position 6?
If you have ersky9x running, then you want position 0 (serial), then set the protocol to "Multi".
I reckon you do have a bootloader installed.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Thu Jan 18, 2018 5:53 pm

[attachment=0]Maple Com15
this is interesting? Yes, with the yellow know at 12:00 and the module in my 9xr pro v -pe3r221, I'm able to bind to a orange dsmx receiver, yea! However, I can't in opentx2.2 on my Qx7 that does bind if I use the serial only version of the 4in1, no yellow knob?
I also can no longer on the 4in1+, select ppm via the yellow knob? Pushing the bind button at power on in position ) did allow me to select ppm or serial as well as the first maybe 20 options and then the rest in ppm?
It would seem it's working but not at delivered. Is it possible this version 4in1 fw isn't up to date for this module and selector sw?

I downloaded the pgm in the link. It doesn't see the module via the usb connection. it's showing up in device manager as maple com15.
to use the flash loader pgm in the link do I want to use the ftdi adapter?

so progress in the fact that it's working and not damaged. Setback is it's not working as designed but does work in my pro. The serial only version works in either tx running the different os?

The yellow knob does select serial in ) but I can no longer select ppv vs serial, always serial now.

Question to consider, wrong multi fw for this module has been flased into it?
The demo pgm can't see the module via usb, should I try ftdi instead?
Attachments
Maple Com15.png

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Thu Jan 18, 2018 10:32 pm

openTx needs to be built with "multimodule" ticked in the settings to use serial to the module.

To use the "Flash Loader Demonstrator", you need to do the same as when you flashed the bootloader, i.e. fit the Boot0 link and connect the FTDI to the 4-pin header.

The USB bootloader appears as "Maple DFU". When the main Multi firmware is running, then you get the "Maple Serial".

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Jyester
Posts: 31
Joined: Wed Nov 12, 2014 11:04 pm
Country: -

Re: RE: IRangeX 4in1 Plus fw flashing.

Post by Jyester » Thu Jan 18, 2018 11:15 pm

ShowMaster wrote:I hope to in more detail, discuss how to flash a bootloader and new fw, as well as how to modify the code for changing channel order and any other defaults that may be required.
The latest plus version 4in1 (stm32) supports ppm or serial ( serial allows menu control with ersky9x or opentx).
It’s fw can be updated via the onboard usb connector or via the latest ersky9x fw.

This statement needs to be clarified/updated by anyone that is more informed. MikeB being one I hope will come on board.

The 4in1 is shipped without a loaded bootloader to support flashing using the onboard USB port or a tx running ersky9x(9xR pro).

So first step is to successfully load a bootloader.
There is a GitHub dedicated to these steps as well as several YouTube videos.
GitHub
https://github.com/pascallanger/DIY-Mul ... g_STM32.md

YouTube
This one is in German but has subtitles and seems to cover the plus version 4in1 directly.
https://youtu.be/qKsoTQQfy_4.

The requirement to flash the bootloader for usb from what I have gathered are

HARDWARE
Read the GitHub page on the sym32 flashing.
Have a usb FTDI programmer.

Have a 9xR pro with the latest ersky9x or a Frsky X9D or plus or Qx7 with the latest otx2.2.x or I believe ersky9x 9x loaded.

3ea female to female programming jumpers.

Install in the 4in1 the required male header pins needed for connecting the FTDI programmer.

SOFTWARE
latest Arduino IDE program
Notepad++
Multiprotocol .ino from the GitHub page.

https://github.com/pascallanger/DIY-Mul ... g_STM32.md

Anything linked to on the GitHub page.

To view the code or modify it in the _config.h file, I found useful a free pgm called Notepad++ for windows allows me to read the hidden comments and make changes.

With all this, I haven’t been successful in programming the bootloader as these exact steps are for me, not detailed enough? Try as I have with what I believe are the exact hardware, software, and step by step, I don’t see or get, the same results trying to burn the bootloader.
At this point I may have trashed (not damaged) the pre loaded fw code by trying.

This is where an experienced, patient, mentor, would be appreciated to walk us challenged but motivated diy’ers thru the process in more detail.
I hope MikeB is reading this as he’s been my savior all these years.
I’ve learned so much and when I can, pass it on.
Anyone however, is welcome to join in and share their knowledge (João).








Sent from my iPhone using Tapatalk Pro
What Tx Qx7? I didn't flash the module, i flashed the Tx it's self. I believe the module already has the proper protocols already, but don't quote me on this! I simply put my Qx7 into bootloader mode before i plug it in via usb port. Once in BL mode, if you haven't already downloaded the updated FW to Opentx do that. Once its in Opentx it will ask you if you want to flash the new firmware, Yes! Thats all i did!! My module works great except for spektrum gear. I like the Tiny whoop but for some reason i keeps telling me, the Tx, rssi low!! It may very well be the module but im not going to try and flash it if its not a direct plug in situation. I don't know about the 9xr or the pro i have one but can't seem to flash it!! I may not have the right drivers or im doing something wrong!! Let us know how things work out, MikeB is the man for problem solving. I have gotten help from hope im not butchering his handle Jao. You mentioned him also im just bad with names.

Sent from my SM-G925V using Tapatalk


User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Thu Jan 18, 2018 11:34 pm

For the 9XR-PRO, power on holding the horizontal trims apart towards each other and it should start in bootloader mode. Then plug in the USB cable and you should see two hard drives appear on the computer. Make sure you plug the USB cable in fully, it can take quite a hard push t get it to plug in fully (with a click).
Once you have the two drives visible, run eepskye and you should be able to flash new firmware.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18890
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: IRangeX 4in1 Plus fw flashing.

Post by jhsa » Fri Jan 19, 2018 12:29 am

MikeB wrote:
Thu Jan 18, 2018 11:34 pm
For the 9XR-PRO, power on holding the horizontal trims apart and it should start in bootloader mode.
Mike, I believe you meant to say "For the 9XR-PRO, power on holding the horizontal trims INWARDS and it should start in bootloader mode".

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Fri Jan 19, 2018 5:36 am

What’s going on is I have been using this module in my x9d plus and Qx7 and the latest multi otx 2.2fw.
Same for my 9xr pro with ersky9x multi fw.
No issues.
Yes I can change the ch order in either tx to match the ch order I need to fly my umx Pitts without issues.
Same for the HK orange module after updating it with Mikes multi fw that fixes the umx receiver issue.
All using the serial interface not ppm.
The no dial version.
Image

I also have a 1980’s vintage pcm10 that can support a module using ppm.

Seeing the latest 4in1 module that can support ppm or serial, and based on the serial only module supporting my umx Pitts, I thought I’d try it in my pcm10.

Dial version 4in1

Image
What I found is the TAER hard coded pcm10 ppm out is the wrong ch order for the umx Pitts.
So what seemed a simple fix was to edit the 4in1+ as it’s called fw, would be easy.
GitHub and videos seemed to show the fw was available as Multiprotocol.

I then found out no bootloader is supplied on the modules.
So with Mikes help, I seem to have loaded a bootloader. Then using what is supposed to be the correct GitHub multi fw, I attempted a flash.
It seemed to go ok.
However, now it works only in serial mode and I can’t force it into the ppm mode anymore. Also it only works in the 9xr pro with ersky9x.
The dial must be in the 12:00 position as Mike suggested so the dial is doing something?

Now the questions I’m trying to answer.
Is the GitHub multi fw actually the correct one for the dial serial/ppm dial latest version module?
Why now is it locked in the serial mode and stranger yet, why only in the 9xr pro, but the non dial serial only (no knob) version works in the pro and Qx7.
This is more of a learning situation now as I have 2 serial versions that work great in my Taranis or pro tx’s.
I also have thanks to Mike fw and guidance, several orange modules that I can use for Spektrum stuff.
I’m in no way setback from flying anything while I sort this out.


So next I’m trying Mikes suggestions on reading back the fw I loaded. Also determining the multi fw I loaded is correct for the ppm/serial dial module.
I had to take a break and will try it fresh tomorrow.










Sent from my iPhone using Tapatalk Pro

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Fri Jan 19, 2018 7:57 am

Looking at the _comfig.h file in the Multiprotocol folder, with notepad++ I do see the reference to ppm as well as the dial position protocols.
That I’m thinking should be good to go.
I’m still going to try and download the fw I flashed from the module to look at it, but I think I’ll try a flash from the 9xr pro SD card next.

This is a question I can use help with.
The flash from tx steps one GitHub says to load the Multiprotocol.ino into Arduino IDE and export multi as a .bin file for the SD card firmware folder. So what about the _config.h file? I’m assuming it should be in the sd card firmware folder as well?
I’m guessing on the sd folder name as I type this away from my tx and computer.

Midnight here so time to rest.

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Fri Jan 19, 2018 1:20 pm

The "_config.h" file is only used when compiling the firmware, so it doesn't need to be on the SD card.
Currently, there are two possible bootloaders, one allows USB flashing and the other allows "Flash from Tx". I've just finished combining these into a single "universal" bootloader that does both! I've just published the source files on Github, but still need to do a "release" so the built binary file is available directly.
So if you flashed the USB bootloader, the module won't flash from the Tx.

In any case, edit _config.h so that the following are NOT commented:
#define CHECK_FOR_BOOTLOADER
#define INVERT_TELEMETRY
#define MULTI_STATUS
#define ENABLE_SERIAL
#define ENABLE_PPM

Then do the "Export" operation in the Arduino IDE.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Fri Jan 19, 2018 3:38 pm

Thanks Mike.
I’m sure you’re help in streamlining this whole operation is going to be appreciated as more give this a try.



Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Fri Jan 19, 2018 3:52 pm

I've just done a "release" of the bootloader binary, so anyone who whishes to try it is welcome to do so!

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Sat Jan 20, 2018 7:33 am

I’m ready. To be sure, could you please provide the link and any instructions you think would help to avoid messing it up.
Couldn’t spend any time on it today, but will have in about 9hrs from now.
I’d like to try a multi fw flash from the 9xr pro.



Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Sat Jan 20, 2018 9:44 am

Bootloader release is here: https://github.com/MikeBland/StmDualBoot/releases.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Sat Jan 20, 2018 4:22 pm

Ok, sleep didn't help. One more time ( I/we hope) how do I flash your latest M4in1.bin into the 4in1 module?
I'm hoping if this works to just use the Pro tx for fw updating. Arduino.ide and notepad++ to edit and compile and export the file, the Pro to flash it. Your dual bootloader however would allow the use of the usb connector so even better?
I also have Flash Loader Demo loaded onto my w7 computer.

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Sat Jan 20, 2018 5:00 pm

Fit the Boot0 link and connect the FTDI to the 4-pin header as before. Then use the Flash Loader Demo.
My settings are:
Port Name (Your FTDI COM port).
Baud Rate 115200
Data bits 8
Parity Even
Echo disabled
Timeout(s) 10

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Sat Jan 20, 2018 9:19 pm

Got closer?
Using flash loader demo and selecting the .bin file option, I was able to see and load your latest boot fw. I was missing the selecting file type before, so simple now that I did it.
I also verified that the lines were NOT commented out as suggested in the _config.h multi file.
I then loaded the multi.ino into Arduino and did a compile selecting flash from tx as a ,bin file. I found that file saved in the Multi bootloader folder.
I loaded it onto my Pro sd card firmware folder. With lower trims pushed outwards I got into the Maintencance mode and selected "update Multi" then update file type Bin. thaen selected the Multi-stm-1.2.0 12.bin file and hit enter and on the next screen "update Multi" I hit enter> The flashing bar came on but then it said FAILED 0000 0000. I tried it again with the same results.

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Sat Jan 20, 2018 10:08 pm

On the 'PRO, change the Invert "Com Port" option to "Yes".

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Sat Jan 20, 2018 11:02 pm

Changing to invert comm to yes flashed ok but...
I can’t bind in pos 0 or seem to put the module in a ppm or serial mode via the rear button at turn on as it was designed to do.
I may still have messed up the multi fw build?
I’ll go thru the steps again.
At lest this time I see the green led lite up as well as the red, just not as should be.
What may be the good news it the flash from tx bootloader is loaded.

I tried a flash from usb via the IDE pgm but no luck.
The maple drivers are loaded but I see as a maple dfu I think.
I’ll go thru the compile to .bin steps again via the pro sd card and not mess with the bootloader for now since I think it’s working on the pro.

I tried earlier to try via flash loader demo to download a readable file from the module I could read with IDE or note pad ++ but no luck. Obviously I’m out of my knowledge zone but rack attempt (with your help) is getting closer it seems.
Making notes of your answers to my issues as we go.

Tomorrow if you can



Sent from my iPhone using Tapatalk Pro

User avatar
jhsa
Posts: 18890
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: IRangeX 4in1 Plus fw flashing.

Post by jhsa » Sat Jan 20, 2018 11:49 pm

Nearly at the beginning of the "config.h" file, there is an option called (or similar) "#define CHECK FOR BOOTLOADER" make sure it is not commented, meaning that it is NOT like this:
//#define CHECK FOR BOOTLOADER

Remove the two "//" at the befinning.

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: IRangeX 4in1 Plus fw flashing.

Post by ShowMaster » Sun Jan 21, 2018 7:07 am

Thanks, I did that in the _config.h file before compiling the Multiprotocol.ino in the IDE pgm.
My concern is that since no one else actually reprogramming this new 4in1 plus module that’s posted success, bootloader included, maybe something’s different?
Is should be so easy I know.
Install the stm32 board file into IDE.
Load in a usb or flash from tx bootloader with a FTDI board using flash loader demo (recommended). Then via Arduino IDE, and the the stm32 Multiprotocol.zip file contents, compile the multiprotocol.ino making any changes in the _config.h file first.
One bring the # files changes Mike and you have listed.
If all of this seems like I’m on track, I’ll give it a fresh start and try it all again.

Mike says I can download via flash loader demo the contents of the module now (boot0 jumper on).
I tried that Mike and it did download but but not in a file type I can read like I see in Notepad ++.
Yes, I must be doing things wrong but if everyone can hang in there, I’ll keep trying.
Hopefully you can “teach stupid” after all.







Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: IRangeX 4in1 Plus fw flashing.

Post by MikeB » Sun Jan 21, 2018 11:30 am

What file type did you get when you read the contents? I think the flash loader gives you an option for the file type, S19 is a form of hex file that should be readable.
Put whatever file you did manage to read in a zip file and post it here please, I can look at most files to see what is in them. You might include your _config.h file in the zip.

With the module in the 'PRO, what is the LED doing?
On the protocol menu, do you see the module revision beside the "BIND" option?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “The Pickled Gnu (The Pub)”