OpenTX - Nightly builds for pre-2.0 testing

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by bertrand35 » Fri May 16, 2014 9:18 pm

Good question, I need tol readd the 'One' trigger. Please open an issue so that I don't forget it!


ssatoru
Posts: 4
Joined: Fri Oct 04, 2013 2:40 pm
Country: Japan
Location: Chiba

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by ssatoru » Fri May 16, 2014 11:12 pm

Thanks! I opened an issue.

Satoru

User avatar
Scott Page
Posts: 864
Joined: Wed Dec 28, 2011 3:32 am
Country: United States
Location: Tri-Cities, Washington State

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by Scott Page » Sat May 17, 2014 12:34 am

ssatoru wrote:Question on 2.0 . How I can do the same as 'ONE' in Special Function to trigger once when model is loaded or radio is powered on? I have used it to initialize GVAR which was used as a counter.

Thanks.

Satoru
ON will accomplish the same thing.

User avatar
MicheleVilla
Posts: 66
Joined: Thu Apr 10, 2014 4:13 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by MicheleVilla » Sat May 17, 2014 7:18 am

Hi to all
OpenTx 2.0 last Night Build (16/05/14)
I have associate a 3-position switch to three phases of flight and I created three wav files Phase1-ON.wav, Phase2-ON.wav, Phase3-ON.wav.
Changing rapidly position the switch to the radio stores all the changes and plays messages as many times as they were on the move
Is possible to add a little delay and play only the last position?

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by bertrand35 » Sat May 17, 2014 7:56 am

Another enhancement issue is needed!


User avatar
MicheleVilla
Posts: 66
Joined: Thu Apr 10, 2014 4:13 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by MicheleVilla » Sat May 17, 2014 8:22 am

Open an Issue in Git?
Ok
thank You

User avatar
Scott Page
Posts: 864
Joined: Wed Dec 28, 2011 3:32 am
Country: United States
Location: Tri-Cities, Washington State

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by Scott Page » Sat May 17, 2014 8:36 am

No nightly build for 5/17?

User avatar
MicheleVilla
Posts: 66
Joined: Thu Apr 10, 2014 4:13 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by MicheleVilla » Sat May 17, 2014 8:52 am

Another question about variometer

setting
pitch at 0 700Hz
pitch at max 1700 hz
means that at 0 change sound run continuosly at 700 Hz
But at 0 change should not remain silent?

mstrens
Posts: 1434
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by mstrens » Sat May 17, 2014 12:03 pm

MicheleVilla wrote:Another question about variometer

setting
pitch at 0 700Hz
pitch at max 1700 hz
means that at 0 change sound run continuosly at 700 Hz
But at 0 change should not remain silent?
You can find more explanations about new vario sounds on this link
viewtopic.php?f=86&t=5081

You will see that per default there is no dead zone anymore (zone with no tone).
The 4 parameters in telemetry panel are used to define 3 ranges of VSpd, each having a different kind of tone. ge
If you want to mute the vario for some range of VSpd you must define customs switches based on VSpd.
This is more flexible (but a little more complex)

pberki
Posts: 2
Joined: Mon May 05, 2014 9:02 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by pberki » Sat May 17, 2014 2:49 pm

Hi,
Is there any key combination or any other way to lock the buttons so, they don't get pressed accidently while flying please ?
Thank you.
Peter

User avatar
MicheleVilla
Posts: 66
Joined: Thu Apr 10, 2014 4:13 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by MicheleVilla » Sat May 17, 2014 3:15 pm

Ok thank you for information
I agree that it's a little more complicated(but more flexible)

I try to play with it

janlebelg
Posts: 12
Joined: Sat May 17, 2014 4:33 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by janlebelg » Sat May 17, 2014 4:48 pm

i have the sbus sensors it works fine but can not show -cell ans -cels on the screen it is always 0V
the power and +power is ok cell and cells are ok to wath dit i mis or is it a issuw an i report it on the nightly builds

i have the soft an bin of 16 05 2014
thanks

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by bertrand35 » Sat May 17, 2014 5:33 pm

Cell- and Cells- always 0, are you sure? If yes, please open a new issue for that so I don't forget, I will have a look next week.

User avatar
MicheleVilla
Posts: 66
Joined: Thu Apr 10, 2014 4:13 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by MicheleVilla » Sat May 17, 2014 8:47 pm

@Bertrand
About Issue 1111
Now is closed and I have send my last answer too late
This issue happens only whit converted memory from 215 to 216
With new model all is ok
Please may you check That?

EDIT:

Before LONG press <] must enable every switch you want to set
Now in this way all is Ok
Last edited by MicheleVilla on Sun May 18, 2014 8:44 am, edited 1 time in total.

janlebelg
Posts: 12
Joined: Sat May 17, 2014 4:33 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by janlebelg » Sat May 17, 2014 9:36 pm

Ok i make a new model

i made update every week
And today have also mixes and telemetry changes after it
Mixes that dont work and telemetry are replased by others

so i gona make a general test tomorow and poste the news

janlebelg
Posts: 12
Joined: Sat May 17, 2014 4:33 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by janlebelg » Sun May 18, 2014 9:56 am

I updated today and all mixes or ok like before but there is non thelemetry on x6d an d4r taranis says no data

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by davx » Sun May 18, 2014 4:13 pm

Hi,

I just came back from my flight session with a Taranis and OpenTX for the first time, I must say I'm really impressed with this combo, thanks for the open source team !!

A little problem however, I was flying in crazy thermals and the flight chrono remained blocked on 1:16:40s. I know it's already a big value but my glider didn't want to land even after numerous loops and barrels ;)

My firmware is the r2940 and I was wondering if you could extend the chronos duration somewhat in OpenTX 2 ?
Do I open an enhancement issue on github ?

Thanks again !

User avatar
Scott Page
Posts: 864
Joined: Wed Dec 28, 2011 3:32 am
Country: United States
Location: Tri-Cities, Washington State

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by Scott Page » Sun May 18, 2014 5:40 pm

janlebelg wrote:I updated today and all mixes or ok like before but there is non thelemetry on x6d an d4r taranis says no data
You updated from which build date to which build date?

wilco1967
Posts: 33
Joined: Tue Dec 27, 2011 8:20 pm
Country: -
Location: Winterswijk

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by wilco1967 » Sun May 18, 2014 6:35 pm

Scott Page wrote:
janlebelg wrote:I updated today and all mixes or ok like before but there is non thelemetry on x6d an d4r taranis says no data
You updated from which build date to which build date?
I noticed the same.

The nightly build from 18-may shows 'no-data' on telemetry pages, and all telemetry data remains 0. RC control works just fine, just no telemetry.
Went back to version from 16 may , which is OK.... (17 may does not seem to exist).

User avatar
dinamich
Posts: 288
Joined: Mon Apr 01, 2013 1:21 pm
Country: Slovenia
Location: Ljubljana

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by dinamich » Sun May 18, 2014 6:41 pm

Betrand did rework telemetry on 16.5 at 4pm so this changes are not in may-16 nightly, but are in may-18. This could be the cause.

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by bertrand35 » Sun May 18, 2014 6:54 pm

It seems I broke something in my refactoring, I delete the build of may 18.

EDIT: No it's just stupid, the S.PORT is now enabled by a compile option and I forgot to include it in nightly builds. It should be ok tomorrow morning.

User avatar
dinamich
Posts: 288
Joined: Mon Apr 01, 2013 1:21 pm
Country: Slovenia
Location: Ljubljana

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by dinamich » Sun May 18, 2014 6:57 pm

davx wrote:Hi,

I just came back from my flight session with a Taranis and OpenTX for the first time, I must say I'm really impressed with this combo, thanks for the open source team !!

A little problem however, I was flying in crazy thermals and the flight chrono remained blocked on 1:16:40s. I know it's already a big value but my glider didn't want to land even after numerous loops and barrels ;)

My firmware is the r2940 and I was wondering if you could extend the chronos duration somewhat in OpenTX 2 ?
Do I open an enhancement issue on github ?

Thanks again !
I will run a test for this. I have checked the code and timer is big enough uint16 which means 65535 seconds = more than 18 hours.

Are you sure you didn't cause a timer stop yourself?

janlebelg
Posts: 12
Joined: Sat May 17, 2014 4:33 pm
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by janlebelg » Sun May 18, 2014 8:17 pm

hi putted the version of 15 05 in the taranis and went flying
everyting went "well" only i putted a new battery nannothech in my easy glider and when i was at 100m high
it went stead down to the eart an esplodes my glider 3 sensor an the x6d

It was the connector hxt 60 that was not soldert in factorry the scrinking held it togeter

so i am sorry but wil not be abel to test currend an votige for a will only have alti sensors left

I can confirm open TX dit not scratch my glider ;)
regards

User avatar
jhsa
Posts: 19403
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by jhsa » Sun May 18, 2014 8:57 pm

Sorry to read this.. It's not nice.. Difficult to find this kind of problem.. Most of the times when you find it, it is to late..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by davx » Sun May 18, 2014 9:47 pm

dinamich wrote: I will run a test for this. I have checked the code and timer is big enough uint16 which means 65535 seconds = more than 18 hours.

Are you sure you didn't cause a timer stop yourself?
I've read your answer and after some thoughts ( :roll: ), I had a doubt. It's a new setup and I'm also using my chrono switch to reset a counter, so to make the story short, I've just run a test and the chrono didn't stop at 1:17:40... It quietly continued to count :?

Thanks for taking the time ;)

Tchao

oiseau
Posts: 25
Joined: Tue Jun 05, 2012 1:15 am
Country: -

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by oiseau » Mon May 19, 2014 4:19 pm

bertrand35 wrote:
oiseau wrote:Hey guys, I upgraded to nightly and I'm enjoying the new changes :)

The only thing I've noticed is I can't get my custom sounds to show up in the Special Functions -> Play Track selection menu, only the default ones are there. I could get them in the old openTX, and I can still see them and play them in the file browser in the "long hold menu" screen.

Is this a known issue or some setting that I missed? Thanks!
Names too long? Now the maximum is 8 chars (compromise to allow 64 functions ...)

Yep, looks like that was it :)

Another question, what's the difference between Taranis and Taranis Plus targets? should I choose Taranis Plus if I have the upgrade parts?

Also, anything I need to know to get vibration working? I bought the addon from Aloft and installed it per instructions, and get nothing. May 5 and today's nightly versions tried.

edit never mind, had version A taranis but no way to tell without a scope... vibration motor sure is weak

User avatar
dinamich
Posts: 288
Joined: Mon Apr 01, 2013 1:21 pm
Country: Slovenia
Location: Ljubljana

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by dinamich » Mon May 19, 2014 6:50 pm

oiseau wrote: Another question, what's the difference between Taranis and Taranis Plus targets? should I choose Taranis Plus if I have the upgrade parts?
Taranis Plus has some changes in wiring, so stick with Taranis image, even with haptic upgrade.

User avatar
azure93
Posts: 9
Joined: Mon May 19, 2014 4:43 am
Country: Korea, Republic of
Location: Jeonju

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by azure93 » Tue May 20, 2014 12:12 am

Hello all !! I'm very thanks for all OpenTX members for this great job.

This is just one bug reporting for 2014.05.19 version.

Please refer SF11 & SF14 lines for all screens. It made in companion and running simulator & export to taranis.

As I assume, Inverted logic switch name are shifted in simulator & radio firmware.


PS ) Could somebody show lua function examples for model.getLogicalSwitch() & model.setCustomFunction() ?

I want make background music jukebox with lua script. ;)
Attachments
taranis.png
taranis function.
simul.png
simulation in companion
simul.png (2.33 KiB) Viewed 5193 times
companion.PNG
companion function.
Free! For Endless World.

User avatar
Scott Page
Posts: 864
Joined: Wed Dec 28, 2011 3:32 am
Country: United States
Location: Tri-Cities, Washington State

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by Scott Page » Tue May 20, 2014 2:41 am

azure93 wrote:Hello all !! I'm very thanks for all OpenTX members for this great job.

This is just one bug reporting for 2014.05.19 version.

Please refer SF11 & SF14 lines for all screens. It made in companion and running simulator & export to taranis.
So simplify your report - in SF11 both the transmitter and simulator show !L7 but Companion shows !L6

In SF14 both the transmitter and simulator show !L12 but Companion shows !L11.

rdeanchurch
Posts: 706
Joined: Tue Dec 27, 2011 11:22 pm
Country: United States
Location: Carson City, Nv

Re: OpenTX - Nightly builds for pre-2.0 testing

Post by rdeanchurch » Tue May 20, 2014 3:43 am

I believe this is reported and fixed in
https://github.com/opentx/opentx/issues ... ate=closed
!lxx shifted by one.
Dean
OldDmbThms: 1. Takeoff, 2. Crash, 3. Repair, GOTO 1


Post Reply

Return to “openTx”