Voice on open9x / stock board

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
gbirkus
Posts: 97
Joined: Sat Jan 07, 2012 4:15 pm
Country: -

Re: Voice on open9x / stock board

Post by gbirkus » Mon Aug 13, 2012 8:58 pm

Martin, Thank you for help and warnings.
Gabriel.


User avatar
janekx
Posts: 82
Joined: Thu Aug 09, 2012 4:08 pm
Country: -
Location: Czech Republic

Re: Voice on open9x / stock board

Post by janekx » Mon Aug 20, 2012 12:35 pm

Hi, where can I find r1209 to use Czech files Companion and binaries on pages sau 1195 only and I today finished voice modul and find that not play well with 1209 files

thanks

User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Mon Aug 20, 2012 1:12 pm

Try these
pcm8.zip
(632.68 KiB) Downloaded 121 times
, but it is not perfect. There is lot of changes in svn regarding sound, better to wait for new release.

EDIT: these sounds are for r1195, Czech language version, there are no system sounds, no correct grammar and fault decimal point numbers.
All will be fixed in new release.

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Mon Aug 20, 2012 3:55 pm

Martin, don't you use the tts.py script to automatically generate the prompts? I have seen you have changed custom prompts to 256 instead of 260, I will update the script for them.
Bertrand.

User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Mon Aug 20, 2012 4:19 pm

Thanks Bertrand, there are no Czech prompts inside tts.py yet. I will have to look at it.


User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Mon Aug 20, 2012 5:19 pm

I cannot realise how to use tts.py
I would like to generate english prompts with espeak on linux. How can I do that?
Can someone help with tts.py parametters?

Romolo
9x Developer
Posts: 1109
Joined: Sat Dec 31, 2011 12:11 am
Country: -
Location: Massa (MS), Tuscany, Italy

Re: Voice on open9x / stock board

Post by Romolo » Mon Aug 20, 2012 6:07 pm

you need espeak and mbrola voices
then: python tty.py espeak en zip

in mbrola you can install czech voices too

User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Mon Aug 20, 2012 6:16 pm

It works,
Thanks Romolo.

User avatar
janekx
Posts: 82
Joined: Thu Aug 09, 2012 4:08 pm
Country: -
Location: Czech Republic

Re: Voice on open9x / stock board

Post by janekx » Mon Aug 20, 2012 8:05 pm

Thanks for voices but my module died now after a 20s and only silently crackle.

Odeslano pomoci Tapatalk, Samsung mobile

User avatar
thomas9x
Posts: 230
Joined: Wed Feb 29, 2012 3:12 am
Country: -
Location: USA

Re: Voice on open9x / stock board

Post by thomas9x » Tue Aug 28, 2012 3:56 pm

I received my customized Voice Interface PCB yesterday (with LM386 Amp) and worked on the solution to the audio click noise that had been reported. For my testing I'm using MikeB's ER9X voice software.

Finally having a working audio board, I must say the reported click noise was not as bad as I imagined. It is just a very faint click at the start and end of each voice transmission. If you guys hadn't mention the noise I don't think I would have paid any attention to it. But perhaps some LM386 installations have it worse than mine.

The solution for removing the click noise is to use a audio transformer to convert the MP3 module's differentially driven audio output to a single ended signal for the LM386. I used a Mouser #42TL016-RC 600:600 Audio Xfmr and connected its secondary to the MP3's speaker output (pins 11 & 12). The SPK+ side will require a 10uF non-polarized electrolytic cap (Mouser #647-UVP1C100MDD) in series with the Xfmr connection. The Xfmr's primary side is now click free for use with your LM386 circuit.

I also tried out a MOSFET muting circuit that was also available on the new PCB layout. It would have been more elegant than the transformer. The MOSFET was controlled by the MP3's BUSY signal. It eliminated the click noise, but there was a very brief period of clocking noise that could be faintly heard before the start of each voice transmission. So this cool trick was a fail.

You can get a sense of the Audio Xfmr's size in the following photo of the new Voice Interface PCB. The Xfmr is upside down (under the little daughter PCB), next to the blk/red/wht/yel cable.
voice_pcb1_750.jpg
Photo of Voice Interface PCB with transformer.
By the way, everything works on the new board. It has Piezo tones through the speaker, Haptic motor control, LED backlight control with 20mA constant current, and a LM386 amplifier for extra loud audio. Best of all it fits in the tight space that was chosen for the install. So I am a happy guy.

I'm officially ready for the voice version of Open9X. Can't wait for it to be released!

- Thomas

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Tue Aug 28, 2012 4:55 pm

Tomorrow if everything goes well :)
Bertrand.

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Tue Aug 28, 2012 6:27 pm

Hi thomas,
nice job on the Sound board. Are you going to make them available for sale?. Havnt quite got onto building your Hub/Gps module yet,have all the parts now.
Thanks
Les

User avatar
thomas9x
Posts: 230
Joined: Wed Feb 29, 2012 3:12 am
Country: -
Location: USA

Re: Voice on open9x / stock board

Post by thomas9x » Wed Aug 29, 2012 12:43 am

Tomorrow if everything goes well :)
Excellent!
... nice job on the Sound board. Are you going to make them available for sale?
Thanks for the kind feedback. If you are interested in building one then contact me at the rc-cam.com web site and we can work something out. I added a project blog there for it.
http://www.rc-cam.com/forum/index.php?/ ... ject-blog/

BTW, I don't want to take this site's discussion too far off topic. So if there are questions about the Speak-9X board then please post them in my rc-cam.com blog.

- Thomas

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Wed Aug 29, 2012 8:54 am

Does anybody know if there is a way to know that the module is ready to accept requests? I have seen that Mike introduced a delay of 1200ms which sometimes (after a long shutdown) is not enough.
Bertrand.

User avatar
MikeB
9x Developer
Posts: 16547
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Voice on open9x / stock board

Post by MikeB » Wed Aug 29, 2012 9:01 am

I've recently added sending the 'set volume' command 3 times before anything else as sometimes the volume setting and the first voice output got lost. Waiting to see if this fixes the problem.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18890
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Voice on open9x / stock board

Post by jhsa » Wed Aug 29, 2012 9:21 am

Wrong thread.. I can't believe I did it again.. :oops: :evil:
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Wed Aug 29, 2012 10:33 pm

MikeB wrote:I've recently added sending the 'set volume' command 3 times before anything else as sometimes the volume setting and the first voice output got lost. Waiting to see if this fixes the problem.

Mike.
I dont understand why it sometimes does not play first sound also when switching the model (open9x). Sound board should be already initialised.

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Mon Sep 03, 2012 9:44 am

Hi All,
Not having much luck at getting sound out on Open9x. Er9x works fine.
Latest version of Open9x on stock board with no frsky and using sound files for er9x stored in root of sd card and no folder.
When i listen closely to the speaker and have a low battery waring operating i can hear a hissing sycronised
with what would be the Message.
What am i doing wrong?,any suggestions would be appreciated.
Thanks
Les

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Mon Sep 03, 2012 10:12 am

iwik wrote:Hi All,
Not having much luck at getting sound out on Open9x. Er9x works fine.
Latest version of Open9x on stock board with no frsky and using sound files for er9x stored in root of sd card and no folder.
When i listen closely to the speaker and have a low battery waring operating i can hear a hissing sycronised
with what would be the Message.
What am i doing wrong?,any suggestions would be appreciated.
Thanks
Les
Open9x doesn't use the same sounds than er9x! Do you use companion9x? If yes there is a button for downloading the Zip of sound files for open9x / stock board with voice mod (in Preferences window)!

Bertrand.

User avatar
Kilrah
Posts: 10131
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Voice on open9x / stock board

Post by Kilrah » Mon Sep 03, 2012 1:54 pm

thomas9x posted on his forum that he couldn't get voice on stock board to work either with the current release...

gbirkus
Posts: 97
Joined: Sat Jan 07, 2012 4:15 pm
Country: -

Re: Voice on open9x / stock board

Post by gbirkus » Mon Sep 03, 2012 2:22 pm

i am using the last version with czech voices and all voices are playing OK.
Gabriel

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Mon Sep 03, 2012 6:23 pm

Hi Bertrand,
Yes im using Companion9x, still pretty new to this, didnt spot the ability to d/l audio files. Will have another look tonight
Thanks

les

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Tue Sep 04, 2012 9:17 am

Hi Bertrand,
Have d/loaded english files and find that audio messages seem to have a gap after the message followed by one word then it will repaest the message.
Ive just tested with battery low warning and there are a total of two gaps before repeating.
I have d/loaded the czech version and it is ok. Even though i cant understand it but there is only one gap. The same problem that Kilrah mentioned
Thomas was experiencing.
Could u please have a look when you have time.
Thanks for your efforts,they are much appreciated
Les

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Tue Sep 04, 2012 10:07 am

But ... the battery low warning is only one prompt (one file), so it means that the codec we use for this board (pcm_u8 at 16kHz) is not optimal for the stock board with voice, am I right?

Bertrand.

User avatar
jhsa
Posts: 18890
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Voice on open9x / stock board

Post by jhsa » Tue Sep 04, 2012 12:19 pm

I use 16khz 8 bit on stock board and works very well.. I use audacity to make the files
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

gbirkus
Posts: 97
Joined: Sat Jan 07, 2012 4:15 pm
Country: -

Re: Voice on open9x / stock board

Post by gbirkus » Tue Sep 04, 2012 3:26 pm

Czech voices are "without gaps" on my stock board.
PCM U8 (araw)
16kHz
8 bits
mono
BTW EN voices downloaded through Companion9x have same codec used.

maybe you use the microSD module version? somewhere on forum is discussion about gaps with it.

Gabriel

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Voice on open9x / stock board

Post by bertrand35 » Tue Sep 04, 2012 3:34 pm

araw means linear in the above message (not the same thing than alaw!)
Bertrand.

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Wed Sep 05, 2012 12:07 am

Gabriel,
Thanks for replying. Have you downloaded the english one and tried them.
The Czech play alright on my module. The module has all parts as per mike article.
i am NOT using the micro sd version.
Les

iwik
Posts: 115
Joined: Fri Feb 17, 2012 6:08 pm
Country: -
Location: NEW ZEALAND

Re: Voice on open9x / stock board

Post by iwik » Wed Sep 05, 2012 6:41 pm

Hi All,
Is there anyone out there using Open9x(latest Version),stock board with Mikes module and English Sound file downloaded via Companion9x.
Im still getting extra sound after the right message is spoken before it repeats.
As im new to all of this i just want to know that its working ok or do i have a problem?.

Please note i think its only the English file that appears to be funny. Czech and French dont appear to me to be a problem.

Thanks
Les

User avatar
mhotar
Posts: 198
Joined: Wed May 16, 2012 9:57 pm
Country: -
Location: Jemnice, Vysocina

Re: Voice on open9x / stock board

Post by mhotar » Wed Sep 05, 2012 10:30 pm

iwik wrote:Hi All,
Is there anyone out there using Open9x(latest Version),stock board with Mikes module and English Sound file downloaded via Companion9x.
Im still getting extra sound after the right message is spoken before it repeats.
As im new to all of this i just want to know that its working ok or do i have a problem?.

Please note i think its only the English file that appears to be funny. Czech and French dont appear to me to be a problem.

Thanks
Les
Hi iwik, what do you mean by "extra sound"?
Can you please check attached voices?
voices_en_stock_1361.zip
(1.71 MiB) Downloaded 121 times


Post Reply

Return to “openTx”