Unable upgrade to 2.2.2 on LinuxMint due to dependency error

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
Post Reply
gsjames
Posts: 14
Joined: Wed May 03, 2017 7:12 pm
Country: -

Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by gsjames » Sun Sep 23, 2018 7:00 pm

I wish to upgrade from OpenTX 2.2.1 to OpenTX 2.2.2 on my Linux Mint system. It is a small MS Surface 3 tablet that I have converted to Linux and take to the field, primarily to read telemetry. However, after downloading the "companion22_2.2.2_amd64.deb" package and attempting to install, I get a dependency error:
Error: Dependency is not satisfiable: libqt5core5a(>= 5.7.0)

When trying to upgrade libqt5core5a to version > 5.7.0 I get this message:
libqt5core5a is already the newest version (5.5.1+dfsg-16ubuntu7.5)

It looks like I can continue to use 2.2.1 on my Mint system for the time being.

Any thoughts on how to work around or fix this? I am only marginally competent in Linux. (but I keep trying...)
Thanks!


User avatar
Kilrah
Posts: 10129
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by Kilrah » Sun Sep 23, 2018 7:09 pm

Which Mint version are you using?

This is one of the biggest pains with linux distros, if your distro comes with outdated libs it is a nightmare to get newer ones. Need to find other sources that provide newer versions and add them to your sources.list, update or completely change distro.

gsjames
Posts: 14
Joined: Wed May 03, 2017 7:12 pm
Country: -

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by gsjames » Sun Sep 23, 2018 10:23 pm

I am running Mint 18.03 But of course I ran sudo apt-get update and sudo apt-get upgrade so I should have the latest packages that the Mint distro provides. Perhaps I can add the package manually if I can find it. Any ideas? Thanks!

User avatar
Kilrah
Posts: 10129
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by Kilrah » Mon Sep 24, 2018 6:38 am

Sorry, can't really help.

You can download and install a newer version of Qt directly from Qt, but that then installs side by side with your current one and I don't know what's involved if any to specify which one to use for what.

User avatar
3djc
Posts: 36
Joined: Mon Feb 22, 2016 7:15 am
Country: -

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by 3djc » Mon Sep 24, 2018 6:56 am

While I'm not using mint, I have read that Mint 19 solves this issue. Not a perfect answer I realise that, but hopefully it can help anyway


User avatar
kalle123
Posts: 737
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by kalle123 » Mon Sep 24, 2018 6:58 am

gsjames wrote:
Sun Sep 23, 2018 10:23 pm
I am running Mint 18.03 But of course I ran sudo apt-get update and sudo apt-get upgrade so I should have the latest packages that the Mint distro provides. Perhaps I can add the package manually if I can find it. Any ideas? Thanks!
Have LM 18.03 Xfce here. Same issue. But it works with LM 19.

Those are the independences under LM 18.03

(LM 18 is based on Ubuntu 16.04 and LM 19 on Ubuntu 18.04!)

Code: Select all

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von companion22:
 companion22 hängt ab von libqt5core5a (>= 5.7.0); aber:
  Version von libqt5core5a:amd64 auf dem System ist 5.5.1+dfsg-16ubuntu7.5.
 companion22 hängt ab von libqt5multimedia5 (>= 5.6.0~beta); aber:
  Version von libqt5multimedia5:amd64 auf dem System ist 5.5.1-4ubuntu2.
 companion22 hängt ab von libqt5svg5 (>= 5.6.0~beta); aber:
  Version von libqt5svg5:amd64 auf dem System ist 5.5.1-2build1.
 companion22 hängt ab von libqt5widgets5 (>= 5.7.0); aber:
  Version von libqt5widgets5:amd64 auf dem System ist 5.5.1+dfsg-16ubuntu7.5.
br

gsjames
Posts: 14
Joined: Wed May 03, 2017 7:12 pm
Country: -

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by gsjames » Wed Sep 26, 2018 10:15 pm

I decided to upgrade the Linux Mint installation to 19. That distro apparently has the updated version of the needed file. Everything works fine now. The only downside is that Mint doesn't provide the ability to simply "upgrade" the installation, you either have to have multiple versions or you have to wipe everything, including the applications. Since the only thing that I am using the Surface for is for viewing log files at the field, I just wiped it and uploaded companion again.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

Post by ThompsonJim » Fri May 10, 2019 9:50 pm

gsjames wrote:
Wed Sep 26, 2018 10:15 pm
I decided to upgrade the Linux Mint installation to 19. ......................... The only downside is that Mint doesn't provide the ability to simply "upgrade" the installation, you either have to have multiple versions or you have to wipe everything, including the applications. .................
I also have it working in Linux Mint 19.
However, my understanding is that it is possible to back up your applications before upgrading. Do you make a practice of doing that before upgrading?


Post Reply

Return to “openTx”