Need to bind every time the TX16S is turned on.

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
Post Reply
kingjamez
Posts: 2
Joined: Thu Aug 19, 2021 11:59 pm
Country: -

Need to bind every time the TX16S is turned on.

Post by kingjamez » Fri Aug 20, 2021 12:14 am

I bought a UMX Night Vapor (DMS2/X) today and got it setup on my Radiomaster TX16S running OpenTx v2.3.14 with the 1.3.2.86 firmware for the multi-module. When I bind the TX16S to the Night Vapor everything works exactly as expected. Telemetry comes back, the model flies (quite nicely!).

However, if I turn the radio off, I must bind again the next time I fly.

I set the receiver number to both 00 and 01 no change. If I keep the radio on, and power cycle the Vapor, everything works, no binding required. If I turn the radio off and keep the airplane on, binding is required.

I have another UMX plane loaded in my model list the Turbo Timber. It doesn't have this problem. It works between power cycles.

When I bind I choose DSM - Auto. Any ideas on what I might be doing wrong?

-Jim


User avatar
Kilrah
Posts: 11062
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Need to bind every time the TX16S is turned on.

Post by Kilrah » Sat Aug 21, 2021 8:39 am

UMX models typically require to have the radio powered on before the aircraft, if they don't see the previously bound radio on powerup they enter bind mode.

kingjamez
Posts: 2
Joined: Thu Aug 19, 2021 11:59 pm
Country: -

Re: Need to bind every time the TX16S is turned on.

Post by kingjamez » Fri Sep 03, 2021 10:34 pm

Thanks for the help. I figured it out. The TX16S was coming on with RF disabled because the throttle wasn't calibrated perfectly and never at -100. I'd been just clicking past the warning, but the UMX consistently didn't find the radio broadcasting in time. Once I disabled the throttle warning feature, everything worked as expected.

U300592
Posts: 1
Joined: Sat Nov 19, 2022 4:22 pm
Country: -

Re: Need to bind every time the TX16S is turned on.

Post by U300592 » Sat Nov 19, 2022 4:27 pm

Just used this, thanks Kingjamez. I'm new to Open TX and have been loading all my models into TX16S. I had the same problem with binding every time. Problem solved.


Post Reply

Return to “openTx”