Redundancy Frsky 2.4 & R9

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
Post Reply
User avatar
youngstar
Posts: 17
Joined: Wed May 06, 2020 1:37 pm
Country: -

Redundancy Frsky 2.4 & R9

Post by youngstar » Tue Jul 28, 2020 12:28 pm

If anyone can shed any additional info on the process, hope this helps.

Using a Horus x10 express and mixing frequencies for redundancy with the R9 Module and 2.4ghz receivers, I have found the following:
The R9 Stab receiver only has sbus out so make this reciever with telemetry active or not? and no servos connected. I am assuming that this would make the R9 the primary receiver with 2.4Ghz slaving or does the Horus tx work in order of 2.4ghz to R9? Either way with redundancy and sbus out (only) you cant attach any servos to R9stab. Servos on the 2.4ghz receiver only with sbus in.

Mixing other R9 receivers and 2.4ghz works perfectly well. Validated by turning each TX protocol off in Transmitter.
If anyone has had any issues with this setup please say.


User avatar
Kilrah
Posts: 10650
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Redundancy Frsky 2.4 & R9

Post by Kilrah » Tue Jul 28, 2020 1:02 pm

If you want to use the stabilization function you won't be able to set up redundancy with an R9 Stab.

User avatar
youngstar
Posts: 17
Joined: Wed May 06, 2020 1:37 pm
Country: -

Re: Redundancy Frsky 2.4 & R9

Post by youngstar » Sat Aug 01, 2020 1:29 pm

Yes, thank you.

In addition I have raised a question with Frsky regarding the R9 2019 Module (R92019M) in that after using an external battery connected to the R92019M
(2s Li-ions) I a have been experiencing issues with the registered R9 receivers no longer binding just flashing fast red led even after deleting and re-registering ok but still wont bind!

Without external battery same problem so re flashed the R92019M and all now ok. I tried to replicate the issue without battery and couldnt. It maybe a coincidence but not going to use the external battery as not switchable and module stays on continuously (as i posted previously answered by Kilrah, https://openrcforums.com/forum/viewtopi ... 57#p150386) Even with the internal RF off the R9 receiver is registering a grren Light!!

Just thought I would mention it.
My Specs:
Horus x10 Express (Access LBT.)
R9M 2019 Access Firmware: V1.3.0
Tx : 2019-09-30 FrOS v2.0.02 Beta (udated Tx too OpenTx 2.3.9)
Iram: 2020-04-21 ISRM v2.1.0


Post Reply

Return to “openTx”