Sound stops working on OpenTx 2.2.0 9xrpro

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
Post Reply
Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Sound stops working on OpenTx 2.2.0 9xrpro

Post by Daveh » Sun Oct 01, 2017 3:13 pm

I posted elsewhere about this when it looked as if this was a model configuration problem. Now it looks more like a firmware problem.

Having loaded 2.2.0 f/w (with GVAR option or GVAR + autoswitch) onto my 9xrPro, the voice or sounds stop working after a few minutes. There is a good variation in the time it takes to stop, even on simple model configs as well as fairly extensive mixes.
The following has been tried: Tested 4G Sd cards (2), reformatted SD cards, different sound packs (2.2.0 and "Amber"), F/W regenerated and reloaded directly and by copying to SD card and flashing from that ROM image. Tried a different Tx. All combinations of these had the same outcome, seemingly random operating time until the sounds simply stop. All other functions continue.
I loaded 2.1.9. This has not failed (yet) and has easily outlasted all other attempts using a simple model configuration.

This is posted more for info as I have exhausted my options on 2.2.0 OpenTx.

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by Daveh » Tue Oct 10, 2017 8:59 pm

For further info, I've loaded Ersky9xr-r220. It has run for a few of hours so far, several 10-15 minute flights and plenty of bench time. The voice alerts have not failed, so this doesn't look very like a hardware fault.

User avatar
jhsa
Posts: 18041
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by jhsa » Tue Oct 10, 2017 9:12 pm

Don't expect a quick fix, it seems the OpenTX dev team kinda gave up on radios that were produced before the Taranis radio :) I would stay with Ersky9x if I were you.. It is still being developed for those older radio systems and has amazing features.. The hardware support on ersky9x is fantastic for all platforms.. Want extra switches or pots? No problem.. Music Player?? Yes Sir... :) Bluetooth? Rotary encoder?? ;) :)

If it looks like I am biased, that's because I am :D :mrgreen:

No, really.. Very cool features.. Have a look, if you don't like it you can always go back to OpenTX and hope they fix the issue..
You can also go to the OpenTX development page, wherever that is, and report the issue there..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by Daveh » Tue Oct 10, 2017 9:55 pm

Thanks for the "sales pitch". I have played with both systems, although not in great depth, before I chose OpenTx..... The main reason may be of interest as it is so basic . OpenTx allows the use of three character labels on the mixes. When trying to make a change at the flying field, months after I have set it up, the simple fact that I can easily find my flap to elevator compensation mix (labelled "F-E") for example, could make life easier. Now that I have reverted to ersky9xr, I have simply learned to keep to a fixed order on my global variables for F-E, C-E, R-E, and T-E. I can also keep a very brief note in the flight box, or on my phone etc, so it should never be an issue.
I can say that Ersky9xr is slick and the complexity of mixes possible is probably limited only by my imagination. It works well.... except for the timer (see my other post), which seems to be not as intuitive as some.

User avatar
jhsa
Posts: 18041
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by jhsa » Tue Oct 10, 2017 10:12 pm

I did see your other post and both Mike and I replied.. It is very easy to setup the timer.. You have all options in the timer menu, including a reset switch for each timer if you want.. It is very intuitive.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


User avatar
MikeB
9x Developer
Posts: 15727
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by MikeB » Tue Oct 10, 2017 10:49 pm

Only 3 characters or 6? It looks like 6 from the source code.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Sound stops working on OpenTx 2.2.0 9xrpro

Post by Daveh » Wed Oct 11, 2017 8:48 am

If I remember correctly, only three (plus parenthesis) are displayed on the Tx screen for lines in the mix. Perhaps the global variables allowed more... but the feature I mean is that any kind of label stays on the Tx displayed info.

Post Reply

Return to “openTx”