Page 1 of 2

9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:12 am
by samten
Hi

I try config this from 2 day and nothing :( . Today on my 9XR PRO I update to r220. first what I want do is change protocol to PXX but i dont have this option. I have (internal module) only PPM, DSM, Multi. Next strange things is i can change protocol in 2 place and here (external module) i have another options PPM, XJT, DSM2, Multy,Xfire. Tx and Rx is binded and work, i use sensor X series connected to smart port. I hope you know how confing this or you have old version software

Samten

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:19 am
by jhsa
PXX was renamed to XJT, so select XJT.

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:26 am
by samten
ok in external module i have XJT but what in interial module? dont use this?

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:28 am
by jhsa
No, XJT is not available for the internal module as far as I know.. But do you have an XJT module installed inside the 9XR-PRO??

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:32 am
by samten
yes

this can help
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:49 am
by jhsa
Where did you connect the module inside the radio then? To the PPM2 connector, or to the pins in the module bay?
As I said, XJT is not available for the internal module..

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 10:55 am
by samten
I plug it to place for module in back ... that all what i do

Sorry i wrong understand you i dont have module inside

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 11:41 am
by jhsa
Ahh, ok, then no problem.. Just select the XJT protocol in the External Module setting :)

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 11:49 am
by samten
i have external XJT and internal OFF and still dont work :( On photo you can see my all config meaby in next step i do mistake.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 12:02 pm
by jhsa
Can't you control the model?
Or you just don't have telemetry?

Sorry i don't understand your problem very well..

João

EDIT: ok I have just read on your first post that tx and rx are bound and work.. That means you only don't have telemetry.
Please go to the telemetry menu and select "Invert COM1" option. Try it and see if it works.

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 12:12 pm
by samten
I put "Invert COM1" option and still nothing. I cant control my model but dont have telemetry

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 12:30 pm
by MikeB
You should need "Invert COM1" off.
With everything connected, and the model in control, on the Tx, press UP LONG, then LEFT a few times to get to the "DEBUG" screen. At the bottom of this is a line with "Tel Rx Count" on it with 2 numbers. The first number should be counting quickly, the second number should be fixed possibly showing 0101.
Is the first number counting?
What is the value of the second number?

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 12:35 pm
by jhsa
I thought it would have to be off as well, but I've seen some strange stuff happening before, so it doesn't hurt trying :)

Also what receiver are you using?

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 1:00 pm
by samten
on DEBUG screen i have TelRxCount 0001 0101
i put back invert COM 1 off
i use FrSky X8R

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 1:26 pm
by jhsa
Mike, wasn't with the PRO that someone had a bad connection on pin 5 of the module bay a while ago?

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 2:42 pm
by samten
i have problem to read today
MikeB wrote:
Wed Feb 22, 2017 12:30 pm
and the model in control
when model in control them i see:
DEBUG
TelRxCount 0000 0101

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 3:37 pm
by MikeB
No telemetry data is being received via pin 5 (bottom pin) of the module bay connector. With everything operating, try pressing the corner of the module where the connector is so you try pushing the module into the radio. The module is sometimes a 'loose' fit in the bay, so try pushing the module sideways in the bay. Have a look at the TelRxCount value and see if it changes from 0000.

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 6:09 pm
by samten
i try push, move, pressing the module and nothing change. Still i have first value 0000 and second 0101. I try too with external cable Image Do you have any idea what i can do?

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Feb 22, 2017 6:47 pm
by MikeB
You may need to open the radio up and check the cable from the back board to the main board is plugged in correctly.
When you switch the radio off, does it go off immediately, or does it stay on for a short while with the message "SHUTTING DOWN" showing on the display.

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Thu Feb 23, 2017 3:03 pm
by samten
i open radio and all looks good. when i turn off i see message "SHUTTING DOWN"

Re: 9XR PRO+XJT module - telemetry not work

Posted: Thu Feb 23, 2017 6:49 pm
by MikeB
The following is a test you may try, if you can make the connections.
Using the external cable above, you need to connect the SPort signal (top pin of the 3-way connections on the back of the XJT module, NOT the 4-way) to the connection nearest the middle of the 4-way connector on the external cable. This will route the SPort signal to COM2.
Now, in the telemetry menu, change the telemetry port to COM2, and set the COM2 function to "Telemetry" and the COM2 baudrate to 57600.
See if you then receive telemetry data.

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 8:35 am
by samten
Sorry for long answer i have bad time in work... If i good understand you i plug external cable normally (connected at back of module 2 tops pins in 4 way and on top of controller to training plug) and make a new connect from top pin in 3 way connector to 2 pin from top in 4 way connector?

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 10:17 am
by MikeB
No, you don't connect the 4-way connector to the XJT. You just connect the top pin of the 3-way to the connection nearest the middle of the 4-way connector on the external cable.

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 1:49 pm
by samten
Image
Image
Image

still dont work :(

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 1:55 pm
by bob195558
Hi Mike and Samten,
I do not have a 9XR-Pro Radio,
but I believe Samten may be confused or not understanding that with his
external XJT Module should have telemetry working without using the
FrSky DJT Module Head Track & Telemetry Extent Cable for 9XR-Pro Radios.
Because he dose not have the FrSky DJT Module and also if he is not using Head Track,
I think he dose not need to use this FrSky Head Track & Telemetry Extent Cable ? :?:
What are you using for the a receiver ( ? :?: (X8R OK)
.
DJT module Head Track and Telemetry Cable_.jpg
FrSky DJT Module Head Track & Telemetry Extent Cable for 9XR-Pro Radios
(https://hobbyking.com/en_us/frsky-telem ... r-pro.html)
For telemetry it looks like plugging into the wrong pins or am I missing something ? :?: OK it is the SPort pin, Just me being :? this morming ;)

Bob B.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 1:58 pm
by jhsa
They are trying to find the problem exactly because the module seems not to be working the way it should. So they are trying with the cable ;) :)

João

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 2:03 pm
by bob195558
Thanks João, I was not understanding his problem then. :?
OK good. ;)
But should he be connecting to the telemetry pins and not the power pins ?

Bob B.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Tue Feb 28, 2017 4:06 pm
by MikeB
It seems the XJT is not sending out any SPort telemetry.
What receiver, exactly, are you using.
The X8R and X6R have a mode where they will work using the 'old' 'D' telemetry. You jumper two of the channel pins before power on to select this mode for binding.

So, please try the following:
Plug the cable from the Futaba socket into the 4-pin connector on the back of the XJT, leave the 3-pin connector unconnected.
On the telemetry menu, change the COM2 baudrate to 9600, leave FrSky COM port as 2.
On the protocol menu, keep XJT selected but change the Type from D16 to D8.
Power on the receiver so it binds in 'D' mode, with the link fitted you should not need to press the button.
On the Tx, select the BIND operation, the Rx should bind.
Power off the Rx, remove the channel pins jumper, then power the Rx back on.
On the Tx, exit the BIND screen. The Rx should now be operating, but in 'D8' mode.

Check to see if the RSSI telemetry value is being received (also check the TelRxCount value in the DEBUG menu).

Mike.

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Mar 01, 2017 7:29 am
by samten
I do that like you tell me and finally something change :)
in the DEBUG menu i see first value is all time changing (calculate in hex) and second value still stay 0101
Telemetry still dont work

Re: 9XR PRO+XJT module - telemetry not work

Posted: Wed Mar 01, 2017 9:36 am
by MikeB
I may have something not quite right in the firmware with these settings, I just tested that configuration and I also see TelRxCount counting but no telemetry. I think I may not be setting the baudrate correctly. I'll investigate that, meanwhile please now try the following.
On the back of the XJT, change the DIP switch 1 so it is up. This puts the XJT into 'D' mode. Now, on the protocol menu, change the protocol to PPM. On the telemetry menu, keep the COM port set to 2.
You should now, at least, get telemetry received (I just tested this configuration).

Mike.