Strange behaviour of companion settings file in Linux Mint

A fork of eePe. It's aim is to provide one tool that works with ALL firmwares!
Post Reply
User avatar
OpenMik
Posts: 26
Joined: Thu Jan 12, 2017 10:20 am
Country: Italy

Strange behaviour of companion settings file in Linux Mint

Post by OpenMik » Sun Aug 01, 2021 7:42 am

Hi
Companion 2.3 on Linux Mint 19
because a problem in My (old) Nas sometimes the permission of companion settings files (.ini) result changed
An execution permission is activated (+x)
In this case if i try to open the saved configuration the file is not upload and no error are reported
The configuration remains the same
Changing the permission (-x) the .ini file is uploaded without problems
obviously it is a problem of my system, but I point out this strange behaviour because it could be useful to some other user
attached my .ini file
Attachments
Companion 2.3 settings 29-set-19.ini
(7.11 KiB) Downloaded 34 times


User avatar
OpenMik
Posts: 26
Joined: Thu Jan 12, 2017 10:20 am
Country: Italy

Re: Strange behaviour of companion settings file in Linux Mint

Post by OpenMik » Mon Aug 02, 2021 7:29 am

Update
Saving configuration file in Companion 2.3 in Windows 10 the execute permission flag is activated
and is not possible to import in Companion under Linux
Changing the permission flag (chmod -x) the configuration file is regularly uploaded
I have tested only on my system, I don't know if is a regoular behaviour in every systems

User avatar
OpenMik
Posts: 26
Joined: Thu Jan 12, 2017 10:20 am
Country: Italy

Re: Strange behaviour of companion settings file in Linux Mint

Post by OpenMik » Fri Aug 06, 2021 6:26 am

Does it seem appropriate to open an issue in github?

User avatar
kalle123
Posts: 885
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Strange behaviour of companion settings file in Linux Mint

Post by kalle123 » Sat Aug 07, 2021 6:27 am

Open an issue and see, if it is approved or declined ....

br KH


Post Reply

Return to “companion9x”