backlight always on

General mods that are considered worth doing; regardless of the end firmware you use.
User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

backlight always on

Post by magnetus » Wed Sep 11, 2013 11:51 pm

like title said. i did the backlight mod to my turnigy 9x wit an AT128 but the backlight stays ON all the time no matter what setting i do on the radio setup menu( ie: backlight mode OFF and still the backlight is ON). please a little help.

ps.
using the following file:
opentx-stock128-templates-audio-voice-haptic-DSM2-ppmca-battgraph-ttsen-en

TIA
magnetus
Miguel


User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Thu Sep 12, 2013 2:20 am

How did you connect the backlight? did you connect it to a FET transistor? and the transistor to pin 17 of the atmega128?
Do you have the smartie parts board?

Tell us a bit more about your mod so we can understand what you did. the more info you give, the better we can help you ;) :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 11:58 am

Programmer is a cheap ebay one.
I connected a fet bs170 with the gate at pin 17 drain to ground and source to the negative of the backlight . Positive of backlight to a 470 ohm resistor to a 5v line.
Miguel

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Thu Sep 12, 2013 12:05 pm

No, DRAIN goes to the negative of the backlight.. SOURCE goes to ground.. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 2:20 pm

thanks. i used a new fet just to be sure and connected gate to pin 17, source to gnd and drain to negative and still have the same issue. no matter what setting i have in the backlight menu its stays always on.
Miguel


User avatar
MikeB
9x Developer
Posts: 17118
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: backlight always on

Post by MikeB » Thu Sep 12, 2013 2:53 pm

You have selected voice in you build for a stock TX (M64/M128). This requires you to add a voice module (Emartee or Megasound). These modules use pin 17 differently and move the backlight control onto the voice module.
If you haven't got one of these modules fitted, but do have voice selected then you lose backlight control.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 4:30 pm

ok. thanks mike, now i create and download another firmware without voice, replaced the fet again and it works but backwards, i set up backlight on keys for 5 seconds. backlight is always on and when i press a key it goes off for 5 seconds. im going crazy,,,,
Miguel

User avatar
gohsthb
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: backlight always on

Post by gohsthb » Thu Sep 12, 2013 4:50 pm

is there an option in the settings somewhere for backlight invert? I know it exists in Er9x.
-Gohst

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: backlight always on

Post by ShowMaster » Thu Sep 12, 2013 4:59 pm

If you disconnect the gate and short it to ground does the BL go off?
Is the FET actually working like a switch?

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 5:28 pm

if i connect the negative of the dl to pin 17 seems to be working but it never turns off, it goes bright after i press a key and dim after timer off ( 5 sec)
Gohst --> loaded Er9x firmware and invert backlight and it works. lights on for 5 sec.
Miguel

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Thu Sep 12, 2013 5:31 pm

Hmm there's something very strange here..

Are you sure you have theFET SOURCE to ground and DRAIN to the backlight negative wire? the positive BL wire (red? ) goes to the 5V?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 5:38 pm

100% sure. bl red to 470 ohm resistor. drain to dl negative, source to gnd and gate to pin 17
Miguel

User avatar
gohsthb
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: backlight always on

Post by gohsthb » Thu Sep 12, 2013 5:39 pm

magnetus wrote: Gohst --> loaded Er9x firmware and invert backlight and it works. lights on for 5 sec.
Ok so the hardware is working correctly then, now someone just has to figure out Open9x.
-Gohst

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Thu Sep 12, 2013 7:04 pm

Are you selecting the SP22 option when you download the opentx firmware with companion?
If you don't have the smartie parts board you should not select that option..
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Thu Sep 12, 2013 8:48 pm

No im not selecting sp22 option
Miguel

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: backlight always on

Post by ShowMaster » Thu Sep 12, 2013 9:15 pm

Your BL is wired this way and your are able to control it on or off by shorting the gate to +5 or ground?
If so it's a menu selection issue or a bad FET.
It has to work.
You are on pin 17 for sure?

ImageUploadedByTapatalk1379020151.045246.jpg
ImageUploadedByTapatalk1379020151.045246.jpg
Check right corner orange wire for pin 17 connection. Any pictures of your wiring please.

ImageUploadedByTapatalk1379020486.473998.jpg

User avatar
Flaps 30
Posts: 1490
Joined: Tue Dec 27, 2011 6:04 pm
Country: -
Location: Wokingham Berkshire

Re: backlight always on

Post by Flaps 30 » Thu Sep 12, 2013 10:54 pm

The backlight connection can also go directly to the pad as shown in the image below.
9x_Prog_Layout board connections.JPG

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Tue Sep 17, 2013 2:03 pm

connections are good, i am able to use the backlight with er9x but i have to use the invert option.

ShowMaster --> 100% sure im on pin 17

Flaps 30 --> i measure the trace and its ok and actually i am connected straight to pin 17
Miguel

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: backlight always on

Post by ShowMaster » Tue Sep 17, 2013 2:35 pm

What's the voltage on pin 17 when the normal non invert option is used and you tell the BL to be on?
On should be +5v on pin 17, off should be pulled to ground. No matter what FET your using does. If you need to use the invert I still think something's wrong?
Is it posable the fets your using are mislabeled and are P channel?
The FET should saturate when +5 is on the gate and cutoff when a low or ground is on the gate. I've modified 10 TXs for BL control using the BS170 or 2n7000 FET and never needed the invert option.
If it's working for you ok then I guess you go with it but not knowing why it requires the invert option would drive me nuts, or more nuts.

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Tue Sep 17, 2013 2:43 pm

Just for reference, the BS170 and 2n7000 have different pinouts if replacing one with the other you will have to turn it around..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: backlight always on

Post by ShowMaster » Tue Sep 17, 2013 2:51 pm

Yes on the two fets having different pinouts. The gate action however acts the same. 2n7000's stocked locally and I have to order BS270's so it depends on my stock. The BS170 can handle higher current.
II still am confused by him having to use the invert option?
It's got to be a FET issue?

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Tue Sep 17, 2013 2:59 pm

are you sure you didn't check the SP22 option when you downloaded opentx with companion? because that is what that option does.. inverts the backlight..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4327
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: backlight always on

Post by ShowMaster » Tue Sep 17, 2013 3:08 pm

You're probably on to something Jhsa.
Until we know what pin 17 is reading when the menu is set to BL normal we'll never know if it's the FW or the FET circuit. Then we can work to correct it.

User avatar
gohsthb
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: backlight always on

Post by gohsthb » Tue Sep 17, 2013 3:56 pm

In the openTx file line he listed earlier, sp22 is not listed. So he didn't check that option in companion.
-Gohst

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Wed Sep 25, 2013 12:04 am

using this configuration: opentx-stock128-templates-audio-DSM2-ppmca-ppmus-dblkeys-battgraph-imperial-en

voltage at pin 17 is 2.9v at all time
and 0 when I press a key. that's using opentx (non inverted)
back to the old problem. backlight on all the time, off for 10 sec when i press a key.

ps.
im using this fet
http://www.ebay.com/itm/221267263749?ss ... 1439.l2649


checked my fet polarity and its hooked up as in the diagram.
:evil: :evil: :evil: :?:

using er9x inverted 0v all the time and 2.9 upon key press
Attachments
20130924_201222[1].jpg
Miguel

User avatar
Kilrah
Posts: 10647
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: backlight always on

Post by Kilrah » Wed Sep 25, 2013 7:26 am

So your FET circuit just happens to work inverted. Just tick the sp22 option in C9X and reflash, this will invert backlight control and you'll be good.

User avatar
gohsthb
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: backlight always on

Post by gohsthb » Wed Sep 25, 2013 12:48 pm

I think the voltage from pin 17 should be higher. It should be much closer to 5V, the same voltage the processor is running from. If it isn't then I think there must be an extra load on the pin. A FET doesn't draw much current so the load shouldn't be coming from that. Do you have a picture of your installation?
-Gohst

User avatar
magnetus
Posts: 92
Joined: Tue Mar 12, 2013 2:10 am
Country: United States
Location: Orlando, FL

Re: backlight always on

Post by magnetus » Wed Sep 25, 2013 9:23 pm

I tried sp22 setting and works normal.
Attachments
20130925_200712.jpg
20130925_200650.jpg
20130925_200636.jpg
20130925_200643.jpg
Miguel

icsss
Posts: 2
Joined: Tue Apr 19, 2016 8:02 am
Country: -

Re: backlight always on

Post by icsss » Tue Apr 19, 2016 8:06 am

I have a similar problem with my backlight after transistor mod.
Instead of completely turning off.. the backlight just dims to about 1/3 brightness. It never goes off completely. Everything else is working as it should.

Any ideas why?

User avatar
jhsa
Posts: 19335
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: backlight always on

Post by jhsa » Tue Apr 19, 2016 3:53 pm

Check you connections to the FET transistor.. I don't know which one you used or which guide you followed. knowing that would help to find the problem. Normally that indicates that the transistor is not well connected.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


Post Reply

Return to “Electronic Mods”