Not Compatible?

General Information & Rules
Post Reply
1Anglico
Posts: 1
Joined: Wed Jul 08, 2020 10:00 am
Country: -

Not Compatible?

Post by 1Anglico » Wed Jul 08, 2020 10:15 am

hi. I bought a frsky Qx7s and came here to update firmware. Radio has 2.2 and the latest download is 2.3.9 I think. I downloaded it and went to flash the radio and it failed. Not compatible. Do I need to install some older updates first? I''m new at this by the way, so thanks for the help.


Post Reply

Return to “General Information & Rules”