Occasional Misbehavior - can I trust my radio?

Post Reply
lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Occasional Misbehavior - can I trust my radio?

Post by lancaster » Wed Jun 15, 2016 8:33 pm

Hi Guys
I have encountered a slightly worrying random fault with 9Xtreme as follows :-

Very occasionally all the navigation keys stop working apart from the exit button, which surprisingly triggers my elevator high/low voice warning.
When in this state, all flight controls work normally apart from the flaps on the slider which become inoperative and also show no response on the bar screen.

After a few moments this fault seems to clear and all functions return to normal.

The LiFe battery is well charged and reading 9.9V

I have installed some modifications without any problems following instructions on the thread, ie
two Taranis sliders
rudder, elevator and aileron rate switches converted to 3 position switch

I am using ersky9x firmware version 3531 dated 8/1/16

I dont know whether to try to track this issue down or just to ignore it - but loss of a flight control could be disastourous

Any suggestions?
regards
Hans

User avatar
jhsa
Posts: 18129
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Occasional Misbehavior - can I trust my radio?

Post by jhsa » Wed Jun 15, 2016 9:25 pm

Please make sure that the 9xtreme board is well seated on top of the 9x mainboard and all the pogo pins are making good connection..
May be a good idea to clean the little pads on the 9x mainboard with some alcohol and an old toothbrush..

Also, make sure the screws that hold the 9xtreme board are tight. But not too tight, of course..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 15804
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Occasional Misbehavior - can I trust my radio?

Post by MikeB » Wed Jun 15, 2016 10:25 pm

Normally, certain values (like the buttons) are sent from the original AVR processor to the 9Xtreme over a serial connection on one of the pogo pins. Another sends display data the other way.
There is, however, a backup mechanism via one of the wires on the 12-way cable. This sends most of the same data.
If the main (serial) connection fails then the backup data is used. It looks like the timeout on receipt of the main serial data is 1.5 seconds.

The four gimbal inputs are direct to the 9Xtreme so main flight control should not be affected.

João is correct that a good clean of the pogo pads will probably fix the problem.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: Occasional Misbehavior - can I trust my radio?

Post by lancaster » Wed Jun 15, 2016 11:04 pm

Joao and Mike

Thanks for the quick replies and suggestions

I suspected the pogo connections might be the culprit

The fault might be linked to periods when the TX has not been used or perhaps subjected to recent temperature changes

It makes sense now you have explained how the gimbals have a direct path and the sliders go through the pogo connections

I will give them a clean

I think I will now be able to trust my radio!

many thanks
regards
Hans

Post Reply

Return to “9Xtreme upgrade board”