FrSky issues

Post Reply
orejass
Posts: 12
Joined: Mon Dec 14, 2015 8:25 pm
Country: -

FrSky issues

Post by orejass » Mon Jan 11, 2016 7:36 pm

I know the issue might not be related to the 9xtreme, but maybe you guys can point me in the right direction.

-Prologue
I recently upgraded my already moded TGY9x with the 9xtreme board from smartieparts (i had the prevoius smartieparts board) and installed th FrSky DJT tellemetry Module and swapped all my recievers to the D4R-II with 27ms cppm fw.
As for firmware on the 9x I'm using the ERSky9x that comes with the 9xtreme board.
Everything on the bench works like a charm, I even use the control to play HotProps and FreeRider without a problem.

-The Issue
Range of FrSky (and rssi value): the range on the FrSky module seems oddly inconsistent, hence I have not flown more than ~150m. right next to the RX, i get a signal value (displayed on the 9x) of 100 (wich i'm only guessing it's a percentage and not the real value as this should be negative and closer to zero).
If i move ~10m away, signal drops to 75; at 50m signal drops to 50 and the 9x looses telemetry comunication (9x screaming "no telem") BUT i can still arm/disarm the quad and navigate the osd menus without a glitch.
If i go to 100m, signal drops to about 30, still I have signal for controling the quad and the 9x screams " no tlemetry"
These tests were performed on an open field.
Here is what happends when flying: flights always performed in open area; quad responds perfect to stick inputs, but, at any range, it enteres (i believe) in failsafe and floats gracefully down to earth (props spin at a very low, stable rpm) and completely ignores my throttle inputs yet I can control yaw, roll and pitch. Once the quad hits ground, I can arm and fly again.

Go figure. :?

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Tue Jan 12, 2016 12:48 am

Did the DJT/D4R-II work OK before the 9Xtreme upgrade?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

orejass
Posts: 12
Joined: Mon Dec 14, 2015 8:25 pm
Country: -

Re: FrSky issues

Post by orejass » Wed Feb 24, 2016 10:47 pm

ive been away from the issue for a while, work work work.

i'll be doing some more tests this weekend. will post results.

will test PWM, PPM (on a naze32 and APM 3.2), a D8R-XP and whatever else I can get my hands on.

And YES, everything worked before the upgrade.

Thx. will post soon

orejass
Posts: 12
Joined: Mon Dec 14, 2015 8:25 pm
Country: -

Re: FrSky issues

Post by orejass » Wed Mar 02, 2016 8:57 pm

***UPDATE***

Gents, oddly enough, it was the Naze32 beeing stubborn.

I swapped the FC as my last test, and i flew without issues. go figure.
Must of been faulty from purchase.


All i have left to do is figure out how to silence the "No Telemetry" voice warning that goes off so often.

Thx! :D

User avatar
jhsa
Posts: 18129
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FrSky issues

Post by jhsa » Wed Mar 02, 2016 9:20 pm

orejass wrote:

All i have left to do is figure out how to silence the "No Telemetry" voice warning that goes off so often.
If it goes off so often, I would be wanting to know why it goes off instead of turning it OFF.. It normally means that something is not working as it should..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Fri Mar 25, 2016 12:16 am

Hi Guys

I am trying to get to grips with the FrSky firmware changes, ie international and EU

I have recently bought the XJT module and X8R Rx from Hobby King - this is working ok on the 9xtreme

As they are both date stamped December 2015, I assumed the EU software had been installed - but today I found that my new X6R bought in the UK would not bind to the XJT module

The X6R has a sticker on the case so I know its has the EU firmware

How can I check the firmware version in the XJT module?

I have been checking out the upgrade videos on Youtube - they show the X series receivers being flashed from the Taranis with Open TX - can we do similar things with ERSky and the 9xtreme ?

regards
Hans

Daedalus66
Posts: 1783
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

FrSky issues

Post by Daedalus66 » Fri Mar 25, 2016 3:24 am

There is no way to determine directly which firmware you acquired originally, but the evidence in your case clearly points to International. To be sure you have a particular firmware you need to flash a known version.

The ability to flash via a transmitter was created by Mike, the developer, on ErSky9x, and only after adopted by OpenTX. So of course it works with the 9XTreme. :)

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Fri Mar 25, 2016 9:31 am

Daedalus

Thanks for the quick reply and helpful advice

I know we can flash updated Ersky firmware to the 9Xtreme but how do you flash firmware to the xjt module and the receiver - perhaps Mike can help?

regards
Hans

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Fri Mar 25, 2016 9:47 am

Start the radio in "maintenance mode" (hold both horizontal trims AWAY from the centre and power on).

Instructions are here (SportFlash.pdf): viewtopic.php?f=45&t=6847&hilit=sport+d ... ing#p94700.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Fri Mar 25, 2016 10:49 am

Thanks Mike
I will follow the link
regards
Hans

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Fri Mar 25, 2016 4:56 pm

Mike
I have read through your instructions and trawled through the various Youtube guides, eg Painless360, Drone shop and Multicopter

It seems the simpler of the two methods is to use the direct cable from the Tx to the Rx - this avoids FTDI converters and associated steps

As your guide does not refer directly to the 9Xtreme, I still have some questions:-

1. Looking at your diagrams I assume that I should remove the XJT module and connect the cable to the pins in the module bay
or can the cable be connected to the Sport in the XJT module?
2. I assume I dont need the diode in the signal wire?
3. I might need to reflash the XJT module to non EU firmware - do I select Update AVR CPU in Maintenance mode?
3. I assume the latest Ersky9X firmware (r218 v3531 8 Jan 2016) has the facility to flash the Rx and external module directly

I need to get my new X6R bound in asap because I'm having intermittent reliability problems with the original X8R and I must ensure that its not a module fault.

many thanks
Hans

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Fri Mar 25, 2016 6:58 pm

1. Remove the XJT and connect to the pins in the module bay.
2. Correct.
3. No, the XJT is an "External SPort Device", just plug it in normally.
4. Correct.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Fri Mar 25, 2016 9:50 pm

Thanks for the quick reply Mike as always - I dont know how you keep up with activities across the forum and your development work as well!

It seems there are three versions of the Frsky firmware - LBT, Europe and International - anyway I'm going for the international so I will be continuing to reflash rxs that I buy in the UK

thanks again, with your expertise its another step forward for me

regards
Hans

Daedalus66
Posts: 1783
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

Re: FrSky issues

Post by Daedalus66 » Fri Mar 25, 2016 10:10 pm

For a discussion of versions, take a look:
http://rc-soar.blogspot.ca/2016/01/eu-n ... odule.html

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Sat Mar 26, 2016 10:44 am

Daedalus

Thanks for the link

Its an excellent summary and clears up the questions decisively (no thanks to EU)

regards
Hans

mmilan
Posts: 120
Joined: Fri Mar 23, 2012 12:16 am
Country: United States
Location: Holly, Mi

Re: FrSky issues

Post by mmilan » Sat Mar 26, 2016 6:05 pm

"I need to get my new X6R bound in asap because I'm having intermittent reliability problems with the original X8R and I must ensure that its not a module fault."

Looks as though I am not the only one how has had reliability issues with the X8Rs. My two receivers go into fail safe in turns. It must be due to the pcb type antennae being so directional. This is in spite of orienting them in a "V" and perpendicular axis to each other. I am about to give up on them as they have crashed 4 planes now. The "D" series never did this. Have others had the same problem?
Mike

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Sun Mar 27, 2016 10:43 am

mmilan

I had a couple of perfectly normal flights before I lost all control about 30m away and crashed. The receiver was buzzing when I got to the plane.
I didnt hear any warnings on the telemetry but I thought it was loss of signal. I had already set the failsafe before the flight but now you mention it, the problem could have been unforced entry into failsafe mode since the motor did shut down.

I have tested the X8R on the bench and managed to record an intermittent signal loss on a log file. I also tested the XJT module with a different receiver (X6R) and I dont get any loss of signal so I assume the module is ok.

regards
Hans
X8R fault log 2.pdf
(132.71 KiB) Downloaded 32 times

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Sun Mar 27, 2016 11:05 am

This does seem to be a faulty receiver. Since the receiver doesn't have a buzzer, it is odd if it was buzzing!

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Daedalus66
Posts: 1783
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

FrSky issues

Post by Daedalus66 » Sun Mar 27, 2016 11:42 am

Sure the Rx was buzzing? About the only thing that's capable of buzzing in most setups is the motor, with the ESC doing the driving. That could be caused by a receiver problem, though.

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Sun Mar 27, 2016 11:46 am

Thanks Mike
Hope you enjoying the Easter break

I wasnt sure if it could also be a faulty XJT module leading to loss of RSSI but I tested this with a X6R

This log (attached) was OK

Unfortunately all XJTs in UK and HK are on back order so I will have a long wait for a replacement from HK

I guess they are preparing for the June clamp down to LBT firmware

Do you think both the XJT and X receivers will be locked against flashing alternative firmware?

regards
Hans
X6R log.pdf
(118.82 KiB) Downloaded 26 times

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Sun Mar 27, 2016 11:51 am

Daedalus66 wrote:Sure the Rx was buzzing? About the only thing that's capable of buzzing in most setups is the motor, with the ESC doing the driving. That could be caused by a receiver problem, though.
Thanks for the reply

I thought it was a servo but I pulled all the leads and the buzz continued

I could not detect vibration from the motor but the buzz stopped when I pulled the esc/rx lead so I guess you're right

regards
Hans

User avatar
jhsa
Posts: 18129
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FrSky issues

Post by jhsa » Sun Mar 27, 2016 11:53 am

Servos can also Buzz.

Does the rx buzz if you connect another receiver battery or ESC?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Daedalus66
Posts: 1783
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

Re: FrSky issues

Post by Daedalus66 » Sun Mar 27, 2016 11:55 am

Unless the ESC was supplying the power!

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Sun Mar 27, 2016 12:01 pm

Hi Guys

I guess it was the motor buzzing and this stopped when I pulled the esc lead

The receiver doesnt buzz now but I still get the random drop in RSSI to zero on the bench

regards
Hans

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Sun Mar 27, 2016 1:52 pm

lancaster wrote:Unfortunately all XJTs in UK and HK are on back order so I will have a long wait for a replacement from HK
In the UK, I'd recommend getting FrSky gear from T9HobbySport (Official FrSky agent), or RCLife, or Robotbirds.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

orejass
Posts: 12
Joined: Mon Dec 14, 2015 8:25 pm
Country: -

Re: FrSky issues

Post by orejass » Wed Mar 30, 2016 4:00 pm

Hey guys,

I guess I come in late in every forum. Hardly get time to pursue the hobby as I would like to.
Dunno how you do it Mike.

So, this weekend I went to fly again, and AGAIN my 9x just screams " No telemetry" and signal drops drastically at any distance after 50m, specially the TxSSI (which hits zero almost immediatley).
Even though it has really bad signal (RxSSI drops to 45 at about 100m) I do not loose control of the craft and I have flown up to about 200m.

This happens with any Rx (D4R-II and D8R-XP). I dont have my old turnigy module to swap back for testing, and none of my buddies that have gone to fly with me have modular (or FrSky compatible) controls.
i do know one guy with a Taranis, hopefully I can do some testing with his control this weekend.

So, I am clueless on what is going on with my range. Doesn't seem to be a problem with the 9xtreme or the rx's.
Could be this something going on with the DJT module (would i need a fw flash, new module...?) or maybe something going on with the 9x itself...?

Cheers,

-Wolken

User avatar
jhsa
Posts: 18129
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FrSky issues

Post by jhsa » Wed Mar 30, 2016 4:26 pm

Do you have another Antenna? maybe from a router? make sure it has the same connector as the frsky module antenna.
I think the module has a male connector and the antenna has a female.. 2 females also do not work, in theory :D
I have the feeling that you have a bad antenna on the module, and if so, that could also damage your module..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky issues

Post by MikeB » Wed Mar 30, 2016 4:41 pm

This does point to a problem with the DJT module. If I understand correctly, this was added (new?) when you also upgraded to the 9Xtreme.
I would actually suspect the antenna, or its connection, in the DJT.

If you put the Tx module into range check mode, how much range do you get?

For information, if no telemetry is being received, the TSSI value is forced to 0. This was done to enable you to use it in logical switches (etc.) to detect the lack of telemetry.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

lancaster
Posts: 182
Joined: Thu Jun 12, 2014 10:28 pm
Country: United Kingdom

Re: FrSky issues

Post by lancaster » Thu Mar 31, 2016 9:28 am

orejass wrote:Hey guys,

I guess I come in late in every forum. Hardly get time to pursue the hobby as I would like to.
Dunno how you do it Mike.

So, this weekend I went to fly again, and AGAIN my 9x just screams " No telemetry" and signal drops drastically at any distance after 50m, specially the TxSSI (which hits zero almost immediatley).
Even though it has really bad signal (RxSSI drops to 45 at about 100m) I do not loose control of the craft and I have flown up to about 200m.

This happens with any Rx (D4R-II and D8R-XP). I dont have my old turnigy module to swap back for testing, and none of my buddies that have gone to fly with me have modular (or FrSky compatible) controls.
i do know one guy with a Taranis, hopefully I can do some testing with his control this weekend.

So, I am clueless on what is going on with my range. Doesn't seem to be a problem with the 9xtreme or the rx's.
Could be this something going on with the DJT module (would i need a fw flash, new module...?) or maybe something going on with the 9x itself...?

Cheers,

-Wolken
Check the antenna integrity on the module. I have had problems with broken connections

Check that the centre pin in the antenna connection is not displaced or damaged

Check for compatibility of parts - the XJT uses reverse SMA connections ie the centre pin is in the module connection

Try a bench test whilst checking for poor connections

regards
Hans

orejass
Posts: 12
Joined: Mon Dec 14, 2015 8:25 pm
Country: -

Re: FrSky issues

Post by orejass » Fri Jul 15, 2016 1:08 am

***UPDATE***

Hey everyone, I finally got my XJT module, installed it and guess what: all issues gone!

Thanks for all your help

W

Post Reply

Return to “9Xtreme upgrade board”