Screen goes blank & speaker starts to buzz

Post Reply
AWC
Posts: 1
Joined: Fri Jun 01, 2018 8:21 pm
Country: United States
Location: Seattle, WA

Screen goes blank & speaker starts to buzz

Post by AWC » Fri Jun 01, 2018 10:09 pm

I'm getting weird behavior today when I turn on my Turnigy 9X with a 9Xtreme upgrade board. Today, I was trying to set up the flight mode switches on the transmitter when suddenly the screen went blank (still lit but blank) and when I switched the transmitter off the screen stayed lit and the speaker buzzed. I took out the battery and left the transmitter alone for awhile. Later I plugged the battery back in and now when I turn the transmitter on the splash screen will show briefly and then the screen goes blank (still lit) and the speaker starts to buzz. Turning the transmitter off does turn off the screen and the buzz. A few weeks ago, I may have accidentally reversed the polarity of the power but the transmitter has been working fine for weeks since then up until today. Anyone have any suggestions for troubleshooting this problem?

User avatar
jhsa
Posts: 18126
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Screen goes blank & speaker starts to buzz

Post by jhsa » Fri Jun 01, 2018 11:00 pm

1) Is the battery charged?
2) Did you do the reverse polarity mod by installing a diode on the Power switch board? Please have a look here:

http://openrcforums.com/forum/viewtopic ... 126&t=7987

If you didn't do this mod and reversed the polarity you could have damaged something..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “9Xtreme upgrade board”