Problem with last new Hobbyking Turnigy 9X transmiters.

User avatar
MikeB
9x Developer
Posts: 17784
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by MikeB » Sat Nov 25, 2017 7:07 pm

When trying to flash, please add -B 100 on the AvrDude command line. This slows the programming speed down and may let the flash operation work.
Do NOT use the -F option.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


ReSt
Posts: 1578
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by ReSt » Sat Nov 25, 2017 10:17 pm

Some time ago, with the M128 processor, I had the hard reproduceable error 0102 when the throttle cut switch was in the up position.

Check that this is not your problem.

Reinhard

drotgabesz
Posts: 2
Joined: Sat Nov 25, 2017 7:08 am
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by drotgabesz » Fri Dec 08, 2017 6:14 pm

Hi,

thanks for the support, the -B 100 solved the writing problem.

Bab
Posts: 3
Joined: Wed May 05, 2021 12:48 pm
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by Bab » Wed May 05, 2021 12:57 pm

Hello everyone,

Just signed up to this forum to say that flashing the Turnigy 9X with the GREEN ED0040502-H16D 1105 chip with the ER9X for Mega128 firmware with eepe works. I used a SmartieParts SP Basic board plugged in to a MacBook Air to do so.
For anyone using this setup: you will need to install Homebrew and AVRDUDE using the terminal.

I'd like to thank all the participants in this thread because it is litterally the only place on the net you can find info regarding the cloned chip.
I'd also like to mention that I first intended to use OpenTx, and used Companion 2.1.9 to flash but the software couldn't recognize the chip and was sending back errors.


Thanks,
L

User avatar
OctavioS
Posts: 640
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by OctavioS » Thu Jul 21, 2022 10:08 am

So I'm, for what I have read, there is no solution for this green chip 9x boards with the 9xtreme.
I added this board, but this switch error shows up.
at power on it seemed to flash the firmware, but then the error show on the screen.
one can hear the welcome message though.
Image
Image
Attachments
IMG_20220720_212717830~2.jpg
(900.66 KiB) Not downloaded yet
IMG_20220720_213025797~3.jpg
(639.07 KiB) Not downloaded yet
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.


User avatar
MikeB
9x Developer
Posts: 17784
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by MikeB » Sat Jul 23, 2022 10:33 am

The 9Xtreme is not managing to flash the firmware to the "Green" cpu.
What do the backlight colours show during power on. They go through a specific sequence indicating how the flashing is progressing, and whether it completes successfully.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
OctavioS
Posts: 640
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by OctavioS » Sun Jul 24, 2022 10:46 am

The first time, there a was sequence alright, but I don't remember what was because it was a bit fast. Then it went to the switch error screen.
Now everytime I power on the radio, that screen shows up.

Edit:
Every time I unplug the battery and plug it again and turn on the radio, I see that the flash attempt occurs again, but with the same result at the end. I will record it and upload the video.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.

User avatar
OctavioS
Posts: 640
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by OctavioS » Mon Jul 25, 2022 12:28 am

Hi Mike, after watching closely, I realised that the situation is straight forward. What happens, is that the screen changes color several times and ends with a red light. Which probably means that it failed to flash. You probably noticed above. There is this user that says it is possible to flash with the smartieparts parts programmer with er9x.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.

User avatar
MikeB
9x Developer
Posts: 17784
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by MikeB » Mon Jul 25, 2022 8:36 am

This is the firmware that is flashed to the AVR processor (same for '64 and '128).

Mike
Attachments
slave64.zip
(2.71 KiB) Downloaded 6 times
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
OctavioS
Posts: 640
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by OctavioS » Mon Jul 25, 2022 6:28 pm

I dont know what have i done, but suddenly it started working fine. I copied that file to the firmware folder, but didnt flashed it, so i assume the 9xtreme flashed it.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.


Post Reply

Return to “9Xtreme upgrade board”