Problem with last new Hobbyking Turnigy 9X transmiters.

User avatar
MikeB
9x Developer
Posts: 17515
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by MikeB » Sat Nov 25, 2017 7:07 pm

When trying to flash, please add -B 100 on the AvrDude command line. This slows the programming speed down and may let the flash operation work.
Do NOT use the -F option.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


ReSt
Posts: 1571
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by ReSt » Sat Nov 25, 2017 10:17 pm

Some time ago, with the M128 processor, I had the hard reproduceable error 0102 when the throttle cut switch was in the up position.

Check that this is not your problem.

Reinhard

drotgabesz
Posts: 2
Joined: Sat Nov 25, 2017 7:08 am
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by drotgabesz » Fri Dec 08, 2017 6:14 pm

Hi,

thanks for the support, the -B 100 solved the writing problem.

Bab
Posts: 3
Joined: Wed May 05, 2021 12:48 pm
Country: -

Re: Problem with last new Hobbyking Turnigy 9X transmiters.

Post by Bab » Wed May 05, 2021 12:57 pm

Hello everyone,

Just signed up to this forum to say that flashing the Turnigy 9X with the GREEN ED0040502-H16D 1105 chip with the ER9X for Mega128 firmware with eepe works. I used a SmartieParts SP Basic board plugged in to a MacBook Air to do so.
For anyone using this setup: you will need to install Homebrew and AVRDUDE using the terminal.

I'd like to thank all the participants in this thread because it is litterally the only place on the net you can find info regarding the cloned chip.
I'd also like to mention that I first intended to use OpenTx, and used Companion 2.1.9 to flash but the software couldn't recognize the chip and was sending back errors.


Thanks,
L


Post Reply

Return to “9Xtreme upgrade board”