Ubuntu and 9xr Pro comm issues

ersky9xr is the port of the er9x firmware to the 9XRPRO radio.
Post Reply
DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Ubuntu and 9xr Pro comm issues

Post by DanielGA » Sat Mar 19, 2016 12:25 pm

Hi,

I've experienced two problems on the 9x pro communicating with Xubuntu 14.4.04 LTS:

1. I tried to flash ersky9xr r218 from eepskye for linux through usb 2 but it didn't upload properly. When I turned it on again I got some dots on the lcd but no more. Flashed again with eepskye for windows and it got fixed

2. In bootloader mode when connected to usb (vers 2 or 3) 9xr pro got mounted (firmware and SD card) properly. It s ok to read from it, but when writing it stops after some files are written

Regards,

Daniel.
Last edited by DanielGA on Sun Mar 20, 2016 11:28 am, edited 1 time in total.


User avatar
MikeB
9x Developer
Posts: 16686
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Ubuntu and 9xr Pro comm problems

Post by MikeB » Sat Mar 19, 2016 12:42 pm

It's difficult for mw to help here as I only have a copy of Ubuntu lite running in a virtual box under windows.
What version of the bootloader do you have on the radio. Note that the bootloader is not updated when you flash new firmware.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 1:07 pm

Thanks Mike!

Bootloader version is 1.3

User avatar
jhsa
Posts: 19111
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Ubuntu and 9xr Pro comm problems

Post by jhsa » Sat Mar 19, 2016 1:29 pm

Mike, I thought of this problem a while ago.. There is no way people will know there is a newer bootloader version.
What about display a message at startup when there is a version with a new bootloader??

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 1:45 pm

I'm going to update the bootloader. Sorry, just a newbie question: is the bin file for the bootloader the same as for the firmware from er9x.com? Then turn on with sticks outwards and then flash bootloader, right? ...don't want to brick the Tx


DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 1:54 pm

Ok. I took the risk. Yes, it is the same bin file. Now I've bootloader 1.5 from r217. I'll check with Ubuntu again

User avatar
jhsa
Posts: 19111
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Ubuntu and 9xr Pro comm problems

Post by jhsa » Sat Mar 19, 2016 1:54 pm

You got it right :)
I think the latest bootloader is on the latest TEST version of the firmware. You can find it here

viewtopic.php?f=7&t=4676

Try the one called " ersky9xProvR219j.zip". Make sure you extract the right one for your radio
Current bootloader version is 2.0
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 2:03 pm

Same problem with bootloader 1.5. It got stuck after 6mb (copying voices folder)

User avatar
jhsa
Posts: 19111
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Ubuntu and 9xr Pro comm problems

Post by jhsa » Sat Mar 19, 2016 2:06 pm

Did you try another SD Card?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 2:17 pm

That's a good point. I'll try that

I've also installed bootloader 2.0 from r219 and same result. It stops after 6mb more or less. It might be related also on how ubuntu automount the 9xr pro. I'll look at it

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 4:21 pm

Ok. Changed the sd card coming with transmitter (4gb, type 6) by a samsung evo 64gb type 1 solved the problem.

The issue is that ubuntu is trying to write too fast for the sd card that comes with the transmitter which seems to be very slow

Adding a udev rule solves the problem with the default sd card:

Code: Select all

sudo nano /etc/udev/rules.d/51-9xrpro.rules
Write text below, save and exit:

Code: Select all

SUBSYSTEM=="block", ATTRS{vendor}=="ERSKY9X", RUN+="/bin/sh -c 'echo 64 > /sys/block/%k/device/max_sectors'" 
And restart udev:

Code: Select all

sudo restart udev
It will slow down writing speed when 9xr pro is connected by usb

Will check if flashing is affected by the same problem

User avatar
jhsa
Posts: 19111
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Ubuntu and 9xr Pro comm problems

Post by jhsa » Sat Mar 19, 2016 5:08 pm

I have been trying to install eepskye on ubuntu. But it seems that it fails to install if eepe is installed. removed eepe and eepskye installed ok.. But now I can't install eepe :( I gives the same error..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 5:14 pm

Which error gives ubuntu?

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sat Mar 19, 2016 5:54 pm

I can't recreate the failed flashing as eepskye throws the error 'Tx disk not mounted' when trying to flash

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Sun Mar 20, 2016 11:26 am

Solved. It is needed to mount the ERSKY_9X drive by clicking on it. In ubuntu when an external storage is plugged it is showed in devices list in folder navigation gui, but it is not really mounted. Clicking on it mounts and opens it. So, a newbie mistake again!! I keep learning about eepskye/ersky9xr. Now I've got eepskye fully working on ubuntu!! And again, thanks for the great work and support!!

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm problems

Post by DanielGA » Tue Mar 22, 2016 10:28 am

jhsa wrote:I have been trying to install eepskye on ubuntu. But it seems that it fails to install if eepe is installed. removed eepe and eepskye installed ok.. But now I can't install eepe :( I gives the same error..

João

There is a problem with the package trying to overwrite files in /usr/bin/eepefiles (I guess language files). You can override this problem installing deb package from command line with force option. Open a terminal, go to the package folder and write:

Code: Select all

sudo dpkg --force-all -i eepe-i386.deb
I did install both to open and import models defined for er9x to ersky9x (eepe and eepm files seems to be not compatible). I just copy the model in eepe and paste it in eepskye and it works!!

User avatar
jhsa
Posts: 19111
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Ubuntu and 9xr Pro comm issues

Post by jhsa » Tue Mar 22, 2016 10:54 am

That is the right way to do it.. open both eepe and eepskye and drag the models. Check everything afterwards of course..

Thank you for the installation explanation..
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

sdavies
Posts: 112
Joined: Wed Jan 21, 2015 6:46 am
Country: Australia
Location: Adelaide SA

Re: Ubuntu and 9xr Pro comm issues

Post by sdavies » Sun Mar 27, 2016 11:52 pm

The SD card speed issue sounds as if it may have been the cause of my hassles with my Fedora box.
I took the easy way out and used a separate card reader to copy files to the SD card.
When you say you replaced your SD card, was it just the card or did you dig in and change the built-in reader?

DanielGA
Posts: 25
Joined: Sat Mar 19, 2016 10:44 am
Country: Spain

Re: Ubuntu and 9xr Pro comm issues

Post by DanielGA » Mon Mar 28, 2016 10:59 am

I changed the sd card in the 9xrpro sd port by a faster one to verify where the problem was (no changes on the 9xrpro sd card reader). No problem with this faster sd card in the 9xrpro port. Then I put back the slow sd card in the 9xrpro and added a udev rule to slow down the maximum amount of data transferred to the device (max_sectors) from 240 to 64. This reduces the speeds but avoid I/O errors for slow devices. Also there was no problem inserting the slow sd card into my laptop sd card reader with max_sectors to default 240, but this implies to remove the sd card from the 9xrpro for each transfer, which I wanted to avoid

sdavies
Posts: 112
Joined: Wed Jan 21, 2015 6:46 am
Country: Australia
Location: Adelaide SA

Re: Ubuntu and 9xr Pro comm issues

Post by sdavies » Tue Mar 29, 2016 11:56 pm

Thanks. I'll try a faster card.


Post Reply

Return to “ersky9xr”