I really need some help

ersky9xr is the port of the er9x firmware to the 9XRPRO radio.
Post Reply
eekzues
Posts: 11
Joined: Sat Jun 10, 2017 7:22 pm
Country: -

I really need some help

Post by eekzues » Sat Jun 10, 2017 8:12 pm

Hey Guys, The other day I received my new STM32 board & have been reading like crazy on how to get this working right.
I'm building a mini spark using a Spektrum AR610 reciver, Radio has the latest firmware, radio settings are AETR & in the mixer for the model I have TAER per everything I have read. I have tried every variation I can think of and I'm not having any success. Radio is mode 2 when I move the right stick right the rudder servo moves 50% then back to center and when moved left the Ele move 50%. Also I dont believe the THR is working have no idea what I'm doing wrong here.
May as well mention when I try to bind to my H8 mini is just flashes rapidly also when I bound to my Syma X8W it took off at full throttle and smashed into the tv. I'm such I noob with these new computer radios. Any advice is greatly appreciated.


User avatar
MikeB
9x Developer
Posts: 17333
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: I really need some help

Post by MikeB » Tue Jun 13, 2017 12:30 pm

Is this "STM32" board a multi module, and you are using a 9XR-PRO with ersky9x on it?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

eekzues
Posts: 11
Joined: Sat Jun 10, 2017 7:22 pm
Country: -

Re: I really need some help

Post by eekzues » Tue Jun 13, 2017 4:27 pm

Yes, 9xr pro with ersky9x-r220 & this module https://www.banggood.com/2_4G-CC2500-NR ... ds=myorder

User avatar
MikeB
9x Developer
Posts: 17333
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: I really need some help

Post by MikeB » Tue Jun 13, 2017 4:32 pm

Have you updated the firmware on the muti module at all?

You might also try the latest test ersky9x, which you wil find here: viewtopic.php?f=7&t=4676#p65894.
Backup your existing EEPROM and firmware before flashing this (just in case!).

Do you have the protocol set to MULTI?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

eekzues
Posts: 11
Joined: Sat Jun 10, 2017 7:22 pm
Country: -

Re: I really need some help

Post by eekzues » Tue Jun 13, 2017 5:06 pm

Thanks Mike. I just flashed it to ersky9x-pd4r221 and no change. I have not tried updating the module yet since i can't seem to find a tutorial for the usb version


User avatar
jhsa
Posts: 19403
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: I really need some help

Post by jhsa » Tue Jun 13, 2017 5:55 pm

I am also waiting for a STM32 Multimodule with USB. It should arrive sometime next week. They didn't have the Frsky version in stock, so I have bought the JR version. That means I will have to flash it..
This module will be installed internally in my most recent 9x radio with Ar9x board..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

eekzues
Posts: 11
Joined: Sat Jun 10, 2017 7:22 pm
Country: -

Re: I really need some help

Post by eekzues » Tue Jun 13, 2017 8:59 pm

I shot a quick video , sadly the menu screen is not visible . I can try again if you guys want to see my settings. Anybody know if I can just use a normal usb cable to update the module . https://youtu.be/AYI0UxFpj9Q

User avatar
MikeB
9x Developer
Posts: 17333
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: I really need some help

Post by MikeB » Tue Jun 13, 2017 10:20 pm

Do you have the protocol set to MULTI, and if you do, what other settings do you have in the protocol menu.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

eekzues
Posts: 11
Joined: Sat Jun 10, 2017 7:22 pm
Country: -

Re: I really need some help

Post by eekzues » Wed Jun 14, 2017 5:17 pm

ext module checked
proto multi rxnum 0
detect telem auto
protocol dsm
type auto
autobind y option 0
power high rate 7ms
1st chan 1

User avatar
MikeB
9x Developer
Posts: 17333
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: I really need some help

Post by MikeB » Sat Jun 17, 2017 9:04 pm

Only use Type "Auto" when binding. Make sure you have the "Usr Proto" set to "DSMx" in the telemetry menu. This is needed to correctly recognise the response from the Rx when binding.
Also make sure you have the correct polarity set for COM1 telemetry to match the polarity from the Multi module. If the telemetry settings are correct, you should see the Multi firmware revision displayed on the protocol screen.
If binding in "Auto" mode does not set the Type to something other than "Auto", you will need to change the Type manually to that required by the Rx, and set Option to the number of channels to transmit (4 to 7).

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “ersky9xr”