telemetry fail with IRANGEX module and ORANGERX

ersky9xr is the port of the er9x firmware to the 9XRPRO radio.
Post Reply
jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sat Jan 01, 2022 11:46 am

Hi all - been away from rc modelling for a while and just back. Have upgraded my 9xr pro to version r222. I am using a IRANGEX multi protocol module in serial mode. I have set up and bound an OrangeRX R820x to it successfully but dont get any telemetry. The usrproto is FrSky, com port is 1, com port invert is 1, com2 function is Telemetry and com1 and com2 baud rate is auto. On the debug screen 9 I can see the TelRxCount increasing and a code of 0700. Any ideas would be very welcome.


User avatar
MikeB
9x Developer
Posts: 17768
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: telemetry fail with IRANGEX module and ORANGERX

Post by MikeB » Sat Jan 01, 2022 12:26 pm

You might try using COM1 not inverted, TelRxCount will always count if something is being received, even if it is incorrectly inverted.
I have done a lot of improvements to handling the MPM. I suggest:
1. Update the Tx to erskyTxR223B5 ( zip file found here: https://openrcforums.com/forum/viewtopic.php?f=7&t=4676).
2. Flash the MPM with firmware that uses "MULTI_TELEMETRY" (not "MULTI_STATUS") as this later version of erskyTx supports that.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

Re: telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sat Jan 01, 2022 8:41 pm

Thanks Mike - I have now updated to erskyTxR223B5 and updated the IRANGEX to multi-stm-opentx-aetr-inv-v1.3.1.69 which is the latest I could find. I set up a brand new model and can connect successfully but still get no telemetry at all. I have tried with both com ports inverted and not inverted. As an aside, I tried using protocol DSM and sub protocol AUTO and it incorrectly set it to X-2f and was not able to bind. I set it to 2-2f and connected and bound straight away.

User avatar
MikeB
9x Developer
Posts: 17768
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: telemetry fail with IRANGEX module and ORANGERX

Post by MikeB » Sat Jan 01, 2022 11:10 pm

If using DSM and AUTO, try binding with the Tx at different distances, 20cm, 50cm, 1M and 2m. During the bind, when successful, you should get a bind response that sets the correct sub-protocol. At some distances this may not be received correctly. Telemetry needs to be working for this to work.

To check the COM port settings are correct, go to the protocol menu and look beside the "BIND". You should see the MPM firmware revision displayed. If it is there, then telemetry from the module to the radio is correctly set. Also, when selecting different protocols and sub-protocols, the names get updated from the MPM.
If the MPM revision is not present, then data is not being correctly received from the module.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

Re: telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sun Jan 02, 2022 10:12 am

It looks like the revision is shown - this is when on COM1 and no inversion. As you suggested, the auto protocol selection was done correctly when the radio was a metre or 2 from the rx. COM2 function is set to TELEMETRY, should i change this to something else?
WIN_20220102_10_10_49_Pro.jpg
WIN_20220102_10_10_49_Pro.jpg (100.93 KiB) Viewed 2891 times
WIN_20220102_09_46_55_Pro.jpg
WIN_20220102_09_46_55_Pro.jpg (93.63 KiB) Viewed 2891 times


User avatar
MikeB
9x Developer
Posts: 17768
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: telemetry fail with IRANGEX module and ORANGERX

Post by MikeB » Sun Jan 02, 2022 1:17 pm

With the data being sent from the module to the radio, to see what is being sent I would like to see a "raw logfile".
See here: https://openrcforums.com/forum/viewtopi ... le#p154139 for how to create a raw logfile. It will be in the "LOGS" directory on the SD card, with an extension of "raw".
Please zip this up and post it for me to see what the module is sending.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

Re: telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sun Jan 02, 2022 1:52 pm

Hi Mike, thanks again for your continued support. Please find attached a zip file for the raw logfile.
Attachments
MODEL01-2022-01-02.zip
(254 Bytes) Downloaded 64 times

User avatar
MikeB
9x Developer
Posts: 17768
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: telemetry fail with IRANGEX module and ORANGERX

Post by MikeB » Sun Jan 02, 2022 3:02 pm

There is no telemetry in there!
I note that the Rx has only short range telemetry (<400m).
It says, in a manual I found on the web, that you may disable the telemetry by having a bind plug on the THR channel during binding. I would think that having a servo (or ESC) connected to the THR channel may have the same effect, so perhaps try binding with nothing in the THR channel.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

Re: telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sun Jan 02, 2022 4:22 pm

Hi Mike, great spot - that was it. I failed to understand the significance of a small red led flashing to indicate telemetry was disabled. Rebound with nothing in the throttle port and telemetry now works. Many thanks and my apologies for my error.

I have noticed that the RSSI value even when the tx is close to the rx is a max of 31. Is there some sort of scaling factor I need to put in somewhere to adjust it? The alarms on the tx dont go down that low.

User avatar
MikeB
9x Developer
Posts: 17768
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: telemetry fail with IRANGEX module and ORANGERX

Post by MikeB » Sun Jan 02, 2022 5:25 pm

Try changing the "UsrProto" to "DSMx". Then the alarms automatically adjust lower.
The RSSI range for DSM is 0-31 (unless you use a Lemon Rx where some send a "real" RSSI value as the "A" value.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

jeffridj
Posts: 8
Joined: Tue May 10, 2016 11:24 am
Country: -

Re: telemetry fail with IRANGEX module and ORANGERX

Post by jeffridj » Sun Jan 02, 2022 8:10 pm

MikeB wrote:
Sun Jan 02, 2022 5:25 pm
Try changing the "UsrProto" to "DSMx". Then the alarms automatically adjust lower.
The RSSI range for DSM is 0-31 (unless you use a Lemon Rx where some send a "real" RSSI value as the "A" value.

Mike
Done and working fine - default alarms go to 20 warning and 18 critical. Thanks for all your help, don't think I would have got there otherwise!


Post Reply

Return to “ersky9xr”