No Splash Screen or Throttle Warning

Hardware Support for the 9XR Pro
CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Sat Sep 05, 2015 10:27 pm

I have 0.5 volts on Q1 and nothing on R7 and R12,when the radio is turned off, or i test wrong?
The diode test on Q1 was not successful with base and emitter.

When the radio is on i got these measurements.
Attachments
IMG_4857.JPG


User avatar
MikeB
9x Developer
Posts: 17371
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Sun Sep 06, 2015 9:14 am

Please do a resistance measurement of R12. It should be 2200 ohms. From the voltages you have measured, it looks to be open circuit.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Sun Sep 06, 2015 10:28 am

IT WORKES, Splash Screen and Alerts are showing. :D

I´ve measured R12 and there was 0 ohms. I replaced the R12. When i unsolder R12 it was broken in half.
Mike you are aresome. Thank you very much!

User avatar
MikeB
9x Developer
Posts: 17371
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Sun Sep 06, 2015 11:29 am

Good, you should also see the "Shutting Down" message when you switch off.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 19413
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by jhsa » Sun Sep 06, 2015 2:50 pm

Bloody well done you two. That's first class troubleshooting and fixing :D

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


Daedalus66
Posts: 1844
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

No Splash Screen or Throttle Warning

Post by Daedalus66 » Sun Sep 06, 2015 4:55 pm

Mike was equally helpful and uncannily on the mark when my installation of a second 3-position switch on a 9XR Pro didn't work. It's nice to see a truly logical mind in action.

darkstar77
Posts: 5
Joined: Wed Apr 13, 2016 3:54 am
Country: -

Re: No Splash Screen or Throttle Warning

Post by darkstar77 » Wed Apr 13, 2016 3:56 am

Sorry to resurrect a thread, but I have the exact same issue as described in this thread, except when I examined the power board, the C1 capacitor is just gone. Would that cause the same issue as described in this thread?

I have all of the same symptons. Trainer cable turns it on.

Obviously, that capacitor missing is a problem, but I don't know the value, or frankly, where to even get a replacement.

User avatar
MikeB
9x Developer
Posts: 17371
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Wed Apr 13, 2016 9:32 am

C1 is 0.1uF (100nF). I don't think that being missing will cause the problem described.
Please measure the resistance values described in previous posts.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darkstar77
Posts: 5
Joined: Wed Apr 13, 2016 3:54 am
Country: -

Re: No Splash Screen or Throttle Warning

Post by darkstar77 » Wed Apr 13, 2016 11:31 am

Thanks for the response Mike, I will check the values.

You don't happen to know if you can buy the RF deck module as a replacement part, do you?

I ask, because I have caused further problems during my troubleshooting. The radio no longer turns on at all. I am going to follow your directions in this thread, in respect to checking R values and voltage at various pins, when I get home from work and post my results.

Daedalus66
Posts: 1844
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

No Splash Screen or Throttle Warning

Post by Daedalus66 » Wed Apr 13, 2016 11:39 am

No sign of replacement boards from HK. Don't count on getting one. If you really have problems you might want to get a new radio while they are available cheap and keep the old one for spares.

By the way, we are not talking about the RF module but the main board, I think.

Edit: Oops, price went back up to $70 on mode 2.

User avatar
jhsa
Posts: 19413
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by jhsa » Wed Apr 13, 2016 12:20 pm

He means the RF deck.. That is the board that holds the RF Module pins, power switch, fuses, etc.. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darkstar77
Posts: 5
Joined: Wed Apr 13, 2016 3:54 am
Country: -

Re: No Splash Screen or Throttle Warning

Post by darkstar77 » Wed Apr 13, 2016 12:34 pm

I do indeed mean the RF deck; just habit to refer to the board as a module.

I was afraid of that as well, I was really hoping I could just buy a $10 part and replace it. Soldering surface mount, for me anyway, is pretty iffy.

For any that is interested, the Mode 1 is still $60 at the international warehouse. I may just order another, and as suggested, keep the current one for parts.

I'm pretty sure I know what I did to damage the one I have at this point; the module wouldn't fit initially, and there may have been some force applied to see if the pins would seat or not. As it turns out, the pins did not line up with the FrSky DJT module, or my Turnigy 9X V2 module, aka FlySky module. I think during this difficulty, I applied enough force to slightly bend the RF deck board and damage one of the surface mount components. I noticed the side with the module pins is completely unsupported by a stand off, which would allow this bend to occur. The radio worked perfectly until I tried to get a module in. It wasn't until I took apart my DJT module to see what was going on, that I realized the pins didn't line up by a non trivial amount; at that point, I believe damage done. Add to that my questionable soldering skills for surface mount, and here I am. So my stupidity is going to cost me a few $$.

I am going to attempt to repair my current RF deck. I'll get a picture or two up with the state of things, along with resistance and voltage readings as soon as I can.

User avatar
jhsa
Posts: 19413
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by jhsa » Wed Apr 13, 2016 1:09 pm

Yes please, a good picture could probably help.. Actually a good resolution picture is as good, or better than a magnifying glass, to find some problems..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darkstar77
Posts: 5
Joined: Wed Apr 13, 2016 3:54 am
Country: -

Re: No Splash Screen or Throttle Warning

Post by darkstar77 » Fri Apr 15, 2016 1:27 am

Well, it took me an extra day, but here is what I have. First up, the best high resolution image I could manage:
9XRPro-RFDeck.jpg
R Values I measured:

R1 100k
R2 47k
R3 2.2k
R5 1
R7 2.2k
R8 2.7k
R9 218k
R10 2.7k
R11 2.2k
R12 102.1k
R14 99.6k
R15 2.7k
R17 2.7k

I was having a hard time getting my meter to settle down for R12 and R14. Yes, R5 measured 1 ohm, I hope that's right.
Attachments
9XRPro-RFDeck-Full.jpg
Last edited by darkstar77 on Fri Apr 15, 2016 3:21 pm, edited 1 time in total.

Daedalus66
Posts: 1844
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

Re: No Splash Screen or Throttle Warning

Post by Daedalus66 » Fri Apr 15, 2016 12:46 pm

Picture link doesn't work.

User avatar
bob195558
Posts: 2262
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: No Splash Screen or Throttle Warning

Post by bob195558 » Fri Apr 15, 2016 1:33 pm

Hi darkstar77,
For your picture try the Full Editor & Preview / Attachments / Add files.

Bob B.
Er9x on 9x radio, with Smartieparts Programmer and TelemetrEZ Board.
ErSky9x on Taranis, Sky9x, 9Xtreme radios.
3D-Printing: (https://openrcforums.com/forum/viewforum.php?f=129).

darkstar77
Posts: 5
Joined: Wed Apr 13, 2016 3:54 am
Country: -

Re: No Splash Screen or Throttle Warning

Post by darkstar77 » Fri Apr 15, 2016 3:22 pm

Image has been directly attached to the post.

pyr8
Posts: 53
Joined: Sun Apr 13, 2014 4:43 pm
Country: -

Re: No Splash Screen or Throttle Warning

Post by pyr8 » Wed May 18, 2016 6:46 am

R12 replacement did it for me as well...thank God I found this post! :)


Post Reply

Return to “Turnigy 9XR PRO radio”