No Splash Screen or Throttle Warning

Hardware Support for the 9XR Pro
CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

No Splash Screen or Throttle Warning

Post by CopterWurst » Wed Sep 02, 2015 1:38 pm

Hello,

my 9XR Pro wont´t show a Splash Screen or a Throttle Warning. I`ve made all the settings to show them. I´ve tried different firmwares but no success.
Can anyody help me plz.
Thank you


User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Wed Sep 02, 2015 2:22 pm

Are you using the firmware it came with, or have you updated it?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Wed Sep 02, 2015 7:01 pm

i`m using the R217 firmware. There was opentx firmware on the radio because i´ve bought it used.
I was trying the r204 but it doesn´t work either.

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 11:13 am

This may be a problem with the EEPROM being incorrect after having openTx on the radio, and not being re-initialised for ersky9x.

Assuming you are only just starting to use this radio, and so don't have any (or not many) models on it, I suggest re-initialising the EEPROM.
The easiest way to do this is to run eepskye on your computer, create a new readio document (File|New), then write this to the radio. This will overwrite the general settings with default settings. After doing this, then calibrate the sticks and pots.
If there are any models showing, and you didn't create them, then delete them.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 11:29 am

No success! There are also no switch warnings! I dont know what i can do more! I´m trying it the last 2 days to get the warnings or the splash screen!
Can it be a hardware problem?


Daedalus66
Posts: 1844
Joined: Tue Dec 27, 2011 8:22 pm
Country: -
Location: Ottawa

Re: No Splash Screen or Throttle Warning

Post by Daedalus66 » Thu Sep 03, 2015 1:32 pm

Tell us more about what you are doing. For example, be sure to use Eepsky9x, NOT Companion. Check that you are using the correct version of the firmware (Ersky9xr NOT Ersky9x). And so on.


Sent from my iPhone using Tapatalk

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 3:06 pm

I´m doing this like here in the tutorial on youtube https://www.youtube.com/watch?v=BOEvvDpWEb8 and its the Ersky9xr Firmware that i use.
On the first start after i´m writing the profile to the radio the alert and the splash screen appear. Then i calibrate the sticks. After i´m turning it off and on no alerts or screen. :-(

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 3:13 pm

You have probably already done this, but power on and go to the radio setup and select general. Make sure that "Splash Screen" is still set to ON.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 3:17 pm

The screen is still sets to on and the alarms too! Thats weird!

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 4:47 pm

OK, next, after power on, press UP LONG, then LEFT. This should get you to the "BOOT REASON" screen. What does this show, including the number in the bottom right corner.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 7:49 pm

On the boot reason screen appears "unexpected shutdown" and in the bottom right corner is 0.
There is a DJT FrSky Module and a turnigy 2200mah lipo in the radio.

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 9:34 pm

That means the radio isn't powering down properly, it should go through a "soft power off" when it makes sure the EEPROM is properly written before it switches the power off itself.
From an unexpected shutdown, as with a watchdog reset, the radio skips the splash screen and warnings and gets running as quickly as possible.
When you switch off, do you see a display of "SHUTTING DOWN"?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 9:50 pm

There is no shutting down Screen!

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 9:59 pm

Sounds like there may be a hardware problem. I'll need to think how to investigate this.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Thu Sep 03, 2015 10:05 pm

OK, got a test. You need a trainer jack plug. With the Tx off, plug the trainer jack into the JR trainer socket. THis should turn the radio on, using the soft power switch, so this will test if this is working.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 10:21 pm

I have no Trainer Plug to Test it but with a normal 3,5mm cable in the jr socket the radio is turning on when the switch is off!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Thu Sep 03, 2015 11:48 pm

When i load a new model with Eepsky9x and flash the firmware. At the first start in the boot reason screen appears "power on". Now when i turn off the radio and on there is "unexpected shutdown".

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Fri Sep 04, 2015 8:50 am

When the radio starts, it reads the EEPROM, and looks for the setting "unexpected shutdown". If you have just updated the EEPROM from eepskye, then this is 0, so you get a normal startup. During startup the setting "unexpected shutdown", is set to 1.
When the radio shuts down properly, it is cleared back to 0. If you are not getting a 'proper' shutdown, it doesn't get cleared.

So a failure to shutdown properly will give the results you describe.

I have another test. Power the radio on holding the two horizontal trims APART. This starts in "maintenance mode". Choose the option "Update Bootloader" (press MENU), but do NOT select a file. Now switch off. The radio should remain ON, until you press EXIT to return the the first screen, held on by the soft power switch. If the radio goes off, then the soft power hardware is not working correctly.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Fri Sep 04, 2015 11:40 am

Ok the radio is turning off.
How i can solve the soft power hardware problem?

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Fri Sep 04, 2015 2:37 pm

The soft power circuitry is on the back board, controlled by a signal from the main board.
You will need to open up the radio.
First look at the 10-way connector of the cable that goes to the back board (plugged in to J6 on the main board). Make sure this is fully plugged in, the control signal is at one end.
If that is OK, you will need to remove the back board in order to look at the circuitry.
To start with, check all the components look to be properly soldered. The ones specific to the soft power are: Q1, Q2, D1, R1, R2, R7, R8 and R12.

Do you have a test meter that can measure resistance and continuity?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Fri Sep 04, 2015 2:58 pm

All cables are finde at the J6.
The back board is the RF Deck, right?
Yes i have a test meter!

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Fri Sep 04, 2015 5:50 pm

Yes, the RF deck. The soft power output pin on the processor is pin 48. You could check this is soldered down on the main board, and using the meter check it connects to pin 1 of J6 and also to the pin 1 on the RF board connector.
If that is all OK, then you will need to remove the RF board to inspect it.

Using the meter as a voltmeter, you could also measure the voltage on pin 1 of J6 (or the RF board) when the radio is on. It should be around 0.6 to 0.8 volts.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Fri Sep 04, 2015 7:52 pm

Pin one on the cable ist the red or black one?
When i connect the pin 48 with the red cable i get a signal on the black there is nothing, also on the rf deck!

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Fri Sep 04, 2015 9:19 pm

On the 9XR-PRO I just looked at the wire is YELLOW!
Pin 1 of J6 is at the end closest to the LCD connector.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Sat Sep 05, 2015 3:36 am

Here is a Picture of J6 and the Pin1. I hope it´s right.
Attachments
IMG_4853.JPG
9XR Pro J6

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Sat Sep 05, 2015 8:16 am

Yes, that's pin 1.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Sat Sep 05, 2015 9:22 am

Ok, i´ve mesured the voltage of pin1 and it´s 3 Volt on the mainboard and the rf deck.

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Sat Sep 05, 2015 10:02 am

You will need to follow this signal through the RF board now. First is to check it connects to the correct components. You will need to remove the RF board to do this.
From the connector on the RF board, the signal goes to R12. The other side of R12 goes to R7, R8 and D1. D1 is a 3.0V zener diode, so the signal does brobably connect, via R12, to that, otherwise you would see 3.3V on the signal.

Check R12 connects to R7, and the other side of R7 connects to Q1. Q1 is an NPN transistor, R7 goes to the base connection and another connection of Q1 is ground.
softpwr.jpg
softpwr.jpg (3.33 KiB) Viewed 5402 times
Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

CopterWurst
Posts: 17
Joined: Wed Sep 02, 2015 1:35 pm
Country: Germany

Re: No Splash Screen or Throttle Warning

Post by CopterWurst » Sat Sep 05, 2015 9:22 pm

Hi Mike,

i´ve checked the connections and i get a signal, the radio is going on. Is that right?

User avatar
MikeB
9x Developer
Posts: 17340
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: No Splash Screen or Throttle Warning

Post by MikeB » Sat Sep 05, 2015 9:57 pm

The power switch connects power always. When Q1 is ON, this turns a FET on that is in parallel with the power switch, so the processor can hold power on after the poawer switch is turned OFF.

The processor does this by just enabling a pull up resistor on the PA8 signal. Since this is around 30K, the voltages on R7 and R12 are close to the base-emitter voltage of Q1, so around 0.6-0.7 volts. If you see 3 volts on these resistors, then Q1 is not pulling the voltage down, either because Q1 has failed, or it isn't connected.

Your meter may have a "diode test" mode, if so, you could check the base-emitter of Q1 to see if it is operating as a diode.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “Turnigy 9XR PRO radio”