Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Everything about the smartie programmer and backlight kit!
Post Reply
Nathan116
Posts: 3
Joined: Wed Nov 30, 2016 1:29 am
Country: -

Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Post by Nathan116 » Wed Nov 30, 2016 1:55 am

Hey everyone,

Sorry if this is posted somewhere already, I sure it is but I couldn't find it and I'm kinda in a rush.

I own a Turnigy 9x with the Smartiepartz board Rev 2.3. I bought it off a guy with OpenTX already flashed on it, I think it was 1.0.9. Today I decided to upgrade to the newer firmwares, 2.0.20. I successfully did that, though now my throttle and Aileron switches don't work. I also realized that that wasn't the most recent firmware, that 2.1.9 is, so I went to try and upgrade and it won't let me. I am flashing under the Thurnigy 9x with stock board. I also have the EZTelemetry board installed.

Any ideas will help!

Nathan


User avatar
Kilrah
Posts: 10745
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Post by Kilrah » Wed Nov 30, 2016 10:29 am

You need to tick the "telemetrez" firmware option before downloading and flashing firmware if you have that board.

For a 9x there are no notable differences between 2.0 and 2.1.

Nathan116
Posts: 3
Joined: Wed Nov 30, 2016 1:29 am
Country: -

Re: Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Post by Nathan116 » Wed Nov 30, 2016 6:16 pm

Kilrah wrote:You need to tick the "telemetrez" firmware option before downloading and flashing firmware if you have that board.

For a 9x there are no notable differences between 2.0 and 2.1.
Thanks for the reply. After spending several hours attempting to flash I did end up figuring that out.

Now I have 1 more question. Since flashing, my Throttle and Aileron switch do not work, they are always stuck on "ON". (Well actually the aileron is always stuck on "on" and the throttle sometimes fluctuated from 50% to "ON" really fast). Anyway I can fix this as on my quad I use a lot of switches for various different modes and all and it would be annoying to go down 2.

User avatar
MikeB
9x Developer
Posts: 17277
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Post by MikeB » Wed Nov 30, 2016 7:07 pm

Please test with the protocol set to both PPM and PXX. I'm not sure if openTx handles the TelemetrEZ board fully. The TEZ board originally supported only the FrSky 'D' protocol at 9600 baud. Later, to support the FrSky 'X' protocol, the firmware in the TEZ board was updated.
FrSky 'D' operates at 9600 baud.
FrSky 'X' operates at 57600 baud.
The later firmware for the TEZ board always uses 57600 for the interface to the processor.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Nathan116
Posts: 3
Joined: Wed Nov 30, 2016 1:29 am
Country: -

Re: Turnigy 9x with SmartiePartz rev 2.3 board having issues flashing OpenTX

Post by Nathan116 » Wed Nov 30, 2016 7:35 pm

MikeB wrote:Please test with the protocol set to both PPM and PXX. I'm not sure if openTx handles the TelemetrEZ board fully. The TEZ board originally supported only the FrSky 'D' protocol at 9600 baud. Later, to support the FrSky 'X' protocol, the firmware in the TEZ board was updated.
FrSky 'D' operates at 9600 baud.
FrSky 'X' operates at 57600 baud.
The later firmware for the TEZ board always uses 57600 for the interface to the processor.

Mike.
I flashed it with the ppm and it worked!

Thanks!


Post Reply

Return to “SMARTIEPARTS PROGRAMMER”