SmartieParts V2.1 now not working

Everything about the smartie programmer and backlight kit!
Post Reply
Posts: 2
Joined: Fri Mar 15, 2013 3:04 pm
Country: -

SmartieParts V2.1 now not working

Post by Slatye » Fri Mar 15, 2013 3:55 pm

Warning: long story. Quick summary first:

- SP 2.1 board with second revision FlySky 9X
- Worked fine until today
- Now very rarely even appears in Device Manager, so avrdude can't find it
- Seems worse when in TX
- When it does connect, it works fine

Full version:
Almost two years ago I bought a V2.1 SmartieParts board and installed it in my 9X. That went fine; it let me upgrade to ER9X and gave me a backlight. The programming side didn't get any further use until about two months ago, when I installed the latest ER9X firmware and had a quick play with eePe to backup the models. Today I tried to use it again to load the V911 model data, but eePe gave me an error:

"avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc"

The USBasp device did not appear in Windows Device Manager. I tried three different USB cables, two USB ports (one on the mainboard, one on a PCIe USB3.0 card), and three copies of Windows (two WinXP 32-bit, one Win7 64-bit). No sign of anything happening.

I figured that this was most likely not a connection issue with the TX itself, since the SP board should still respond even if the TX is completely stuffed. To test the SP board, I removed it from the TX and plugged it in separately. Most of the time the same symptoms occurred. Sometimes it did appear in Device Manager, although often it took 30+ seconds for the device to be detected. Once it was detected, the eePe error message changed to the usual "target not responding" one (obviously because the SP board was not connected to the TX at the time). I would have suspected an intermittent connection with the USB cable, but once it did detect no amount of moving the wires around would cause it to disconnect again. All the solder joints look fine, both on the board and the USB connector. No wires touching, all plugs are fully inserted.

Putting the SP board back into the TX, I was unable to get any response from it; no sign of any connection (although the TX turned on when the USB cable was connected, as expected). I forgot about that and went on with other stuff; about half an hour later the Windows "found new hardware" box popped up asking to install the USBasp drivers again. I've got no idea why that would happen, but I took advantage of the opportunity to upload the new EEPROM with eePe. That worked perfectly, so the connection appears to be reliable. However, when I unplugged it and plugged it back in, it once again failed to appear (and has now continued to do so for about ten minutes).

I should mention that the TX itself has been absolutely fine; it's behaving just as expected. The only hardware modifications have been the SP board and replacing the 78L05 regulator with an XC6202 (because it's got a lower dropout voltage). The TX pack is a 3S 1800mAh LiFePO4 one, and there's definitely no risk of that coming into contact with the USB connector.

  • Unlikely to be a dodgy connection with the TX mainboard. In this case I'd expect the USBasp to connect but then fail to program/verify. The problem also continued to occur with the SP board removed from the TX completely.
  • Unlikely to be a dodgy connection to the PC, for similar reasons. Once it does connect, the connection appears to be reliable.
  • Unlikely to be a software issue on the PC, because it'd really have to be a Windows error that affects both XP and 7.
Any ideas? Should I solder the 10-pin header onto the SP board and reflash the USBasp firmware?

User avatar
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: SmartieParts V2.1 now not working

Post by gohsthb » Fri Mar 15, 2013 7:53 pm

There should be no need to reflash the firmware. Most likely it is either your usb cable, or the short jumper with the usb plug for the smartieparts board. Even though all of the connections look fine, go ahead and resolder them anyway. Also check that the wires to the board connector aren't coming out or frayed. There should be some piece of plastic you can move that will allow the wire to slip out of the connector. Look closely and you should see it. One final thing, the reason windows asked to reinstall the driver is probably because you plugged the device into a different port. To windows if you plug the same device into a different port, it is an entirely different device!

Posts: 2
Joined: Fri Mar 15, 2013 3:04 pm
Country: -

Re: SmartieParts V2.1 now not working

Post by Slatye » Sat Mar 16, 2013 10:50 am

Thanks very much for the reply.

It now seems to be working reliably, with the same PC/OS/USB cable/USB port, although I've got no idea why. Not working last night, working now (five times in a row, connected and disconnected with no problems). I haven't changed anything at all between those two. This is annoying; I much prefer things that fail consistently.

On Monday I'll resolder all the USB-related connections in the hope that this will fix it permanently. They do look okay for now, although some have a little bit more of the conductor exposed near the solder points than I'd like to see (only 2mm or so, but still too much for comfort). I might actually replace the four USB wires nice silicone-coated ones, since that eliminates the possibility that there's a break in one of the wires and they're also much nicer to work with. I've got access to a crimping tool so I can replace the connector

Regarding the Windows USB stuff: I've noticed that before with USB drives; and every now and then installation on one port fails with the result that the USB drive never works with one port while others are perfectly happy on that port.

Anyway, at least for now it seems to be working fine.

Posts: 882
Joined: Thu Dec 29, 2011 6:11 am
Country: -

Re: SmartieParts V2.1 now not working

Post by s_mack » Fri Apr 12, 2013 4:18 pm

I'm sorry I missed this. Did you get this fully resolved to your satisfaction?

In general, this may not even be a hardware issue at all. I've personally experienced times when the programmer wouldn't work until I rebooted the machine. I also have a usbasp (generic, not mine) that exhibits the behavior you describe where it works on one USB port but not another. yet another usbasp works on all ports. I think its small issues with the drivers. That's one problem with opensource... if its a bug that's difficult to root out and/or easy to get around and/or simply not reproducable by the developers (which is not me!) then it can go a long time without ever being fixed.

Re: silicon. Just an FYI, but I switched to silicon for Rev 2.4 for flexibilty. however, you say it "eliminates the possibility that there's a break in one of the wires". This is not at all the case. In fact, silicon wires increase the possibility of having a wire break because they can physically bend so easily. That doesn't mean the wire inside is any more flexible or less prone to breaking! So it gives the impression that you can get away with tighter turns, but really the wires may still break. But copper is very maleable so really the liklihood of breaking the internal wires in any kind of wire is very low. Its also VERY easy to confirm if you have a broken wire... use a multimeter and check for continuity.

Post Reply