Help flashing Turnigy 9X

Everything about the smartie programmer and backlight kit!
Post Reply
CrocuS
Posts: 3
Joined: Mon Jul 23, 2012 6:31 pm
Country: -

Help flashing Turnigy 9X

Post by CrocuS » Mon Jul 23, 2012 6:38 pm

First of all, hello to everyone :)
I received today my Smartieparts add-on board 2.2 for my new Turnigy 9X. Mounted, installed the drivers and when I try to flash it this error appears:


=================================================================================
AVRDUDE Iniciado\n
C:/Program Files (x86)/eePe/avrdude.exe -c usbasp -p m64 -P usb -U eeprom:r:C:/Users/GONALO~1/AppData/Local/Temp/temp.hex:i
=================================================================================

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude.exe done. Thank you.


=================================================================================
AVRDUDE done - exit code 1
=================================================================================

I checked and the board is V2... Can anyone help me please?

Thank you!


User avatar
Crucial
Posts: 581
Joined: Tue Dec 27, 2011 6:56 pm
Country: -
Location: SE WI, USA

Re: Help flashing Turnigy 9X

Post by Crucial » Mon Jul 23, 2012 7:02 pm

Did you turn your radio on before flashing?

CrocuS
Posts: 3
Joined: Mon Jul 23, 2012 6:31 pm
Country: -

Re: Help flashing Turnigy 9X

Post by CrocuS » Mon Jul 23, 2012 7:07 pm

I think I tried with radio on and off...

User avatar
gohsthb
Posts: 1412
Joined: Wed Dec 28, 2011 2:32 pm
Country: -
Location: Naperville, IL

Re: Help flashing Turnigy 9X

Post by gohsthb » Mon Jul 23, 2012 8:39 pm

Double check the installation of the smartieparts board. Check the pads on the 9x main board where the pogo pins connect to. They may need to be cleaned with either a pencil eraser or alcohol. Then re-install the board making sure it goes down flat, and all of the spacers are touching both boards at the same time.
-Gohst

User avatar
Crucial
Posts: 581
Joined: Tue Dec 27, 2011 6:56 pm
Country: -
Location: SE WI, USA

Re: Help flashing Turnigy 9X

Post by Crucial » Mon Jul 23, 2012 8:56 pm

The new Smartie Parts board requires the radio to be turned on when flashing. Please try it again with it turned on to be sure.

Gohst's suggestions are valid as well but try it with it turned on first to avoid having to take it apart again. If you do take it apart again can you snap a pic of your board without the smartie parts board installed?


Post Reply

Return to “SMARTIEPARTS PROGRAMMER”