SCK error and Target dosn't answer

Post Reply
Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

SCK error and Target dosn't answer

Post by Anhydrite » Sat Feb 23, 2013 5:34 pm

Hi,

I am trying to flash my 9x with open 9x using Companion9x.
I have checked the wireing..and I have a V2 board.

I am using the HK USBasp.
I have made no modifications to my transmiter.

When I run Companion9x and try to flash I get the following error.......

----------------------------------------------------------------------------------------------------------------
Started AVRDUDE
C:/Program Files/companion9x/avrdude.exe -c usbasp -p m64 -U flash:w:C:/Users/bobby/Downloads/open9x-stock-templates-PXX-ppmca-autoswitch-pgbar-imperial-en.hex:i
=================================================================================

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude.exe done. Thank you.


=================================================================================
AVRDUDE done - exit code 1
=================================================================================
---------------------------------------------------
I have resoldered all my connections just to make sure and I have tried to jumper the resister in my radio and nothing helps.

Any ideas?

Thanks

User avatar
jhsa
Posts: 18012
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SCK error and Target dosn't answer

Post by jhsa » Sat Feb 23, 2013 5:43 pm

Anhydrite wrote: I have resoldered all my connections just to make sure and I have tried to jumper the resister in my radio and nothing helps.

Any ideas?

Thanks
Which resistor in the radio are you trying to jumper? :o

A good picture of of board showing all your conections and showing the connections to the programmer too if possible??

Thanks

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

Re: SCK error and Target dosn't answer

Post by Anhydrite » Sat Feb 23, 2013 6:05 pm

Image
Image
Image

I have tripple checked the wireing. Not sure why target dosn't answer.

I unsoldered and resoldered to ensure no cold solder joints.

User avatar
thomas9x
Posts: 230
Joined: Wed Feb 29, 2012 3:12 am
Country: -
Location: USA

Re: SCK error and Target dosn't answer

Post by thomas9x » Sat Feb 23, 2013 6:47 pm

Please post clear close-up photos of BOTH sides of the USBasp programmer.

Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

Re: SCK error and Target dosn't answer

Post by Anhydrite » Sat Feb 23, 2013 6:57 pm

Image
Image
From HK...


User avatar
thomas9x
Posts: 230
Joined: Wed Feb 29, 2012 3:12 am
Country: -
Location: USA

Re: SCK error and Target dosn't answer

Post by thomas9x » Sat Feb 23, 2013 7:42 pm

Good, I don't see any of the unwanted protection resistors on MOSI/MISO/RST/SCK. So the problem is elsewhere. Perhaps it would be wise to check the voltage on your 9X board during programming to see if it is getting the 5V. Other than that, maybe a different USBasp is needed.

Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

Re: SCK error and Target dosn't answer

Post by Anhydrite » Sat Feb 23, 2013 7:49 pm

The 9x screen shows 4.6v when the USB is plugged in...

Additionally the low voltage alarm does NOT beep when plugged into the programmer.

User avatar
thomas9x
Posts: 230
Joined: Wed Feb 29, 2012 3:12 am
Country: -
Location: USA

Re: SCK error and Target dosn't answer

Post by thomas9x » Sat Feb 23, 2013 8:30 pm

The 9x screen shows 4.6v when the USB is plugged in...
That voltage is fine.
Additionally the low voltage alarm does NOT beep when plugged into the programmer.
That is correct, the beeper does not work when the 9x is powered by USB.

If you are sure that all your soldered connections are correct then perhaps it is time to try a different USBasp programmer.

Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

Re: SCK error and Target dosn't answer

Post by Anhydrite » Sun Feb 24, 2013 5:52 am

I tested everything with a Multimeter and it appears the solder joint that connects the ATMEL chip to the 9x has a cold solder on the RST pin. I should have done this earlier...considering the bad workmanship overall of the radio. It just lookd good when I looked at it and I didnt have a meter. Found one today.
Now to try to fix that solder joint with my aweful soldering iron.

User avatar
ShowMaster
Posts: 4315
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SCK error and Target dosn't answer

Post by ShowMaster » Sun Feb 24, 2013 4:53 pm

May I suggest trying eepe before you do anymore soldering. As long as the programmer pins and the 9x solder points match up using your ohm meter to verify continuity to the correct pads and to the m64 pins if you want to go the whole way, you're good to go there.
Next being that you're using the HK programmer that usually works if the driver is installed (check device manager) eepe once told the correct port should work.
Some remove the yellow/orange colored reset cap lower right but I've never had to do that do far in 8 conversions.

Unless you're programmer is defective, it's got to be a driver, or program port config, or wiring error, or last, the reset line cap.
All covered already in hour posts but do it all again slowly measuring all wiring point to point, checking that you are correct there, no shorts.
The fact that you see 4.6v on the LCD is good! This is a good number for powering the m64 for programming from your USB port and programmer.
You're real close!
Try eepe and er9x as a change and see if that works. Then try C9x again if it goes. You've got to narrow it down to software or hardware issues.
SM


Sent from my iPod touch using Tapatalk.

Anhydrite
Posts: 8
Joined: Thu Jan 17, 2013 7:18 pm
Country: -

Re: SCK error and Target dosn't answer

Post by Anhydrite » Sun Feb 24, 2013 5:20 pm

Hardware was the issue. RST pin on 9x 64 chip not solderd properly. No conituity with multimeter test today. Fixed solder and now has conituity.
Flashed first try after fixing faulty solder.

Thanks for looking over my setup and throwing out ideas.

User avatar
jhsa
Posts: 18012
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SCK error and Target dosn't answer

Post by jhsa » Sun Feb 24, 2013 5:23 pm

Great.. that was a good catch.. congratulations.. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4315
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SCK error and Target dosn't answer

Post by ShowMaster » Sun Feb 24, 2013 7:19 pm

Good find!
I always check right to the pin from the source as you did when all else fails. The programmer and wiring if correct works right off. Get that fight and the driver and program config and it's a winner.
You're ready to help others now that you've passed the trouble shooting test.
SM


Sent from my iPod touch using Tapatalk.

pyr8
Posts: 53
Joined: Sun Apr 13, 2014 4:43 pm
Country: -

Re: SCK error and Target dosn't answer

Post by pyr8 » Mon May 05, 2014 9:37 pm

SOLVED!!!!

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1

The issue in my case was that the 10 PIN to 6 PIN adapter was not soldered properly! Check your solder points on your adapters! :shock:

Post Reply

Return to “PROGRAMMERS”