Voice files stop playing.

Post Reply
Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Voice files stop playing.

Post by Daveh » Sun Sep 17, 2017 2:00 pm

I have OpenTx 2.2.0 loaded onto my 9XR Pro transmitter. It's a new installation to me. I have set up some fairly extensive glider mixes, using two flight modes. The "Amber" sound pack is loaded, playing wav files for when the flight mode switch is changed between the two modes and also continuously at 3s intervals when the throttle stick is below mid point in flight mode 2 (it becomes the flap control input for CH6).
It seems to work well, but after a few minutes, the voice files don't get played. Other sounds using the buzzer and the haptic, work all the time. When powered off/on, it's OK for a while again. I can't find a particular switch/input sequence that I can say causes this, is this something that is a known feature?

User avatar
Kilrah
Posts: 9608
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Voice files stop playing.

Post by Kilrah » Sun Sep 17, 2017 2:12 pm

Can come from a faulty SD card, try to format and reload that one or to use another one.

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Sun Sep 17, 2017 9:43 pm

Thanks for that suggestion. So easy to try this... will buy a new card and try it again.

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Mon Sep 18, 2017 5:34 pm

New card (tested). Still the voice stops after a while. Noticed this time that the beeps stopped also but the haptic continued.
Replaced the Amber voice pack with the original for 2.2.0.
Voice (and beeps) stops after around 8 mins. Does not appear to be related to any particular function input.
Seems just time... power off/on and it restarts.

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Thu Sep 21, 2017 6:21 pm

After a while playing around with this. it seems that the sounds/voice stops after the combined haptic/beep warning (as set in the mix window) has sounded. The loss of sound is not immediate, but can happen several seconds later. Tx seems to be stable once all combined haptic/beep events were deselected. So far, on the bench, it has managed five or six ten minute runs without stopping. On one run it did stop near the 10min mark, not sure what caused this and have been unable to recreate it. I will try it in the field.


Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Fri Sep 22, 2017 3:00 pm

So, in the field, it's no different. Is there a pointer to indicate the part of the firmware that runs sound files is stopped? would be really helpful if I could determine that the hardware was at fault.

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Fri Sep 29, 2017 5:03 pm

In an effort to move somewhere on my problem, I tried:
Reloaded and different sound packs.
A different 9XR Pro Tx with its own SD card.
Regenerated and reloaded 2.2.0
Tried 2.1.9 but found model configs reported as "not compatible" (I can see no reason that 2.1.9 might fare any better).
Tried different model configs (for other similar models, edited from the same original config).
Non of these actions had a definite effect, except that on my original FW (2.2.0) a simple 4 ch model appears to run for several minutes longer until the audio crashes/disappears.
Any suggestions?

Daveh
Posts: 50
Joined: Wed Aug 02, 2017 7:05 pm
Country: -

Re: Voice files stop playing.

Post by Daveh » Fri Sep 29, 2017 10:11 pm

Having listed the things I'd tried, it seemed that there's more easy things to eliminate. If a simple model config fails on 2.2.0, I can at least try the same on 2.1.9.
So far it has outlasted the same on 2.2.0 and run for an hour. Maybe worthwhile a more complex definition.
I wonder if this post is in the right forum section.

Post Reply

Return to “openTx model setup”