Search found 53 matches

by pyr8
Tue May 17, 2016 7:11 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

jhsa wrote:hmm, disassemble it and check for bad soldering on the power switch or near..

João
Did that already...I actually re-flowed the solder on the power switch thinking that might be the issue with the witch at least!
by pyr8
Tue May 17, 2016 6:39 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

I'm checking exactly what happens when you switch off the power when running normally. Does the radio go off immediately, or is there around a 0.5 second delay? Mike. Mike, I'm getting ready to throw this remote in the garbage!!!!!! :evil: This morning I picked it up and it was working flawlessly o...
by pyr8
Tue May 17, 2016 12:35 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

I can't see anything wrong with those tests, try this one: Hold the two horizontal trims APART, and power the radio on (ersky9x). This will start the radio is "maintenance mode". Select "UPDATE BOOTLOADER" with the menu key. Now switch the power off. The correct response is for the radio to remain ...
by pyr8
Wed Apr 27, 2016 5:16 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

Mike, Ok, so i plugged a "JR" to USB adapter (used for connecting to my PC for flight simulation) into the unit. When plugged in, the 9XR Pro turns on with power switch off. When I go to the "Trainer" screen, I get "Slave". If I turn the radio on with power button while on the "Trainer" screen (and...
by pyr8
Mon Apr 25, 2016 4:04 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

Mike, Ok, so i plugged a "JR" to USB adapter (used for connecting to my PC for flight simulation) into the unit. When plugged in, the 9XR Pro turns on with power switch off. When I go to the "Trainer" screen, I get "Slave". If I turn the radio on with power button while on the "Trainer" screen (and ...
by pyr8
Mon Apr 25, 2016 2:27 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

If you have ersky9x installed, and you switch the power off, do you see a screen showing "Shutting Down"? If the radio doesn't shut down properly, then on restart it is assumed something went wrong and the startup splash and checks are skipped to get the radio operating in model control mode as fas...
by pyr8
Sun Apr 24, 2016 3:26 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

The strange thing is that if I load the firmware that shipped with the 9xr Pro (ersky9xr_rom_r212) - (Bootloader 1.3), the voice works, which means that the SD card is readable with that firmware. However, the splash screen appears on the first boot after install, and not after that (voice will alwa...
by pyr8
Sun Apr 24, 2016 4:10 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

Ok, I just used one of the nightly builds of OpenTx Companion (2.2ON288) to flash a backup of a OpenTx .bin (latest non nightly build). The firmware flashed OK, hoever did not give the "WARNING Bad EEprom Data" warning, and the SD card was there, until I power cycled the remote and it was gone again...
by pyr8
Sun Apr 24, 2016 4:03 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

Have you tried installing the bootloader first from ersky9xr .bin file, then flashing firmware for same?
by pyr8
Sun Apr 24, 2016 3:05 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

OK, I now have the 9XR Pro "un-bricked" and the latest version of OpenTx installed. My original issue is back...not having access to the micro SD card file structure while navigating within the remote. I can access via USB tethered to my PC and I have tried 2 separate SD cards thinking it might be a...
by pyr8
Fri Apr 22, 2016 1:28 am
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Re: Unbrick 9XR Pro after reseting Atmel chip - How ????

That guide is the way to do it. If all seemed to work, did you forget to "Execute" the script “Boot from Flash (GPNVM1)”? Mike. That did the trick Mike...thank you for pointing that out!!!!!!!! :D :D :D I must have read the tutorial 5 times and missed the part about “Boot from Flash (GPNVM1)” - :oo...
by pyr8
Thu Apr 21, 2016 8:03 pm
Forum: Turnigy 9XR PRO radio
Topic: Unbrick 9XR Pro after reseting Atmel chip - How ????
Replies: 31
Views: 4809

Unbrick 9XR Pro after reseting Atmel chip - How ????

I used the reset button on the bottom of my 9XR Pro (next to the usb and SD card slot) thinking not knowing it would erase the Atmel chip (stupid me) ! I have tried to restore the unit using a guide I found here on the forums (9XR Pro Using SAM-BA to restore bricked Tx 2014-02-12.pdf) After going th...
by pyr8
Mon Apr 18, 2016 3:11 pm
Forum: OpenLRSng
Topic: [SUPPORT] OpenLRSng support thread
Replies: 147
Views: 70526

Re: [SUPPORT] OpenLRSng support thread

I am having an issue with "Channel 1" not working on a "OrangeRx Open LRS 433MHz".

No matter what pin I assign channel 1 too, I cannot get it to work.
Anyone have any ideas?
by pyr8
Wed Mar 02, 2016 7:06 pm
Forum: Turnigy 9XR PRO radio
Topic: 9xr pro & OrangeRX rx/tx modules & telemetry
Replies: 21
Views: 5881

Re: 9xr pro & OrangeRX rx/tx modules & telemetry

I thought openTx supported MavLink on all platforms, but it seems it only has it for the 9X/9XR. For ARM processors, it relies on either a Teensy or an Arduino to convert the telemetry data on the receiver. I'll see how soon I might be able to get native MavLink support into ersky9x. At what baudra...
by pyr8
Wed Mar 02, 2016 5:17 pm
Forum: Turnigy 9XR PRO radio
Topic: 9xr pro & OrangeRX rx/tx modules & telemetry
Replies: 21
Views: 5881

Re: 9xr pro & OrangeRX rx/tx modules & telemetry

Modified 9XR (to allow receiving of Mavlink data) with OpenTX firmware, APM with OrangeRX TX & RX (Modified TX).

These two links are a good place to start.

http://goo.gl/JFZLrm
http://goo.gl/3pbQEu
by pyr8
Wed Mar 02, 2016 8:08 am
Forum: Turnigy 9XR PRO radio
Topic: 9xr Pro Opentx 2.0 Sd Card File Structure
Replies: 10
Views: 2248

Re: 9xr Pro Opentx 2.0 Sd Card File Structure

Kilrah wrote:Name must be 6 chars max and file must be in SOUNDS\en.
Yup, renamed it to 6 chars and it's all good now. Thanks! :D
by pyr8
Wed Mar 02, 2016 8:00 am
Forum: Turnigy 9XR PRO radio
Topic: 9xr Pro Opentx 2.0 Sd Card File Structure
Replies: 10
Views: 2248

Re: 9xr Pro Opentx 2.0 Sd Card File Structure

Kilrah wrote:A special functiuon with
ONE - Play Track - <file>
Thanks for the reply!

For some reason the <file> does not show up on the remote via the 9XRPro menu. I have placed the .wav file in both the SOUNDS/en/ folder as well as SOUNDS/en/SYSTEM/ for testing. It wont populate to the list on the radio.
by pyr8
Wed Mar 02, 2016 5:51 am
Forum: Turnigy 9XR PRO radio
Topic: 9xr pro & OrangeRX rx/tx modules & telemetry
Replies: 21
Views: 5881

Re: 9xr pro & OrangeRX rx/tx modules & telemetry

At the moment ersky9x doesn't support native MavLink telemetry data. I've just added support for MavLink over FrSky, by using an Arduino to convert between them. From that Arduino code I will be adding native Mavlink support to ersky9x. Mike. Mike, are you saying that you are working on having the ...
by pyr8
Wed Mar 02, 2016 5:32 am
Forum: Turnigy 9XR PRO radio
Topic: 9xr Pro Opentx 2.0 Sd Card File Structure
Replies: 10
Views: 2248

Re: 9xr Pro Opentx 2.0 Sd Card File Structure

How do you get the 9XR-PRO to announce the name of the craft when switcing profiles?

I have created the .wav file and put it on the root of the SD CARD in /SOUNDS/en/
by pyr8
Tue Sep 22, 2015 4:05 pm
Forum: openTx
Topic: [MAVLINK] Input needed for MAVLINK ArduPlane / ArduCopter.
Replies: 60
Views: 22935

Re: [MAVLINK] Input needed for MAVLINK ArduPlane / ArduCopte

Hi pienk, I loaded latest OpenTX with MAVLINK support via Companion9x. My radio is Turnigy 9x with telemetry mod hooked to 3DR clone 433MHz radio for telemetry. Unfortunately I can't get any telemetry when I go to mavlink screens in 9x. At what baudrate telemetry works and how can I set it. When I ...
by pyr8
Mon May 05, 2014 9:37 pm
Forum: PROGRAMMERS
Topic: SCK error and Target dosn't answer
Replies: 13
Views: 10769

Re: SCK error and Target dosn't answer

SOLVED!!!!

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1

The issue in my case was that the 10 PIN to 6 PIN adapter was not soldered properly! Check your solder points on your adapters! :shock:
by pyr8
Mon May 05, 2014 8:29 pm
Forum: PROGRAMMERS
Topic: Updating Usbasp firmware using Eepe in Windows
Replies: 119
Views: 44202

Re: Updating Usbasp firmware using Eepe in Windows

Hey Guys.... I have flashed the firmware on my unit using "Main.hex", however I am now getting the following error in Companion9X: __________________________________________________________________________________ avrdude.exe: error: programm enable: target doesn't answer. 1 avrdude.exe: initializat...
by pyr8
Tue Apr 15, 2014 12:34 am
Forum: OpenLRSng
Topic: [SUPPORT] OpenLRSng support thread
Replies: 147
Views: 70526

Re: [SUPPORT] OpenLRSng support thread

I'm having an issue connecting to the "RX Module" through openLRSng. I am able to flash the firmware on both the TX and RX, and I am able to configure the TX, however when I try to connect to the RX via the TX radio link, the "timeout" counter freezes. Anyone have any ideas on the issue? Using Orang...

Go to advanced search