Search found 243 matches

by RightRudder
Fri Mar 15, 2013 1:26 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: OpenXVario flight reports
Replies: 175
Views: 21019

Re: OpenXVario flight reports

Good to hear the vario is working nicely with the DLG. That it detects the small stick thermals tells a lot. Way to go guys this is awesome! I finally received my GY-63 boards but no sign of the arduino boards yet. The only glider I currently have is not much of a thermal machine. More of a warmline...
by RightRudder
Thu Mar 14, 2013 8:44 pm
Forum: openTx
Topic: Fas100 - wrong current measurement
Replies: 11
Views: 1758

Re: Fas100 - wrong current measurement

I think what happened is that now that FrSky have a superior product ie the FAS-100 they were having a hard time getting rid of stock on the older FAS-40. So they changed the shunt so that it could handle 100 amps safely and maybe adjusted the firmware to get the correct readings with the new shunt ...
by RightRudder
Thu Mar 14, 2013 12:22 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

No it is not an FAS-100. I get a significant voltage drop across the shunt when I run high current. The FAS has a hall sensor so there is no loss. For example using current meter (not a small one for in the plane) which has hall sensor I can get 55 amps with a fresh battery but when I put the funky ...
by RightRudder
Thu Mar 14, 2013 12:09 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

So here is the official response from Eva at FrSky: Dear Joe, Thanks for your e-mail and support. There is one batch of 120pcs FAS-100 provided to HobbyKing that with the same PCB size as FAS-40 but they are true FAS-100 and could measure 100A without problem. They have been well tested, but were pu...
by RightRudder
Thu Mar 14, 2013 12:08 pm
Forum: openTx
Topic: Fas100 - wrong current measurement
Replies: 11
Views: 1758

Re: Fas100 - wrong current measurement

So here is the official response from Eva at FrSky: Dear Joe, Thanks for your e-mail and support. There is one batch of 120pcs FAS-100 provided to HobbyKing that with the same PCB size as FAS-40 but they are true FAS-100 and could measure 100A without problem. They have been well tested, but were pu...
by RightRudder
Tue Mar 12, 2013 6:43 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

You might be able to tell by looking at it. One hint is the 100 is larger than the 40 and if it is a 40 with a 100 label then the label is too big and is bent a little around the corners but if it is on an actual 100 it will lie totally on the flat. Look at the pictures.
by RightRudder
Tue Mar 12, 2013 6:05 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

There is also a guy here on the 9x forums who reported a FAS-100 not showing amps properly.
by RightRudder
Tue Mar 12, 2013 4:22 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

Even more surprising, Frsky has not responded at all. It's only a few days though. Perhaps they are looking into it?
by RightRudder
Tue Mar 12, 2013 3:39 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

So the official response from Hobbyking was; Glad you figured it out. Ticket resolved! No sorry for our mistake here's a refund, no here's the proper part, not even a promise to warn recent customers they could have a fire if they try to run 100 amps. Shocking. There's already at least two others I ...
by RightRudder
Tue Mar 12, 2013 3:28 pm
Forum: openTx
Topic: Fas100 - wrong current measurement
Replies: 11
Views: 1758

Re: Fas100 - wrong current measurement

I made further investigations. I have tryied with a FAS-40 and the reading on the 9x display is correct. The problem is related to the FAS-100. I assume is my new fas-100 that is not working correctly. STefano I recently ordered FAS-100 but received FAS-40 labeled as FAS-100. The BATT and ESC posit...
by RightRudder
Sun Mar 10, 2013 9:21 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

What the &%&(/?? Is frsky doing that?? or is HK doing that? :o Yes. I don't know who is responsible but at 100 amps something's gonna get hot and HK and Frsky might want to send an advisory out to anyone affected. I hope they send me my two 100 amp sensors for free as a thank you for figuring out t...
by RightRudder
Sun Mar 10, 2013 9:15 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: openXvario development
Replies: 251
Views: 34649

Re: openXvario development

Sorry this got off topic over here. I don't know how (or if I can) but some of these posts could be moved over to this thread:

viewtopic.php?f=23&t=1075&p=43107#p43107
by RightRudder
Sun Mar 10, 2013 9:13 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

SOLVED! It turns out the BATT and ESC positions are reversed between the FAS-40 and FAS-100. Hobbyking sold me FAS-40 with FAS-100 labels! I followed the labels of course, so it meant I was sending current through the device the wrong way. So I reversed my connectors and now everything works perfect...
by RightRudder
Sun Mar 10, 2013 8:43 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Yes I have opened dialog with both HK and Frsky. I will let you know what transpires.
by RightRudder
Sun Mar 10, 2013 8:40 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Well That was it! WATCH OUT GUYS HOBBYKING IS SELLING FAS-40 MASQUERADING AS FAS-100!

Thanks very much to those who spent time trying to help me with this frustrating and weird problem.

Joe
by RightRudder
Sun Mar 10, 2013 8:31 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Oh man. I just surfed over to aloft and compared images of the FAS-40 and FAS-100. Check out the labels where it shows the ESC and battery connections. Just the opposite! It makes sense with what you said about not showing negative current. I think I only need to reverse my connectors and at least I...
by RightRudder
Sun Mar 10, 2013 7:30 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

mmhhmmm. Why would hobbyking sell me a FAS-40 packaged as a FAS-100? I cut the heatshrink to expose the board but it is definitely labeled as a FAS-100 on the outside. Might have been a goof up at the factory. I wonder what happens when you put FAS-100 firmware in a FAS-40? That might explain everyt...
by RightRudder
Sun Mar 10, 2013 5:12 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Do you have a picture of this hall sensor? My sensor appears to have a shunt soldered in the red + line on both sides of the board. There is definitely a mv signal across the device as current is drawn. Here is top and bottom shots of what I have.
FAS-100_top.JPG
FAS-100_bottom.JPG
by RightRudder
Sun Mar 10, 2013 4:14 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Yes I soldered the connectors myself but they are correct. I removed the shrink wrap and used my dvm to verify that a voltage is developed across the shunt when current is flowing. It is really strange. One thing I notice is that the label says FAS-100 but the silkscreen on the board says FAS-40 Rev...
by RightRudder
Sat Mar 09, 2013 11:26 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: openXvario development

Black wire to Rx G, Yellow wire to Rx on Rx. I know what could it be? It's kinda driving me nuts here. I even though about a ground loop, so tried just the yellow wire. Same. fas volt ok FAS amp nothing.
by RightRudder
Sat Mar 09, 2013 10:40 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: openXvario development
Replies: 251
Views: 34649

Re: openXvario development

Interesting. I just looked at the idle data without changing any actual voltage. I have been experimenting sending data from a terminal program to the D8R-II+ using the hub protocol from the datasheet. I can change the values easy enough on the 9x display. The current seems to behave as the datashee...
by RightRudder
Sat Mar 09, 2013 6:47 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: openXvario development
Replies: 251
Views: 34649

Re: openXvario development

Ok I can confirm that the data coming out of the FAS telem port is only once per second. I see it on oscilloscope. I am having trouble actually getting the FAS telemetry working properly with my 9x. I have details on a FAS thread, but for sure the packets are only ~ 1hz rate.
by RightRudder
Sat Mar 09, 2013 6:34 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

Ok so I tried again with the hub. Maybe I had a cable not plugged correctly last night. This time though I get a voltage reading which makes sense, goes down when I open throttle but the current, power and power consumption still are wrong. Never see more than 0.2A on a motor that ca draw 55 amps at...
by RightRudder
Sat Mar 09, 2013 5:53 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

Ok so here's the news. On my oscilloscope I can easily see the data coming out the telemetry port of the FAS-100. The strange thing is in between the packets the signal is 0v which to me looks like the serial data is not inverted ie not rs-232 logic. I can't read anything out of the data out which i...
by RightRudder
Sat Mar 09, 2013 1:56 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

Yes both the FAS I tried have the LED blinking. I have to take my dog to the vet right now but later I can try with a scope and see if the port is putting anything out. I see a value being shown for A2 even though I have nothing connected to A2 input on rx. Do I need to set any range for A2 if I am ...
by RightRudder
Sat Mar 09, 2013 12:49 pm
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

Yes I tried it on hub when I used the hub and when ran the serial line direct from the FAS to the Rx I tried with hub and also with none.
by RightRudder
Sat Mar 09, 2013 3:54 am
Forum: FRSky Telemetry Mods
Topic: FrSky FAS-100 Telemetry Amperage Sensor
Replies: 94
Views: 24106

Re: FrSky FAS-100 Telemetry Amperage Sensor

I am not geting any data from FAS-100. I tried with the hub and without hub. I know the telem is working as I can see data from alti sensor on hub. I set telem screen user data section for FAS current and voltage. I have two FAS-100 sensors brand new and they both behave the same. I am using a sky r...
by RightRudder
Fri Mar 08, 2013 5:50 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: openXvario development
Replies: 251
Views: 34649

Re: openXvario development

The easiest might be to use rs232 between the FAS100 and receiver, as firstly there's no guarantee the FAS100 will forward anything it receives on the data in connection (could be only the official frsky IDs), and secondly it would be simpler to support both generations of sensors in one (probably ...
by RightRudder
Fri Mar 08, 2013 5:31 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: openXvario development
Replies: 251
Views: 34649

Re: openXvario development

Well I am guessing that it means that even though the Rx sends down the frame to the tx every 100ms the FAS-100 only sends to the hub new data every 1 sec. It is right in the technichal specs but is says exactly "Update Rate: ≥1Hz" So what does that mean "≥" ??

J

Go to advanced search