Search found 16264 matches

by MikeB
Sun Apr 11, 2021 8:56 pm
Forum: Turnigy 9XR PRO radio
Topic: Ardupilot telemetry via DragonLink on 9xrPo ?
Replies: 3
Views: 493

Re: Ardupilot telemetry via DragonLink on 9xrPo ?

I don't have or use either dragonlink or pixhawk. Please try setting the baudrate for COM1, in the telemetry menu, to 57600. You may also try changing COM1 to inverted. In any case, go to the DEBUG menu (in STATISTICS) and see if the number beside "TelRxCount" is changing. If it is, then this indica...
by MikeB
Sun Apr 11, 2021 10:35 am
Forum: Turnigy 9XR PRO radio
Topic: Ardupilot telemetry via DragonLink on 9xrPo ?
Replies: 3
Views: 493

Re: Ardupilot telemetry via DragonLink on 9xrPo ?

What protocol are you using to send control data TO the dragonlink?

Do you know what format and baudrate the telemetry data is coming from the dragonlink?

In the TELEMETRY menu, have you tried setting the "Usr Proto" to "ArduP"?

Mike
by MikeB
Sat Apr 10, 2021 10:25 pm
Forum: Hardware
Topic: X9E upper display testing?
Replies: 4
Views: 459

Re: X9E upper display testing?

T9HobbySport in the UK are showing as having 2 in stock.

Mike
by MikeB
Sat Apr 10, 2021 8:25 am
Forum: Other Radios
Topic: Q X7 Schematic; how to find it on ORCForums?
Replies: 35
Views: 13500

Re: Q X7 Schematic; how to find it on ORCForums?

I just saw a large + sign beside C125, so assumed it was polarised, but I now see there is a + sign beside most of the capacitors. The actual polarised ones do have a different symbol, so C125 is not polarised (I guess it is a ceramic cap).

Mike
by MikeB
Fri Apr 09, 2021 8:56 am
Forum: Hardware
Topic: Bad Eeprom error. 9xtreme/encoder.
Replies: 36
Views: 4427

Re: Bad Eeprom error. 9xtreme/encoder.

Yes. Test 1. Disconnect the IO13 wire, use the currently installed firmware and check if EEPROM works OK. Test 2. Remove the resistor (you circled in red), re-connect the IO13 wire, and check if EEPROM works OK. Test 3. Revert to the March 16th firmware and check if EEPROM and encoder both work OK. ...
by MikeB
Fri Apr 09, 2021 8:51 am
Forum: Other Radios
Topic: Q X7 Schematic; how to find it on ORCForums?
Replies: 35
Views: 13500

Re: Q X7 Schematic; how to find it on ORCForums?

4.7uF 16V, according to the schematic I have for the Rev. 0.4 motherboard. It is polarised so needs to be fitted the correct way round.

Mike
by MikeB
Thu Apr 08, 2021 8:10 pm
Forum: Hardware
Topic: Bad Eeprom error. 9xtreme/encoder.
Replies: 36
Views: 4427

Re: Bad Eeprom error. 9xtreme/encoder.

Two possibilities come to mind: 1. The MISO signal is being driven at the wrong time, causing data corruption. (Not so likely as it should be an input while the EEPROM is selected, controlled by hardware). 2. The SCK (clock) signal is being loaded by the Arduino causing missed clocks. This is the mo...
by MikeB
Thu Apr 08, 2021 9:03 am
Forum: Hardware
Topic: Bad Eeprom error. 9xtreme/encoder.
Replies: 36
Views: 4427

Re: Bad Eeprom error. 9xtreme/encoder.

I've PM'ed another test version. In this one I've removed the encoder code. Please try this to make sure you don't have a problem with the actual EEPROM. If you still get problems, please, if possible, try disconnecting the arduino that drives the encoder, to see if it that loading the signals causi...
by MikeB
Wed Apr 07, 2021 10:10 pm
Forum: Hardware
Topic: Bad Eeprom error. 9xtreme/encoder.
Replies: 36
Views: 4427

Re: Bad Eeprom error. 9xtreme/encoder.

There must still be a conflict between the EEPROM access and the encoder (on the Arduino) access. I've added an extra check to try to prevent this. I've posted it in a PM to you.

Mike
by MikeB
Tue Apr 06, 2021 11:36 am
Forum: Hardware
Topic: X9E upper display testing?
Replies: 4
Views: 459

Re: X9E upper display testing?

It connects to the main board on the 7-way connector P9. The connections are: 1. VCC 2. Ground 3. DATA 4. WR 5. Chip Select 6. LED + (VCC via a couple of resistors) 7. LED - (Switched to Ground via transistor Q9) So you could check some of the voltages at least. If you have a 'scope, you could check...
by MikeB
Mon Apr 05, 2021 7:03 pm
Forum: erskyTx (was ersky9x)
Topic: ERSKYTx (was ersky9x) Questions
Replies: 2093
Views: 561226

Re: ERSKYTx (was ersky9x) Questions

I tried but all I got was to ask here: https://www.facebook.com/groups/immersionrchub/, but since I don't have a facebook account I couldn't do so. Any further request for information has been ignored.

Mike
by MikeB
Sat Apr 03, 2021 10:26 am
Forum: er9x
Topic: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)
Replies: 12
Views: 721

Re: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)

Update from the radio should continue to work.

Mike
by MikeB
Sat Apr 03, 2021 10:22 am
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

I did fix a bug with the calibration of the SR slider being lost. You should have this fixed, but need to do a calibration to get the SR operating correctly.

I did change the power switch LED to be green for the TX16S. My Jumper T16 doesn't have a green LED.

Mike
by MikeB
Thu Apr 01, 2021 3:47 pm
Forum: er9x
Topic: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)
Replies: 12
Views: 721

Re: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)

I thought the "USB Disabled" applied to the MPM firmware only, and removed the USB debug code. The bootloader, I thought, doesn't affect that. I'm sure I haven't changed my bootloaders for a long time (many months).

Mike
by MikeB
Thu Apr 01, 2021 3:23 pm
Forum: ersky9xr
Topic: delta expo
Replies: 4
Views: 535

Re: delta expo

I've just tried those mixes in both eepskye and on a radio. The channel outputs look correct to me. I would wonder about your offset (decalage) values. Are these causing your servo arms, when central, to NOT be at right angles to the servo. If they are NOT at right angles, you will get mechanical di...
by MikeB
Thu Apr 01, 2021 10:30 am
Forum: ersky9xr
Topic: delta expo
Replies: 4
Views: 535

Re: delta expo

I cannot see any specific problem, I just applied the Delta template and set the AIL expo to 70% and I see the same amount of change on the channel outputs. Do you have differential set in the mixer? Please double check the expo setting. You can set a different amount of expo on either side of the s...
by MikeB
Thu Apr 01, 2021 8:33 am
Forum: er9x
Topic: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)
Replies: 12
Views: 721

Re: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)

I've just updated from Github to 1.3.2.67, compiled using 1.8.13 Arduino IDE (compiler is 4.8.3), and I get a size of 118196 out of 120808, with all protocols included. I'm using "USB Support Disabled" and "Debug Option None".

Mike
by MikeB
Tue Mar 30, 2021 8:43 am
Forum: er9x
Topic: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)
Replies: 12
Views: 721

Re: Q: er9x compatibility with 2021 FW for 4-in-1 MPM (v1.3.2.58 or .61)

If you use the "test" version er9xProv822w.zip, then you should be compatible the latest release of the MPM firmware. er9x does support "Multi Telemetry". What I think I need to do is an full release of version 822 as the "last" release of er9x. No doubt "MULTI_STATUS" was removed to free up flash s...
by MikeB
Fri Mar 26, 2021 7:43 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

What did you do to fix it?

Mike
by MikeB
Wed Mar 24, 2021 11:47 am
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

Just to be certain, is that after you flashed openTx after using Zadig and the power off method of flashing?

Mike
by MikeB
Tue Mar 23, 2021 9:35 am
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

So did you managed to get openTx written to the radio, but it still doesn't work?

Mike
by MikeB
Mon Mar 22, 2021 7:12 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

Here are the instructions, from openTx, for using the STM bootloader:
http://open-txu.org/home/undergraduate- ... ing-zadig/

Follow these instructions and you should be able to get openTx back on, then we can go from there.

Mike
by MikeB
Mon Mar 22, 2021 2:33 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

What happens when you press the power button, anything at all?

With the radio off, try plugging in the USB cable to the PC, do you get a device appearing (STM Bootloader)?

Odd that has happened as "Daedalus66" successfully updated the bootloader on his TX16S.

Mike
by MikeB
Sun Mar 21, 2021 8:05 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

So you can edit the second screen but, on the main display screens, you can only see the first screen? The "PAGE<" button should switch between them. If you are on the main screen and you press the "PAGE<" button LONG, do you get to the Radio Setup menu? I don't understand what you mean for Maintena...
by MikeB
Sun Mar 21, 2021 2:05 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

When you edit the second screen, is it not saved through a power cycle? (so after power off and on the settings have gone). If it is saved, then when you have the first screen displayed on the main menu, one of the page buttons should switch to the second screen. For model images, currently you need...
by MikeB
Fri Mar 19, 2021 11:03 pm
Forum: erskyTx (was ersky9x)
Topic: MasterRadio TX16S
Replies: 168
Views: 18261

Re: MasterRadio TX16S

Some of the downloads are almost certainly bots (e.g. Google). I've just posted a new test version. I've been working with "Daedalus66" who has a TX16S to sort a few things. The buttons should be as before, so the MDL button on the right should act as RIGHT, the SYS button on the left should act as ...
by MikeB
Fri Mar 19, 2021 10:35 pm
Forum: Hardware
Topic: Charging port.
Replies: 38
Views: 3428

Re: Charging port.

0.04V looks good while charging.

Mike
by MikeB
Fri Mar 19, 2021 9:16 pm
Forum: Hardware
Topic: Charging port.
Replies: 38
Views: 3428

Re: Charging port.

You are measuring from the Gate, not between Drain and Source.
Please measure, with the meter, between the two pads of the original diode.

Mike
by MikeB
Fri Mar 19, 2021 7:38 pm
Forum: Hardware
Topic: Charging port.
Replies: 38
Views: 3428

Re: Charging port.

The power switch does disconnect the charging circuit when the radio is on so that is correct.
What is the voltage across the MOSFET?

Mike
by MikeB
Fri Mar 19, 2021 3:26 pm
Forum: Hardware
Topic: Charging port.
Replies: 38
Views: 3428

Re: Charging port.

Given you had the wire melt earlier, it is likely the MOSFET is damaged. Since the MOSFET has a built in diode, it should never have more than 0.7V across it when charging, which at 1A is only 0.7W, so it should only get warm if it is not turned on. Since it should also turn on, then it should have ...

Go to advanced search