Search found 4 matches

by pintst
Fri Jan 11, 2019 8:54 am
Forum: FrSky Taranis radio
Topic: X9D+ SE dead after first discharge
Replies: 6
Views: 1069

Re: X9D+ SE dead after first discharge

MikeB wrote:
Thu Jan 10, 2019 11:45 pm
A first test is, with the power switch OFF, connect the radio to the PC with a USB cable. If the PC finds a STM Bootloader device, then the 3.3V regulator and the processor are working OK.
Yes, it detects STM32 BOOTLOADER.
by pintst
Thu Jan 10, 2019 4:00 pm
Forum: FrSky Taranis radio
Topic: X9D+ SE dead after first discharge
Replies: 6
Views: 1069

Re: X9D+ SE dead after first discharge

Just measured the battery voltage: 8.09V
Dang it! Was hoping it was going to be as easy as replacing the battery...

Any tips on how to find out what wrong?
by pintst
Sat Jan 05, 2019 12:14 am
Forum: FrSky Taranis radio
Topic: X9D+ SE dead after first discharge
Replies: 6
Views: 1069

Re: X9D+ SE dead after first discharge

I know, I tried charging it with the charger. I am not sure if it's the battery or the remote's charging controller, or some other component. It would be great if someone could be so kind and help identifying what's wrong so I do my best to repair it.
by pintst
Fri Jan 04, 2019 6:10 pm
Forum: FrSky Taranis radio
Topic: X9D+ SE dead after first discharge
Replies: 6
Views: 1069

X9D+ SE dead after first discharge

Hi! I have had an FrSkyTaranis X9D+ SE for over a year. I picked it up after I received it, flashed latest version of OpenTX on it, and played some Liftoff, and then left it until recently. Last month I started playing more Liftoff, and bought a Whoop that arrived yesterday, and while I was flying t...

Go to advanced search