Search found 59 matches

by darozas
Thu Nov 16, 2017 8:54 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Well nothing to worry it works!!!. I just don't turn on off quick. It wont effect radio from functioning so im fine.

Anyways got new radio coming so don't really worry about this at all.

Keep it up Mike !!!
by darozas
Wed Nov 15, 2017 5:00 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Are you using a Megasound board, as produced by HC1969? Is it connected using serial (trim switches moved), or parallel? Mike. I have "Oliver PCB " design here. While back you helped me to solve the issues I was having with it. Its runs over serial . Yes trim switches moved. If I turn on off on qui...
by darozas
Wed Nov 15, 2017 2:05 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Hi Mike, Do you know if sometimes when connecting the TX the megasound does not work, and that has to turn it off and on again to work? Marco, Same here If I connect radio on and off on quick it stops working. Then I have to leave radio turned off for like 3 minutes to get it working again. Regards
by darozas
Fri Mar 03, 2017 11:42 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

I didn't include a haptic driver on my original design. I think the board you have includes the driver (transistor buffer), but it still needs to be wired to the main processor, pin 43. There is a pad labelled PG2 on your board for this connection. Mike. Thanks for your time again But i connected i...
by darozas
Fri Mar 03, 2017 11:15 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Hi all again !!! How does the haptic feedback works tried to connect small motor but looks like nothing happening :( Set to do haptic on switch change soldered 3.3v vibrator motor in line with diode but wont runn. De-soldered motor plugged multi meter on but cant see anything changing in voltage? Ag...
by darozas
Sat Feb 25, 2017 11:30 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Hi and BIGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGG Thanks to you

I have swaped wires on PD lines and flashed to non test version BOOOOOOM working

Where is DONATE button here ???

Regards
by darozas
Sat Feb 25, 2017 11:05 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Dont know what to do hit wall here ........

Regards
by darozas
Sat Feb 25, 2017 10:20 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks again for your time

here results below



Regards
by darozas
Sat Feb 25, 2017 9:43 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

MikeB wrote:
Sat Feb 25, 2017 9:32 am
You do have a ground (GND) connection as well don't you?

Mike.
I got connected like this ???

Regards
by darozas
Sat Feb 25, 2017 9:18 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

jhsa wrote:
Fri Feb 24, 2017 10:46 pm
Because the connection to the radio is not good

João
Thanks for reply but there only 2 wires.

See attached

Regards
by darozas
Fri Feb 24, 2017 9:41 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

I'll do another special test version, but I won't have time until either late tonight or tomorrow now. Mike. Thanks will be waiting !!! Just tried to flash first test version i have compiled and i do same thing as the one you just send.Back light flashing file 40 playing,If i press trims adding cha...
by darozas
Fri Feb 24, 2017 5:26 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Please press the Esc key several times. If you have LEDs on the FTDI, please check the "Tx" LED flashes when you type a character. The processor should be turning the backlight on and off about once a second. The signal is on PB1 (pin 13) and is buffered by a transistor. Please check there are not ...
by darozas
Fri Feb 24, 2017 4:34 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks for your time again So, with this loaded: 1. Do you see the 588588... on the terminal? YES 2. Does the voice file play? Yes File 40 3. Is the backlight flashing? NO 4. Do you see extra characters when you press the trim switch? Yes 5. What happens if you press the "Esc" key TWICE on the termi...
by darozas
Fri Feb 24, 2017 7:38 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

BEFORE you remove any components, please try the following. Use the normal firmware. You have the FTDI adapter connected to the Tx and Rx pads. When you tested with the normal firmware, you can read and write files to the SD card, so these connections are working. Move the connection to the Rx pad ...
by darozas
Thu Feb 23, 2017 11:42 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Here, I put some comments on the schematic.. Please remove R17, remove also the FET(and bypass it).. João Thanks for your time ill do that first thing tomorrow. Got to much of this mod already.Loosing patients trust me never ever had such a frustrating thing in my life :mrgreen: All look like works...
by darozas
Thu Feb 23, 2017 11:38 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

No, I suggested connecting the trims to pins 25 and 26 of the ATMEGA328 on the megasound board. You say the backlight is working. Can you turn it on and off by assigning a switch to the backlight in the Radio setup menus and then using the switch to turn the backlight on and off? For when using the...
by darozas
Thu Feb 23, 2017 9:45 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks for reply

pins like mike suggessted to Atmega128 pins 25 & 26

see schematics

Back-light is on working fine

Regards
by darozas
Thu Feb 23, 2017 9:19 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Tried to by pass diode same

Im using oliver audiosound

Radio firmware is er9x 128 and yes flashed amodserial

All wired up us needed

Trims works coz i have wire them to Pin 25 pin 26 (Dont work on atmega328p)

Regards
by darozas
Thu Feb 23, 2017 8:56 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

If the trims are working, it means that the megasound is now working and the communication between radio and voice module is also working.. Why don't u just flash the normal file?? João If i flash standard amod_ser_hex it stops working radio wont do any sound at all just ticking speaker that all. H...
by darozas
Thu Feb 23, 2017 7:34 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks again

Just tried E S E and more nothing Echoed back

File upload works fine just have to re flash to TEST 0 to be able to talk to SD card

The way im testing is keep renaming different file to 0040 and uploading to sd via EEPE

And all files play fine


Regards
by darozas
Thu Feb 23, 2017 6:55 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks for reply i get nothing echoed back just line off XXXXXX"Euro sign"XXXXXXXXXXXXXXXXXXXXXXX ans so on looks like euro sign shows up when its start to play soaund again So board works just tripple checked connections all as required still no joy :( Wired TRIM lines to X1&X2 Trims working now fi...
by darozas
Thu Feb 23, 2017 6:21 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Hi all again Got some success here :D GOT AUDIO FINALLY :D but not there yet So came back home recompiled hex with TEST 1 flashed boom playing. But only playing file 40 (Dont do anything if i press from 0 to 9) Back light same always on. So recompiled to TEST 0 back where started ill try to remove d...
by darozas
Thu Feb 23, 2017 3:28 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

There is one diode on ATMEGA328 PD1 should I remove by pass it??

Regards
by darozas
Thu Feb 23, 2017 2:53 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Are you sure you connected the trims to pin 1 and 2 of the voice module, and connected the voice module to pins 27 and 28 of the radio's processor? Your picture above is wrong.. João Attached pictures is for TRIM connection as MIke Suggested And all connected like this PD2 - Pin 27 PD3 - Pin 28 Atm...
by darozas
Thu Feb 23, 2017 2:29 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

The trim switches that connected before to pins 27 and 28 of the Atmega 128 connect now to the voice module, atmega328 pins 1 and 2, again if I'm not mistaken. Pin 1 is Thr trim up Pin 2 is Thr trim down João Don't work That way :( That what I got now and its not working Every time I touch TRIM swi...
by darozas
Thu Feb 23, 2017 2:27 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

And if I'm not mistaken, Pin 30 (RX) of the Atmega328 connects to pin 28 of the m128 and Pin 31(TX) of the Atmega 328 connects to pin 27 of the m128 João Serial works communication is fine to PC I can upload files without problem. Problem I have and it looks like Mega Sound don't talk with Atmega12...
by darozas
Thu Feb 23, 2017 2:15 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

It's wrong. You marked pins 25 and 26 of the atmega.. You need to solder to pins 27 and 28 of the atmega.. On my voice module I had to remove the resistors. João Thanks for your reply . But here is TRIM port connection to chip Like Mike Suggested to connect Trim pins to X1 & X2 instead of Megasound...
by darozas
Thu Feb 23, 2017 1:20 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Is that correct ???
Do I need to solder Before resistor or after ???

Or do I need to remove them ???

Regards
by darozas
Thu Feb 23, 2017 7:14 am
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Hi thanks again Well nothing coming out from megasound on other switches.Only re-wired one cause that noise.Other trim switches plays BUZZER type noise. If i create voice in settings then it ill make similar noise as per video. And it does do same noise on start up here video https://youtu.be/Kft4y3...
by darozas
Wed Feb 22, 2017 11:44 pm
Forum: Software
Topic: Build Compile amod [Please help]
Replies: 125
Views: 12680

Re: Build Compile amod [Please help]

Thanks for reply again No i wasn't pressing anything. But if i power controller with FTDI attached TX led constancy blinks in short pulses if that makes any sense? But if i press trim it just make speaker to act like in video Im getting so close to forget about audio mod been so frustrating for past...

Go to advanced search