Search found 219 matches

by Raythegreat
Tue Sep 03, 2019 1:05 am
Forum: General help (FrSky Taranis radio)
Topic: Taranis with the Vista drone
Replies: 1
Views: 150

Re: Taranis with the Vista drone

Hi, More info: Attached is the PDF manual of the Vista. Where I would like to get some help is about an explanation of the Setup section (page 2) in PDF file. I have an RF module in the back of Taranis that can support the SLT compatibility so I simply need explication of the setup description to ma...
by Raythegreat
Mon Sep 02, 2019 4:45 pm
Forum: General help (FrSky Taranis radio)
Topic: Taranis with the Vista drone
Replies: 1
Views: 150

Taranis with the Vista drone

Hi, One of my friend gave me a the VISTA quadcopter from Dromina and with remote control (Tx) MR100, a very cheap remote. I would like to use the Taranis instead of the Tx MR100. Can you help me on giving me the mixing of each channel, order is usually for drones AIL, ELE, THR, RUD. I tried the usua...
by Raythegreat
Fri Aug 09, 2019 1:31 am
Forum: General help (FrSky Taranis radio)
Topic: Oscillating servo
Replies: 5
Views: 401

Re: Oscillating servo

Yes this makes sense and should be considered as the main suspect, the 3.3V signal on old servos.
I will try to find a way to prove it.

Thanks Kilrah,
Ray
by Raythegreat
Thu Aug 08, 2019 5:47 pm
Forum: General help (FrSky Taranis radio)
Topic: Oscillating servo
Replies: 5
Views: 401

Re: Oscillating servo

Hi Kilrah, OK I have made further tests. I exchanged the servos from the oscillating S3004 to HS-65 and back to the oscillating S3004. The same S3004 you saw in the video did not oscillate anymore! I have seen this behavior before, an S3004 was oscillating and then when outside after flying a few ti...
by Raythegreat
Thu Aug 08, 2019 5:05 pm
Forum: General help (FrSky Taranis radio)
Topic: Oscillating servo
Replies: 5
Views: 401

Re: Oscillating servo

Thanks Kilrah, I will answer your questions: Do other S3004's do it if swapped in place? NO not all S3004 do it but I have seen this only on different S3004 a few times. Do all S3004's you have do it or is there one that works? Do you see this with servos other than the S3004? I have seen this only ...
by Raythegreat
Wed Aug 07, 2019 9:48 pm
Forum: General help (FrSky Taranis radio)
Topic: Oscillating servo
Replies: 5
Views: 401

Oscillating servo

Hi all, I have attached a video to show how my aileron servo oscillates when I move fast right and left on my aileron stick. I have OpenTx 2.2.2 and Taranis plus and all works well. I can fly all my airplanes with no problems but I would like to know what can cause the small oscillations when a sudd...
by Raythegreat
Thu Jun 06, 2019 1:41 am
Forum: General help (FrSky Taranis radio)
Topic: Taranis as game controller for HELIX
Replies: 2
Views: 283

Re: Taranis as game controller for HELIX

Hi schimaiw, You must check the channel mappings. Do not only look at channels # 1 to 4 or 1 to 8. Often in games you can have ailerons mapped at channel 5 or even 9 or even higher like 10 or 12. It depends. Explore all the channels under 16 and map your mixer in Taranis to those. Hope that works. RTG
by Raythegreat
Sat Jun 01, 2019 3:13 am
Forum: General help (FrSky Taranis radio)
Topic: Telemetry Bar Graph
Replies: 2
Views: 320

Re: Telemetry Bar Graph

Hi,

When you selected BAR, did you set the min and max ?
Set the max value first then min.

rtg
by Raythegreat
Sun Mar 10, 2019 4:44 pm
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Re: Save telemetry simulator settings

Thanks Kilrah, So this means this simulator behavior acts the same as the real FLVSS sensor. I never tried to put a real voltage over 4.2V on the sensor in fear it could damage the sensor. So this is very good then if it has nothing to do with the simulator, it will help doing a more robust LUA prog...
by Raythegreat
Sun Mar 10, 2019 4:06 am
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Re: Save telemetry simulator settings

Hi, To continue on the subject of the companion telemetry simulator, I noticed that if we put a voltage at any cell over 5 volts we can get the message "sensor lost" and/or the function pack_voltage = getValue("Cels") the table gets corrupted. This means there is some additional logic hidden behind ...
by Raythegreat
Wed Mar 06, 2019 9:06 pm
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Re: Save telemetry simulator settings

I'm glad you confirmed it Kilrah. Might be nice to add this feature...

Nevertheless, the simulator and openTx in general are awesome. Real good job.

Thanks,
RTG
by Raythegreat
Wed Mar 06, 2019 1:53 am
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Re: Save telemetry simulator settings

Thanks Kilrah, I tried what you suggested and it does not keep the LiPo cels individual voltages. All other telemetry shows up correctly. When I save any simulation session into a log file and load it after, the cell voltages previously entered in the simulation window are not updated after the load...
by Raythegreat
Tue Mar 05, 2019 2:33 am
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Re: Save telemetry simulator settings

Thank you rdeanchurch, Your idea is not bad, I can take an existing log file and load it with the current cels value in there. However, I can't have the test values I want because I can't save the sim telemetry entries, I will need to fix my test values manually anyway. I'm surprised we cannot save ...
by Raythegreat
Mon Mar 04, 2019 4:02 am
Forum: General help (FrSky Taranis radio)
Topic: Save telemetry simulator settings
Replies: 9
Views: 617

Save telemetry simulator settings

Hi all

I have companion 2.2.2.
Can you help me by telling me how I can save the telemetry simulator setting in a file and be able to load it.
Where is the save ?
See file attached.

Thanks
RTG
try.pdf
(124.58 KiB) Downloaded 21 times
by Raythegreat
Sun Feb 17, 2019 10:35 pm
Forum: Software
Topic: LUA script question
Replies: 8
Views: 535

Re: LUA script question

Thank you rdeanchurch, It is good to know that there are queues. This changes the whole concept of using misc founctions. It is also good to know that there is a delay also, not only queues. I did this: timer1 = getTime() playFile("90perc.wav") timer2 = getTime() display timer2 - timer1 You guessed ...
by Raythegreat
Sun Feb 17, 2019 8:27 pm
Forum: Software
Topic: LUA script question
Replies: 8
Views: 535

Re: LUA script question

Thanks Kilrah,

I believe my first answer to you did not get out.
I'm sure the read time will work.

Thanks guys.
RTG
by Raythegreat
Sun Feb 17, 2019 8:24 pm
Forum: Software
Topic: LUA script question
Replies: 8
Views: 535

Re: LUA script question

Thank you Mike,

Just got your reply as I was responding to Kilrah.

RTG
by Raythegreat
Sun Feb 17, 2019 7:29 pm
Forum: Software
Topic: LUA script question
Replies: 8
Views: 535

Re: LUA script question

Hi rdeanchurch, Thanks for your response. Yes of course I know about the -1024, +1024, here, I was just trying to do something very simple here to debug the playFile issue. I know this issue is a timing problem and the playFile takes too much time to execute for the loop. So I'm trying to find anoth...
by Raythegreat
Sun Feb 17, 2019 2:11 am
Forum: Software
Topic: LUA script question
Replies: 8
Views: 535

LUA script question

Hi, I attached a simple LUA program that I use on my Taranis plus with firmware and companion 2.2.2. This script displays the values in real time of the elevator stick on the LCD screen and output some voices I recorded to say 90%, 80%, 70%. The program is just a test. I tried on both sim and Tarani...
by Raythegreat
Sun Feb 03, 2019 4:20 am
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Thanks Kilrah for the confirmation.

My bad, I thought the 2 was the number of lipo cells, it is the ID of sensor.

Problem solved.

Many Thanks
RTG
by Raythegreat
Sat Feb 02, 2019 10:17 pm
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Hi I believe I have found the reason why only 2 works in the field Cels for the telemetry simulator. The 2 is NOT the number of cells but (as I thought) but more an ID. Right? Please confirm how to set these numbers in the 2 columns shown by the two arrows or are they set automatically by the model ...
by Raythegreat
Sat Feb 02, 2019 7:57 pm
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Hi, OK I found in the Telemetry simulator of Companion that if I put 2 as the number of Cels in the field near the 6 entries of LiPo voltages it works. Strange, only 2 there works. Any other number in that field does not work well. So now the LUA problem was caused by companion. If I keep 2 there al...
by Raythegreat
Sat Feb 02, 2019 6:10 pm
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

No gaps, still does not work for me. Anything over 3 cells does not work (for me) This is what I did: I defined 4 telemetry sensors coming from calculated values, C1,C2,C3,C4 and I display them in the display menu. All work very well in real life on the transmitter but in Companion and when using LU...
by Raythegreat
Sat Feb 02, 2019 5:15 pm
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Thanks Kilrah,

Yes I have seen this. I just wanted to check if there was a simpler way. Cel- will do the job for now.

But what about the telemetry simulator in Companion 2.2.2, number of cells over 2 does not seem to work. 1 or 2 cells works

RTG
by Raythegreat
Sat Feb 02, 2019 5:59 am
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntax error

Hi all, I've been playing with LUA for a few days now and starting to get used to it. I have open TX 2.2.2 for both firmware and Companion. In the companion telemetry simulator, the Cels field does not seem to be working over 2 cells. Works for 1 or 2 cells only. From 3 to 6 does not work. Also when...
by Raythegreat
Tue Jan 29, 2019 4:04 am
Forum: General help (FrSky Taranis radio)
Topic: Help with retract setup on x9d plus radio
Replies: 24
Views: 1621

Re: Help with retract setup on x9d plus radio

Hi bonnicij,

OK then we know it's not the retracts the problem.
Continue like this one piece at the time until you identify the culprit.
Go backwards from retracts to up the hill to the Tx, including cables, connections, grounds, V+ , receiver, etc etc.
Don't jump anything and you'll find it.

rtg
by Raythegreat
Tue Jan 29, 2019 2:00 am
Forum: General help (FrSky Taranis radio)
Topic: Help with retract setup on x9d plus radio
Replies: 24
Views: 1621

Re: Help with retract setup on x9d plus radio

Hi,

You need to isolate the problem first.

Just replace your retracts by a servo with a horn and see what happens.
If a known good servo does not work, then you'll know the problem is not your retracts.
Go step by step, including changing wires if necessary.

RTG
by Raythegreat
Sun Jan 27, 2019 4:54 pm
Forum: General help (FrSky Taranis radio)
Topic: Radio setup: lost of time
Replies: 11
Views: 1818

Re: Radio setup: lost of time

Hi all,

My taranis RTC date and time problem was immediately fixed then I changed the battery. My Taranis had 5 years.

Kilrah is right, some batteries are cheaper than others and are worse, not up to their 100% capacity at shipment so the problems may occur at any time.
by Raythegreat
Mon Jan 14, 2019 3:58 am
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Many thanks rdeanchurch

RTG
by Raythegreat
Mon Jan 14, 2019 3:05 am
Forum: Software
Topic: Lua syntak error
Replies: 15
Views: 1433

Re: Lua syntak error

Thank you again rdeancherch.

Where can I find a list and the description of parameters of allowable lua functions for Taranis?
That would help me greatly. I looked around and found no place where functions are listed with their parameters description (for the Taranis).

RTG

Go to advanced search