Search found 36 matches

by 3djc
Sun May 12, 2019 9:27 am
Forum: openTx
Topic: Writing Lua Widgets for Horus
Replies: 11
Views: 1337

Re: Writing Lua Widgets for Horus

Please do not crosspost your issue, specialy if you ask for non LUA solution in a thread ABOUT LUA ...

3djc
by 3djc
Sun May 12, 2019 9:26 am
Forum: openTx
Topic: Making calculations on Telemetry Values
Replies: 2
Views: 252

Re: Making calculations on Telemetry Values

Don't think you can without resorting to tricks way more complicated than using a simple LUA mixer scrip (which bye the way, solves the non linearity of lipo voltage vs percentage issue)

3djc
by 3djc
Mon Apr 08, 2019 5:21 am
Forum: openTx
Topic: confusion and question on otx2.2.3
Replies: 5
Views: 503

Re: confusion and question on otx2.2.3

Yes, you seem to be mixing quite a few things, which can happen at first. - Flash the firmware : are you connecting the radio in 'bootloader' mode (ie turn on while holding the two horinzontal trim button toward center ? The screen should display a title like OTX bootloader - Lowest cell : perfectly...
by 3djc
Sun Mar 24, 2019 4:29 pm
Forum: openTx
Topic: Writing Lua Widgets for Horus
Replies: 11
Views: 1337

Re: Writing Lua Widgets for Horus

There are some widgets writen in LUA to understand the basic structure. Details on available functions is here : https://legacy.gitbook.com/book/opentx/ ... de/details
by 3djc
Fri Nov 02, 2018 7:56 am
Forum: openTx
Topic: OpenTX GPL violation? Nirvana NV14
Replies: 18
Views: 7707

Re: OpenTX GPL violation? Nirvana NV14

As far as we know, what Kilrah wrote in his second post of this thread is still true, the plan is to have both supported into companion. If that was to change, we would obviously do whatever the situation requires. The development is not slow over dispute or anything like that, simply, the radio got...
by 3djc
Tue Oct 30, 2018 7:36 am
Forum: openTx
Topic: String in LUA widget options
Replies: 1
Views: 585

Re: String in LUA widget options

Fix for that incoming
by 3djc
Sat Oct 13, 2018 8:43 pm
Forum: openTx
Topic: Ailerons moving slow & with delay
Replies: 19
Views: 5027

Re: Ailerons moving slow & with delay

As I said, the X9E gimbal issue are very very well known, and have absolutely nothing to do with firmware, there is more than ample evidence of that. Eventually, all X9E will have that at one time or another. For the two x7 with hall stick having an issue, if it was firmware, we would likely have a ...
by 3djc
Sat Oct 13, 2018 8:32 pm
Forum: openTx
Topic: OpenTX GPL violation? Nirvana NV14
Replies: 18
Views: 7707

Re: OpenTX GPL violation? Nirvana NV14

Companion does not handle NV14 yet, and since we are not offering firmware for those yet, you need to ask them for instruction on how to flash it
by 3djc
Mon Sep 24, 2018 6:56 am
Forum: openTx
Topic: Unable upgrade to 2.2.2 on LinuxMint due to dependency error
Replies: 7
Views: 935

Re: Unable upgrade to 2.2.2 on LinuxMint due to dependency error

While I'm not using mint, I have read that Mint 19 solves this issue. Not a perfect answer I realise that, but hopefully it can help anyway
by 3djc
Fri Sep 21, 2018 6:08 am
Forum: openTx
Topic: Just a bit thick?
Replies: 6
Views: 825

Re: Just a bit thick?

According to your product page : The beacon has 5 modes, Rotate fast, Rotate slow , flash fast , flash slow and off. The modes are accessed sequentially.

So off seems part of the sequence, and it does not look like you have a on/off to last selected mode available
by 3djc
Wed Sep 19, 2018 10:04 am
Forum: openTx
Topic: OpenTX GPL violation? Nirvana NV14
Replies: 18
Views: 7707

Re: OpenTX GPL violation? Nirvana NV14

FYI, we have started merging NV14 in our official repo, but bear with us, there is a lot to do still :

https://github.com/opentx/opentx/tree/kilrah/nv14merge
by 3djc
Tue Sep 18, 2018 6:49 am
Forum: openTx
Topic: OpenTX 2.2.2 G-speed sensor from Crossfire/BF incorrect value
Replies: 2
Views: 483

Re: OpenTX 2.2.2 G-speed sensor from Crossfire/BF incorrect value

I believe we followed the Crossfire sensor specs. I'll double check those
by 3djc
Fri Sep 07, 2018 6:58 am
Forum: openTx
Topic: OpenTX GPL violation? Nirvana NV14
Replies: 18
Views: 7707

Re: OpenTX GPL violation? Nirvana NV14

We are doing a lot of efforts to move this work forward, but we also need to balance it with existing OpenTx users that also deserve our support. When we believe the software is a state where it can start to be used as beta (it may not have all features, but enough to be safely used), it will be ann...
by 3djc
Mon Sep 03, 2018 3:26 pm
Forum: openTx
Topic: Bind dual FS-IA6B
Replies: 10
Views: 1254

Re: Bind dual FS-IA6B

i was talking with OpenTx
by 3djc
Mon Sep 03, 2018 7:00 am
Forum: openTx
Topic: Bind dual FS-IA6B
Replies: 10
Views: 1254

Re: Bind dual FS-IA6B

You do not need two modules to have 16 chans on X series. Just bind one receiver on 1-8 and another one on 9-16 (just make sure one of the receiver only is bound with telemetry)

3djc
by 3djc
Fri Aug 31, 2018 4:06 pm
Forum: openTx
Topic: Bind dual FS-IA6B
Replies: 10
Views: 1254

Re: Bind dual FS-IA6B

That can be done with FrSky receivers, just make sure only ONE has telemetry enabled

3djc
by 3djc
Sat Jun 23, 2018 3:08 pm
Forum: openTx
Topic: Ailerons moving slow & with delay
Replies: 19
Views: 5027

Re: Ailerons moving slow & with delay

X9E gimballs are very well known for that, and mine did no exception, with exact same symptoms. I have replaced all the gimball wire with turnigy silicon wire, removed the conector and direct soldered my gimbals, problem gone, and stayed gone (well even more now that I have put M9 Hall gimballs ;D) ...
by 3djc
Fri Mar 23, 2018 11:01 am
Forum: openTx
Topic: TRSS on DSMX receiver
Replies: 2
Views: 628

Re: TRSS on DSMX receiver

I think this raises the question on where should the adaptation layer come from. We certainly do not want to release a version of OpenTX each time a new protocol is been supported by multi and new module types. Sure in a new eeprom version of OpenTX, we could allow to chose which sensor RSSI is comi...
by 3djc
Thu Apr 27, 2017 1:38 pm
Forum: openTx
Topic: OpenTX 2.2.0 RC1
Replies: 50
Views: 26206

Re: OpenTX 2.2.0 RC1

https://www.virustotal.com/fr/file/6e2b ... 493300273/

The issue is with Avast, not Companion
by 3djc
Mon Aug 29, 2016 3:36 pm
Forum: FRSky Horus radio
Topic: Open tx 2.2
Replies: 5
Views: 4210

Re: Open tx 2.2

Let's be cristal clear : current beta firmware shared with beta users will NOT work on production radio, as they are different. Do NOT try to get one from a beta tester for a prod radio (anyway, you will see very very quickly that it does not work !) There will be a version that supports production ...
by 3djc
Mon Aug 22, 2016 11:08 am
Forum: openTx
Topic: Telemetry voice alert units
Replies: 5
Views: 1237

Re: Telemetry voice alert units

Might be worth having code that checks if the correct voice pack exists. May be start with a simple check of a text file. If someone unfamiliar with the sound packs only upgrades the firmware then the firmware will find that the text file kept with the sound file is incorrect and displays a warning...
by 3djc
Thu Aug 04, 2016 8:08 am
Forum: openTx
Topic: OpenTx Lua getTime()
Replies: 2
Views: 717

Re: OpenTx Lua getTime()

It depends what you call acurate. The lua is not real time on the radio, scripts are called periodicaly. On my radio (x9e) the scripts are run every 150ms at best, and take some time to be run, so between the read of rtc clock and it been displayed or computed, there will be latency. Also, the simul...
by 3djc
Sun Jul 31, 2016 5:37 pm
Forum: openTx
Topic: X9E downgrade to 2.1.7
Replies: 2
Views: 739

Re: X9E downgrade to 2.1.7

Are you in Europe? Could be an eu-lbt issue

3djc
by 3djc
Thu Mar 17, 2016 7:31 pm
Forum: openTx
Topic: Multirotor custom LUA issue
Replies: 4
Views: 1147

Re: Multirotor custom LUA issue

Sorry, it took some time for the bug to appear again, and no, there is not such a logo, the speaker volume was displayed as usual.

3djc
by 3djc
Mon Mar 14, 2016 6:44 pm
Forum: openTx
Topic: Multirotor custom LUA issue
Replies: 4
Views: 1147

Re: Multirotor custom LUA issue

I did not notice, I'll have a look
by 3djc
Mon Mar 14, 2016 6:29 am
Forum: openTx
Topic: Multirotor custom LUA issue
Replies: 4
Views: 1147

Multirotor custom LUA issue

Dear all, I need some help to debug a script that works most of the time, but from time to time will prevent the radio to generate any audio, and also change the model picture to frsky logo (using 2.1.7) The script is attached and is designed for Cleanflight 1.12 with smartport.It gives you a panel ...
by 3djc
Mon Mar 14, 2016 6:23 am
Forum: openTx
Topic: Get computed average cell value from VFAS
Replies: 7
Views: 1133

Re: Get computed average cell value from VFAS

fyi, as a temporary solution, we will likely send a single computed cell value using A4

Cheers 3djc
by 3djc
Mon Mar 07, 2016 2:06 pm
Forum: openTx
Topic: Get computed average cell value from VFAS
Replies: 7
Views: 1133

Re: Get computed average cell value from VFAS

Shall I open an issue then ?

Cheers, 3djc
by 3djc
Mon Mar 07, 2016 10:11 am
Forum: openTx
Topic: Get computed average cell value from VFAS
Replies: 7
Views: 1133

Re: Get computed average cell value from VFAS

Tried everything I could think of arround creating that 'constant' sensors, but with no luck (2.1.7). I wonder if it is not related to the update time which never happens.

3djc

Go to advanced search