Search found 33 matches

by JanRy
Thu Jul 09, 2020 9:47 am
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Got it, thank you.
by JanRy
Wed Jul 08, 2020 11:27 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

OK, I've updated the array sizes too now.
I'm not sure if you saw "edit 2" in my previous post.

One more question. I am confused with the use of MULTI_TELEMETRY and MULTI_STATUS in multiprotocol. Which one should be defined for MBTX?
by JanRy
Wed Jul 08, 2020 10:52 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

The multi reports rev V1.3.1.32 (next to Bind button). I've attached my EEprom.
by JanRy
Wed Jul 08, 2020 10:36 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Brilliant Mike, I am indeed using multi as an internal module and the suggested fix has done the trick. Than you very much again! Edit: I got too exited. It appears by replacing byteCount = 26 ; with byteCount = length; the connection with multi is lost. The Multi activity led flashes with 50% duty ...
by JanRy
Wed Jul 08, 2020 8:03 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Hi Mike,
the communication between ARUni and MPM was OK between 93000 to 103000 baud. Outside these values the Hitec Optima sub-protocol would not update from OPT_FW or it got garbled. I've settled mid range at 98000 baud. But, persistently, anything above protocol 65 wraps around.
by JanRy
Tue Jul 07, 2020 10:33 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Thank you Mike,
I've reinstated multi.txt, flashed MBTX and multi from your files. The behavior is still the same though.
I wonder if anyone else has the same issue. I think João uses AR9x?
by JanRy
Tue Jul 07, 2020 8:51 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

thanks again Mike, I've just flashed the firmware you've compiled. The problem persists, so I guess it is not a MBTX compilation issue. I am compiling Multi (STM32 version) myself, so perhaps there is an issue there in _MyConfig.h settings. I'll investigate that further. So, does it mean that for MB...
by JanRy
Tue Jul 07, 2020 12:16 am
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Hi Mike, Thanks for looking into this. I don't know if the issue is with my Tx or my compilation, but my problem persists. I've recorded the behavior when changing the sub-protocol. In this case the main protocol is 65 (FrSkyR9) but it reverts to Flysky. It knows the protocol number, since it briefl...
by JanRy
Mon Jul 06, 2020 8:20 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Thanks Mike,
I've tried #define MULTI_TEXT_SIZE 800 (If that's the buffer in question), but it made no difference. The multi revision is V1.3.1.36.
I am in no rush for the fix, since I am not using any protocol over 65 at the moment.
by JanRy
Mon Jul 06, 2020 9:47 am
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

I am compiling only with the REVB=1 option.
by JanRy
Mon Jul 06, 2020 2:05 am
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Hi Mike, that worked. I've noticed an issue, though. The radio displays correctly the protocols 1-64, then starting with 65 I get briefly the correct name (i.e 'FrSkyR9') but then it changes to 'FlySky'. The same goes for the rest of the list. The displayed protocol is 'Selected'-64. The protocols 6...
by JanRy
Sat Jul 04, 2020 11:19 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Hi Mike, something is not right. I am getting the following error: obj_ersky9x/menus.o: In function `menuRangeBind(unsigned char)': R:\_Tx__Rx-DIY_modules\_My_Transmitters\ARuni-DIY transmitter\mbtx-master\radio\ersky9x\src/menus.cpp:10517: undefined reference to `DebugDsmBind' obj_ersky9x/menus.o: ...
by JanRy
Sat Jul 04, 2020 11:36 am
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Thanks Mike, I'll re-flash it tomorrow.
by JanRy
Fri Jul 03, 2020 11:56 pm
Forum: erskyTx (was ersky9x)
Topic: Ersky9x Bug Reporting
Replies: 388
Views: 108560

Re: Ersky9x Bug Reporting

Hi Mike, I've updated my transmitter (ArUni based Ersky9x - which I must compile myself to enable encoder page navigation) with the latest Multi-protocol and copied the multi.txt to the SD card. The file has now 72 entries. The protocols names are not displayed correctly anymore. Some have names, ot...
by JanRy
Sun Dec 24, 2017 2:07 am
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

Thanks for your help Mike,
it all appears to work now.
by JanRy
Sat Dec 23, 2017 11:05 pm
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

I've tried now without REVB=1 option and the result seems to be the same. I am using ARUni board, is option REVB=1 even required?
The power to RF module is being switched off, but the ARUni board stays ON after sliding the power switch to OFF position.
by JanRy
Sat Dec 23, 2017 9:57 pm
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

Hi Mike,
all seems to work OK, except the radio wouldn't turn off now.
I've replace all three instances of #ifdef REVB with #ifndef REVA in power.cpp file.
by JanRy
Sat Dec 23, 2017 11:40 am
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

Just noticed now that you were pointing me to the SKY folder...
by JanRy
Sat Dec 23, 2017 11:38 am
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

Thanks for the quick response, Mike. I am getting the same error after "make clean', then "make"; and also "make clean', then "make revb=1". There are two power.cpp files. One in X9D folder, the other in SKY folder. I get no compilation error after editing power.cpp in SKY folder as per your suggest...
by JanRy
Sat Dec 23, 2017 4:34 am
Forum: erskyTx (was ersky9x)
Topic: ErskyTx Test Versions
Replies: 115
Views: 147601

Re: Ersky9x Test Versions

Mike, I'm trying to compile the latest code from github (my 'special' version with '#define PAGE_NAVIGATION 1' in menus.cpp), but I am getting the following error: R:\TX and RX DIY modules\mbtx-master 21-12-17\mbtx-master\radio\ersky9x\src>make REVB=1 Generate Version-stamp: arm-none-eabi-gcc -c -mc...
by JanRy
Sun Feb 26, 2017 3:20 am
Forum: er9x
Topic: er9x development
Replies: 3134
Views: 539557

Re: er9x development

"Only one of the lcd_init() functions will be compiled at one time."
Yes, you are right. In my case only delay before line 1130 is actually required.
I'm glad you are working on LQi code. I've had an impression it is already implemented (from Rcgroups forum?)
by JanRy
Sat Feb 25, 2017 3:37 am
Forum: er9x
Topic: er9x development
Replies: 3134
Views: 539557

Re: er9x development

I was hoping to see LQI values in Frsky telemetry. I've needed a rather long delay at power up for my serial LCD to initialise properly, so I've inserted the following lines in lcd.cpp (lcd_init): PORTC_LCD_CTRL |= (1<<OUT_C_LCD_RES); for (uint8_t i = 0; i<4; i++ )delay_1_5us(30000); before line 102...
by JanRy
Fri Feb 24, 2017 11:23 pm
Forum: er9x
Topic: er9x development
Replies: 3134
Views: 539557

Re: er9x development

It seems the Github code is about three month old.
My serial LCD does not initialise properly with published hex (I need do add an additional delay loop in lcd_init, and re-compile).
Is there any other place I can download the source code from?
by JanRy
Wed Aug 24, 2016 9:27 am
Forum: er9x
Topic: er9x development
Replies: 3134
Views: 539557

Re: er9x development

Looks like 'Next' was just updated. Thanks Mike.
by JanRy
Wed Aug 24, 2016 7:45 am
Forum: er9x
Topic: er9x development
Replies: 3134
Views: 539557

Re: er9x development

Thanks Mike, I'll be waiting patiently for the latest updates.I am using a serial LCD and have to compile myself to get it working (with added delays in lcd_init)
by JanRy
Thu Jan 07, 2016 10:27 pm
Forum: er9x
Topic: flashing latest er9x
Replies: 106
Views: 14761

Re: flashing latest er9x

yes, you are right, it is 30ms! When testing, it required minimum of 10ms, so I've added 30ms. Still a very short delay on power up.
The data sheet for KK2 lcd that I found doesn't mention power-on-reset circuitry.
by JanRy
Thu Jan 07, 2016 8:10 am
Forum: er9x
Topic: flashing latest er9x
Replies: 106
Views: 14761

Re: flashing latest er9x

flybabo, that's a very good news :D . I'll check with my KK2 LCD too. I've added crudely 30us delay just before the reset pulse (@ approx line 910 & line 1000): " LcdLock = 1 ; // Lock LCD data lines PORTC_LCD_CTRL |= (1<<OUT_C_LCD_RES); delay_1_5us(30000); PORTC_LCD_CTRL &= ~(1<<OUT_C_LCD_RES); //L...
by JanRy
Wed Dec 30, 2015 5:51 am
Forum: er9x
Topic: flashing latest er9x
Replies: 106
Views: 14761

Re: flashing latest er9x

Hi flybabo, thanks for writing serial LCD library. It made my project possible (re-using DX4e shell). I am happy with the outcome, since I've had no room for a sound module anyway. All is working now. I am not entirely sure if CS can be left tied to the ground permanently. According to the data shee...
by JanRy
Wed Dec 30, 2015 12:28 am
Forum: er9x
Topic: flashing latest er9x
Replies: 106
Views: 14761

Re: flashing latest er9x

Thanks João, it works now.
by JanRy
Wed Dec 30, 2015 12:01 am
Forum: er9x
Topic: flashing latest er9x
Replies: 106
Views: 14761

Re: flashing latest er9x

I am using and have compiled M128 version. Where does the hardware menu appear?

Go to advanced search