Search found 35 matches

by IceWind
Thu Mar 12, 2015 3:59 pm
Forum: openTx
Topic: Use OpenTx to send and receive UART data ?
Replies: 14
Views: 4800

Re: Use OpenTx to send and receive UART data ?

Excellent that would be great.
Of course this will require those specific RX's with specific telemetry support.

I have one that suports the bi-directional link but ended up never trying it, may give it a go in the mean time while I wait for v2.1. ;)
by IceWind
Fri Mar 06, 2015 12:37 pm
Forum: openTx
Topic: Use OpenTx to send and receive UART data ?
Replies: 14
Views: 4800

Re: Use OpenTx to send and receive UART data ?

Sorry to dig out this thread but the question is directly related to it. Does the latest version of openTX allow to send data from the TX to the RX using for example a LUA script? FrSky allows for basic two way comunication ( FrSky 2Way Protocol ) and there is comunication from the radio into the fr...
by IceWind
Tue Jul 08, 2014 8:09 pm
Forum: er9x
Topic: Warming/Alarm at half timer count
Replies: 2
Views: 811

Re: Warming/Alarm at half timer count

Woow you rock Mike. Thanks!

I actually did the mod on my 9x but I think the piezzo buzzer isn't that great. So if this works better with the stock buzzer
I don't mind reverting back to it.

Going to set that up.
Thanks again.
by IceWind
Tue Jul 08, 2014 10:24 am
Forum: er9x
Topic: Warming/Alarm at half timer count
Replies: 2
Views: 811

Warming/Alarm at half timer count

Hi all, I was trying to find a way to set this option but so far I haven't found it. (still searching...) The idea was to have the radio make a different sound when it reaches half the timer count, at the moment I have it set to beep at every minute. But when I have like 7 to 10 minutes set, I easil...
by IceWind
Fri Oct 18, 2013 9:32 pm
Forum: eePe
Topic: Updating splash of ER9X 128 corrupts HEX.
Replies: 8
Views: 3688

Updating splash of ER9X 128 corrupts HEX.

Hi, I was flashing the latest release 806 for ER9x and as usual I swapped the logo. But after flashing it doesn't work, the radio doesn't even start. So it seems that it somehow corrupts the FW. The EEPE seems to read/write correctly the splash in the HEX file but somehow it is corrupting the HEX. F...
by IceWind
Sun Aug 11, 2013 1:10 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Telemetry mod was already done. The rotary encoder I don't see much use for it, Instead I prefer to convert one pot to a second 3Pos switch. Voices... I had also swapped the buzzer for another one but the result was not that good. Sound is low and didn't noticed much difference. I'll see what's need...
by IceWind
Sat Aug 10, 2013 3:04 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Yeap. found it right after posting the question. :)

Also added the 4x 1K resistor mod for the mega128 plus the backlight control mod.

All working now, all switches and I can read/write Flash & Eeprom.
by IceWind
Sat Aug 10, 2013 12:31 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Thanks for the details. Question, I assume the mega128 FW includes the changes for the pin re-routing of TRH and AIL switches right? Since I loaded the mega128 FW those two are always on. I've re-checked the wiring but nothing. As I see the FrSky telemetry menus I assume the firmware has also the ne...
by IceWind
Fri Aug 09, 2013 6:50 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Thanks Mike.
I'll do that.

If I got it right is just cut the track and fit the resistors.
I have some SMD 0805 laying around I my use those.
by IceWind
Thu Aug 08, 2013 11:20 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Just to finalize this thread. Continued testing and nothing... eventually decided to swap the uC. As I was to change it I went to a AtMega128. Just finished installing it and all seems fine, I can now program the uC normally and the ELEV switch that had stopped working is now working again. So it re...
by IceWind
Fri May 31, 2013 9:56 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

You mean that tiny white dot between the tracks? I think that was a speck of dust or some artefact from the photo but I'll give it a check. Btw, the full output from AvrDude is the following: ---- Started AVRDUDE /usr/local/bin/avrdude -c avrispmkII -p m64 -B 32 -P usb -U eeprom:r:/var/folders/g7/1t...
by IceWind
Fri May 31, 2013 8:59 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Here it is.
by IceWind
Fri May 31, 2013 5:29 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

@jhsa, yes that's correct. I ended up removing the resistor and measuring it outside to be sure it was ok. At it was fine. (220R) I checked continuity from the resistor to the pin. @gohsthb, the common error when there is no response from the IC. (Something like: initialization failed, rc=-1) I'll g...
by IceWind
Fri May 31, 2013 2:39 pm
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Ok, I would suggest disconnecting the telemetry wires that come from the frsky module to the MISO and MOSI pads and see if gets better.. My fault there as I forgot to mention it, I installed a plug in the wires that go out of the pads for those pins. So I can easilly disconect it and that was my fi...
by IceWind
Fri May 31, 2013 10:53 am
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

These were the instructions I've used to do the mod:
http://openrcforums.com/wiki/index.php/ ... _Mod_FrSky
and
http://openrcforums.com/forum/viewtopic.php?f=23&t=430

So no level converter used.
This evening I'll take a high resolution pic of the main board.
by IceWind
Fri May 31, 2013 8:51 am
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

Re: ATMega64 pins dying???

Thanks!
I've done the one that requires rewiring of the two pins.
I'll get a pic of the board.
by IceWind
Thu May 30, 2013 11:24 am
Forum: Hardware
Topic: ATMega64 pins dying???
Replies: 26
Views: 4324

ATMega64 pins dying???

Hey, The ATMega64 pins on my 9x seems to be failing... I have the following mods installed: FrSky Telemetry + Updated Buzzer It has been working well for quire some time, until recently I started having problems with the FrSky Telemetry. The receiving part seems ot be working fine I get proper detai...
by IceWind
Mon Jan 07, 2013 11:42 pm
Forum: er9x
Topic: Servo test on FrSKY FW version.
Replies: 2
Views: 1283

Re: Servo test on FrSKY FW version.

Excellent! I wasn't aware that was possible.
Thank you!
by IceWind
Mon Jan 07, 2013 5:40 pm
Forum: er9x
Topic: Servo test on FrSKY FW version.
Replies: 2
Views: 1283

Servo test on FrSKY FW version.

Hi, I know that the FrSky FW version doesn't include the templates section. Thing is I'm trying to have something like the servo test in order to test some radio TX/RX systems. I could backup everything, load the FW with templates and run the servo test but I'd prefer to leave that to very last opti...
by IceWind
Fri Dec 28, 2012 11:23 am
Forum: er9x
Topic: er9x development
Replies: 3129
Views: 453587

Re: er9x development

Hopefully this will fit in this thread. But one thing I've noticed is the that there is duplication of functions in the buttons. For example long press the menu will open the models list/conf area and the same happens with a long press on the RIGHT button. Any special reason to have two buttons doin...
by IceWind
Tue Dec 25, 2012 2:50 am
Forum: er9x
Topic: er9x development
Replies: 3129
Views: 453587

Re: er9x development

I've disabled pot scrolling as soon as I found it existed. As a option on it's own I don't like it much because we're using a control that can be used to change the model flight characteristics for the radio settings, meaning I'd be using the pot to scroll and later leave it outside the position I'd...
by IceWind
Sun Nov 11, 2012 11:34 am
Forum: eePe
Topic: Eepe on MAC
Replies: 93
Views: 42694

Re: Eepe on MAC

:( The problem I was hopping to be solved on the latest version is not.
Still can't save/load images to generate the logo.
Going to try and fix that.
by IceWind
Fri Nov 09, 2012 8:18 am
Forum: eePe
Topic: Eepe on MAC
Replies: 93
Views: 42694

Re: Eepe on MAC

I'm running the latest version > Xcode 4.5.2.
by IceWind
Fri Nov 09, 2012 2:17 am
Forum: eePe
Topic: Eepe on MAC
Replies: 93
Views: 42694

Re: Eepe on MAC

Problem solved, the version of Qmake that is mentioned in the instructions is not compatible with XCode 4.x. Need to get a newer version: http://get.qt.nokia.com/qt/source/qt-mac-opensource-4.8.1.dmg Still having some issues with the path's but it should be easier to fix. Update : I'm now running re...
by IceWind
Fri Nov 09, 2012 1:23 am
Forum: eePe
Topic: Eepe on MAC
Replies: 93
Views: 42694

Re: Eepe on MAC

I've been trying to compile it in mac with no luck. When opening he generated project in xcode it crashes, anyone encountered the same problem? Error log: --- $ xcodebuild eepe.xcodeproj 2012-11-09 01:43:46.845 xcodebuild[65054:1207] [MT] DVTAssertions: ASSERTION FAILURE in /SourceCache/IDEXcode3Pro...
by IceWind
Sat Oct 27, 2012 10:55 am
Forum: FRSky Telemetry Mods
Topic: FrSky telemetry mod without RS232 level converter
Replies: 128
Views: 65410

Re: FrSky telemetry mod without RS232 level converter

Well with mine that combination doesn't work.
It was tricky to solder the 0306 SMD 1K, but I may well do that to change it to a 10K.
But at least it's working now, even using the pins of the back of the DJT module.
by IceWind
Sat Oct 27, 2012 1:08 am
Forum: openTx
Topic: Trainer Problem
Replies: 12
Views: 2402

Re: Trainer Problem

Hey did you ended up making this work? I want to do exactly the same, use a DX7 as slave.
by IceWind
Sat Oct 27, 2012 12:23 am
Forum: FRSky Telemetry Mods
Topic: FrSky telemetry mod without RS232 level converter
Replies: 128
Views: 65410

Re: FrSky telemetry mod without RS232 level converter

Ok, it's confirmed is the 470R resistor. :) Ended up doing some code to test and connect bypassing the 1K resistor and it worked fine. http://img706.imageshack.us/img706/3064/20121027004238.jpg After I removed the 470R resistor and used a lower one, 4.7R (didn't find a 47R at home) and the radio cou...
by IceWind
Fri Oct 26, 2012 11:07 pm
Forum: FRSky Telemetry Mods
Topic: FrSky telemetry mod without RS232 level converter
Replies: 128
Views: 65410

Re: FrSky telemetry mod without RS232 level converter

Well I'm still checking it.
So far I traced all the way to the pins on the 9x module slot and it's fine.
The er9x FW fetches the alarms thresholds right after we turn on the radio.

I'll keep checking it all up until the uC itself. :)
by IceWind
Fri Oct 26, 2012 4:56 pm
Forum: FRSky Telemetry Mods
Topic: FrSky telemetry mod without RS232 level converter
Replies: 128
Views: 65410

Re: FrSky telemetry mod without RS232 level converter

Ehehe! :)
It's better to use the R notation. So you've used a 47R resistor. :)

I'll try to change it today to a SMD 10K (if I don't find any 47R at home) and see how it goes.

Go to advanced search