Search found 37 matches

by athertop
Sun Feb 09, 2020 5:22 pm
Forum: OpenXVario - an open source vario supported by the open source firmwares!!
Topic: LUA script for openTX how to?
Replies: 3
Views: 1122

Re: LUA script for openTX how to?

Have a look at the Yaapu script. His solution and installation of the script on FrSky radios is well documented. See here: https://github.com/yaapu/FrskyTelemetryScript

best regards
by athertop
Thu Jul 12, 2018 12:08 pm
Forum: FrSky Taranis radio
Topic: Taranis X9D Plus SE Antenna problem
Replies: 11
Views: 3480

Re: RE: Re: Taranis X9D Plus SE Antenna problem

Could use two receivers, one with each transmitter using internal for telemetry (opentx). With ersky9x for Taranis you can choose which transmitter you want to use for telemetry, internal or external. But the LRS systems I mentioned allow any serial data through, multiplexed with the rc data, so fu...
by athertop
Thu Jul 12, 2018 10:59 am
Forum: FrSky Taranis radio
Topic: Taranis X9D Plus SE Antenna problem
Replies: 11
Views: 3480

Re: RE: Re: Taranis X9D Plus SE Antenna problem

Most people use the transmitter antenna that comes with there Taranis. Sometimes range is affected by where you are doing your testing. You may want to look at the external TBS Crossfire (https://alofthobbies.com/tbs-crossfire-diversity-bundle.html). I'm happy with ULRS thanks with full duplex 1920...
by athertop
Thu Jul 12, 2018 10:26 am
Forum: FrSky Taranis radio
Topic: Taranis X9D Plus SE Antenna problem
Replies: 11
Views: 3480

Re: RE: Re: Taranis X9D Plus SE Antenna problem

Could buy the external XJT module and this could fix all your troubles too (https://alofthobbies.com/frsky-xjt-jr-graupner-type-16ch-duplex-transmitter-telemetry-module.html). I did that also, but initial testing showed range issues with this too, so ended up with a new taranis. I never gave that m...
by athertop
Thu Jul 12, 2018 8:34 am
Forum: FrSky Taranis radio
Topic: Taranis X9D Plus SE Antenna problem
Replies: 11
Views: 3480

Re: RE: Re: Taranis X9D Plus SE Antenna problem

The ESD protection was not originally there, it was only added at some point after too many people shot their board while adding an SMA pigtail. That is good to know! Wondering how we could identify a board with esd protection - and if those replacement boards from banggood have this feature. Incid...
by athertop
Fri Dec 29, 2017 12:49 am
Forum: openTx for FrSky radios
Topic: Display minimum cell value with 2.2.1 Telemetry
Replies: 3
Views: 928

Re: RE: Display minimum cell value with 2.2.1 Telemetry

I just upgraded to OpenTX 2.2.1, and I cannot find the way to display in the screen the lowest cell value. In 2.0 I just have a Cell parameter that showed the minimum value, but in 2.2 cannot figure out how to obtain that value. Is anywhere where the new values/calculations are explained for 2.2? T...
by athertop
Tue Feb 21, 2017 9:48 pm
Forum: openTx
Topic: Can LUA detect if reset flight has occurred?
Replies: 3
Views: 1230

Can LUA detect if reset flight has occurred?

I have a telemetry script running on 2.1 (and 2.2) Taranis, and want to have some variables in the script reset if the user chooses the "reset flight" menu option. Is there any way to detect in the script that "reset flight" has been actioned?

Thanks, Paul
by athertop
Tue Feb 14, 2017 8:32 pm
Forum: openTx for FrSky radios
Topic: S6R config wizard in 2.2RC10
Replies: 10
Views: 3674

Re: S6R config wizard in 2.2RC10

Kilrah, I just tried running through the S6R_Calibrate.lua script, and keep hitting snags running this also. When a calibration takes, it flashes the yellow LED which stays on for a second then goes off, but I have not managed to complete all the calibration steps - when it fails, the yellow LED jus...
by athertop
Tue Feb 14, 2017 12:41 pm
Forum: openTx for FrSky radios
Topic: S6R config wizard in 2.2RC10
Replies: 10
Views: 3674

Re: S6R config wizard in 2.2RC10

No, no module. I will try again tonight.

Sent from my Nexus 6P using Tapatalk
by athertop
Tue Feb 14, 2017 12:03 pm
Forum: openTx for FrSky radios
Topic: S6R config wizard in 2.2RC10
Replies: 10
Views: 3674

Re: RE: Re: S6R config wizard in 2.2RC10

Kilrah wrote:Then transmission failed in the middle of reading parameters. Make sure you're not too close to the receiver and try again.
I have tried dozens of times with no improvement. Getting solid green light, so no disconnection.

Incidentally, the calibration script works fine.
by athertop
Tue Feb 14, 2017 11:18 am
Forum: openTx for FrSky radios
Topic: S6R config wizard in 2.2RC10
Replies: 10
Views: 3674

S6R config wizard in 2.2RC10

I have this morning been trying to configure a S6R with the s6r.lua script included on the 2.2V0005 SDCard files. I am running 2.2RC10 on a Taranis+. Page 1/2 allows me to select Delta and Horiz, then page 2/2 allows me to select Enable as first field (S6R Functions), but then all the following fiel...
by athertop
Mon May 23, 2016 12:01 am
Forum: openTx
Topic: Stop track from playing
Replies: 3
Views: 1027

Re: Stop track from playing

Yes I ended up using the BGMusic option, but this repeats the track over and over - I need it to play just once for a launch script (After its launched I don't need it to play over and over - maybe this could be an option for the BGMusic in a future release?
by athertop
Thu May 05, 2016 2:51 pm
Forum: openTx
Topic: Stop track from playing
Replies: 3
Views: 1027

Stop track from playing

I don't think this is currently possible, but I would really like to discuss the idea of having a new option added to the "Play Track" Special Function on the Taranis. This new option when enabled, would allow the new track to play, interupting (stopping) any existing tracks that are in the queue fr...
by athertop
Fri Apr 29, 2016 7:26 am
Forum: openTx
Topic: Lua Script Tips
Replies: 1
Views: 1058

Re: Lua Script Tips

You don't need to use LUA to do any of that stuff. You can do it on the Taranis directly without programming. For the 3-pos switch to give specific values, start in the curves screen and create a 3 point curve with your three values (for those 3 positions) on the y axis. These will correspond with 1...
by athertop
Tue Apr 26, 2016 11:11 pm
Forum: openTx
Topic: Companion 2.1.8 (mac) simulator bug
Replies: 0
Views: 2450

Companion 2.1.8 (mac) simulator bug

Hi, I have been following a youtube video to setup an autolaunch mix on my Taranis. its basically 3 of the mixer channels replaced when switch SF is flipped towards me (shows SFdown in the mixer page), each of these replacement mix lines has a different up time associated with it - on the Taranis th...
by athertop
Fri Apr 15, 2016 8:35 pm
Forum: Hardware
Topic: X6R lost bind and will not rebind
Replies: 3
Views: 1432

Re: X6R lost bind and will not rebind

I had this exact same issue last night with my X6R. Mine is using the latest EU LBT firmware. I have had it bound to my taranis plus for over a month on a Bix 3 plane, and about a week ago I transferred it to a new Cloud Surfer model I am building and its been working in my workshop in this model fo...
by athertop
Mon Mar 28, 2016 11:20 pm
Forum: openTx
Topic: Companion bug in external radio module setup
Replies: 3
Views: 787

Companion bug in external radio module setup

This issue is just in Companion and not in the 2.1.7 OpenTx f/w for Taranis plus:
Screen Shot 2016-03-29 at 00.13.30.jpg
The max number of channels you can set is 15, not 16 strangely. Just a validation error it appears based on value of the start ch.
by athertop
Mon Mar 28, 2016 10:17 pm
Forum: openTx
Topic: 2.1.7 Mixer delay bug (and a lot of head scratching)
Replies: 11
Views: 2092

Re: 2.1.7 Mixer delay bug (and a lot of head scratching)

In your case all these MAX lines should go in an Input, and in the mixer you just have 100% [input] and the delay. Kilrah, you are indeed a font of great knowledge! Thanks for this info. I just setup 5 Logical switches each using ANDs based on positions of my 2 switches SD and SG, each to represent...
by athertop
Mon Mar 28, 2016 4:12 pm
Forum: openTx
Topic: 2.1.7 Mixer delay bug (and a lot of head scratching)
Replies: 11
Views: 2092

Re: 2.1.7 Mixer delay bug (and a lot of head scratching)

Delay and slow work on a change of the source value, not on activation/deactivation of a line. If you set your source as the throttle stick and move it the dealy/slow will be applied to it. You use them on source MAX, which never varies so in any case you're not going to get the behavior you expect...
by athertop
Sun Mar 27, 2016 9:33 pm
Forum: openTx
Topic: 2.1.7 Mixer delay bug (and a lot of head scratching)
Replies: 11
Views: 2092

Re: 2.1.7 Mixer delay bug (and a lot of head scratching)

You should only ever have ONE line with a slow on a given channel, not more. I am using 'delay up/dn', rather than 'slow'. Is this comment valid to the delay configuration also? I have just tested putting the up/down delay to 0.3s on only the first mix line for Ch5 (as per my original screenshot in...
by athertop
Sun Mar 27, 2016 2:45 pm
Forum: openTx
Topic: 2.1.7 Mixer delay bug (and a lot of head scratching)
Replies: 11
Views: 2092

2.1.7 Mixer delay bug (and a lot of head scratching)

I think I have identified a bug in OpenTx 2.1.7 on Taranis Plus. I have the following mixes set up for Ch5 which controls my APM:Plane flight modes thus: Screen Shot 2016-03-27 at 13.45.09.jpg So there are two 3-pos switches controlling 5 different flight modes. With SG in the up position, SD is ful...
by athertop
Sat Dec 26, 2015 9:55 pm
Forum: openTx
Topic: 2.1 & GPS coordinates from LUA
Replies: 7
Views: 3088

Re: 2.1 & GPS coordinates from LUA

Just found this thread and trying to learn lua. I wrote this script based on the info above, but nothing displays at all on the telem screen running this code: local gpsLatLon = {} local function run(event) lcd.clear() gpsLatLon = getValue("GPS") if (type(gpsLatLon) == "table") then lcd.drawText(1,1...
by athertop
Sun Oct 11, 2015 8:48 pm
Forum: openTx
Topic: OpenTX 2.1 telemetry system preview
Replies: 281
Views: 124968

Re: OpenTX 2.1 telemetry system preview

I see what you mean - I tried this workaround also and it does as you suggested. Nice work! To be honest though, this is a bug as the form shouldn't allow itself to get caught up this way, requiring the workaround to get the sensor row usable again. Do you concur? Should I make a feature request for...
by athertop
Sun Oct 11, 2015 3:46 pm
Forum: openTx
Topic: OpenTX 2.1 telemetry system preview
Replies: 281
Views: 124968

Re: OpenTX 2.1 telemetry system preview

That's a great idea! Many thanks for checking this for me. eepe file attached.

On a separate note - is there a way to easily copy telemetry settings to another existing model?

Best regards, Paul
by athertop
Sun Oct 11, 2015 1:32 pm
Forum: openTx
Topic: OpenTX 2.1 telemetry system preview
Replies: 281
Views: 124968

Re: OpenTX 2.1 telemetry system preview

Hmm if that line previously had a GPS sensor that wasn't deleted on the radio it's possible it still has its unit set to GPS, which hides the fields you don't see. Setting type to something else than custom should reset the other parameters and/or allow you to change them. If I set this line to Cal...
by athertop
Sun Oct 11, 2015 12:05 pm
Forum: openTx
Topic: OpenTX 2.1 telemetry system preview
Replies: 281
Views: 124968

Re: OpenTX 2.1 telemetry system preview

Maybe I'm not explaining myself clearly - apologies. This is what I am seeing (even if no data is entered on line 12 in the sensors table): Screen Shot 2015-10-11 at 12.59.14.jpg Regardless of the settings assigned to that row, it remains like this (as long as its set to 'Custom'). As I suggested, l...
by athertop
Sat Oct 10, 2015 10:27 pm
Forum: openTx
Topic: OpenTX 2.1 telemetry system preview
Replies: 281
Views: 124968

Re: OpenTX 2.1 telemetry system preview

Any idea why the telemetry page in Companion (I'm using 2.1.3 just now) has some of the sensor lines which don't display all the fields - on mine the 12th sensor definition line down (if selected as 'Custom') has the 2nd field (the one where 'Custom' appears) much longer than the same field on all o...
by athertop
Sat Sep 26, 2015 8:40 pm
Forum: General help (FrSky Taranis radio)
Topic: Losing signal strength over short distances
Replies: 2
Views: 1638

Re: Losing signal strength over short distances

I tried various antenna orientations to get the best possible signal. I didn't know there was a range test mode! :? I was just simply looking at the telemetry screen where I had RSSI and SWR displayed. I shot a video if it - apologies, Its a bit boring! https://goo.gl/photos/S4s3yQZ6JU9Fw79n6
by athertop
Sat Sep 26, 2015 5:12 pm
Forum: General help (FrSky Taranis radio)
Topic: Losing signal strength over short distances
Replies: 2
Views: 1638

Losing signal strength over short distances

Ever since I have had my Taranis Plus (about 6 months now), due to being new to RC I have never really flown beyond 150m, I have noticed however that at this sort of distance I have been seeing fairly low signal strength (RSSI) - down to 40db. On my 680Pro hexa its never really caused any issues (ne...
by athertop
Sat Aug 29, 2015 5:10 pm
Forum: companion9x
Topic: "Hold" in simulator
Replies: 4
Views: 4607

Re: "Hold" in simulator

So the program remembers, that the centering spring is disabled, but not, that the throttle is down ... Does not make sense :? I have always thought the same. This should maybe requested as an enhancement? In open Tx 2 the companion shows s3 also but does not work well at all to simulate the 6pos s...

Go to advanced search