FRSKY R9M compatibility?

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
Post Reply
Ukalelefpv
Posts: 3
Joined: Mon Apr 09, 2018 12:06 am
Country: -

FRSKY R9M compatibility?

Post by Ukalelefpv » Mon Apr 09, 2018 12:09 am

I currently have a TGY 9x that has the module mod and I will be adding ER9X to it once I get a USBASP programmer. I am also going to do the telemetry mod so I can get telemetry from my multiprotocol module following oscar liang's post but only worrying about cutting traces on pin 5 as it instructs on github. I am curious to see if this firmware. ER9x frsky, also will be compatible with the R9M using telemetry for RSSI. If anyone knows please let me know!

Mahalo!

Ukalele FPV

User avatar
MikeB
9x Developer
Posts: 15651
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Mon Apr 09, 2018 11:07 am

Does your 9X have a '64 or a '128 processor?
The R9M needs some additional options (like power setting), that are not currently in er9x (but are in ersky9x for other radios), but I can add them for the '128, but the '64 code just doesn't have any spare space.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Ukalelefpv
Posts: 3
Joined: Mon Apr 09, 2018 12:06 am
Country: -

Re: FRSKY R9M compatibility?

Post by Ukalelefpv » Mon Apr 09, 2018 8:40 pm

I just opened up my 9x and see that it has the '128 processor. That would be awesome but it doesn't have to be top priority as I do not have the funds quite yet to get my r9m I was really just curious to see if it would be a viable option for me. Mahalo Mike!

Ukalele FPV

volumax
Posts: 199
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Thu Jul 12, 2018 3:15 am

Hey Ukalelefpv did you get the r9m module and did you get to flash it with your t9x radio? How do I know if I have the 64 or 128 processor?

Mikeheli45
Posts: 1
Joined: Wed Aug 08, 2018 4:48 pm
Country: -

Re: FRSKY R9M compatibility?

Post by Mikeheli45 » Wed Aug 08, 2018 4:51 pm

That would be great if any one has any info on this ..so far I can not get bind process to work r9m module light stays red when in bind mode and nothing happens..Angelo would be appreciated.
Thanks Mike :?:


User avatar
MikeB
9x Developer
Posts: 15651
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Thu Aug 09, 2018 10:40 am

I've just posted a new test version (822g). This includes support for the R9M in '128 and 2561 radios.
I tested I could bind on my '2561.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17923
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FRSKY R9M compatibility?

Post by jhsa » Thu Aug 09, 2018 11:15 am

Mike, did you do anything regarding that problem of the radio not staying in the bootloader on the m2561 if the FTDI adapter is built permanently inside the radio?
Currently, if i update my radio to a version with bootloader, I lose the ability to share models and voice files between PC and radio's SD Card.
People in the same situation have 2 options at the moment.
1 - Do not update Er9x anymore..
2 - Update the firmware, but then downgrade to an older version without bootloader every time they want to download/upload a model from/to the radio, which is a pain :)

Thanks

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “er9x”