Problem with 9XR, XJT and XM+

Hardware Support for the 9XR
Crashex
Posts: 17
Joined: Thu Sep 07, 2017 4:09 pm
Country: -

Re: Problem with 9XR, XJT and XM+

Post by Crashex » Sun Sep 24, 2017 10:44 am

I cut the link between the two middle ground pins and the two side ones, they are not connected to anything now. But it gives the same error:

Code: Select all

Started AVRDUDE
C:/Program Files (x86)/eePe/avrdude.exe -c usbasp -p m128 -P usb -U eeprom:r:C:/Users/ask80/AppData/Local/Temp/temp.hex:i
=================================================================================

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude.exe: error: programm enable: target doesn't answer. 1 
avrdude.exe: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.


avrdude.exe done.  Thank you.


=================================================================================
AVRDUDE done - exit code 1
=================================================================================

ReSt
Posts: 1438
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Problem with 9XR, XJT and XM+

Post by ReSt » Sun Sep 24, 2017 2:50 pm

Separate the two middle pins also from each other

Again: Don't use the -F option

With power off (and/or battery removed)
The last what you can check now is, that all wires are really connected correctly from the solderpad on the board through the cables and plugs/connectors to the corresponding pin on the programmer; that Miso goes to Miso, Mosi to Mosi and so no. And that there is no short of any signal to ground or any of the other pins.

If that all turns out to be correct, then I'm afraid, it is your programmer that doesn't work as required.

Reinhard

User avatar
jhsa
Posts: 17439
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Problem with 9XR, XJT and XM+

Post by jhsa » Sun Sep 24, 2017 8:31 pm

Can you please post a picture of the radio's mainboard? Also what processor does it have?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

marhub
Posts: 1
Joined: Thu Feb 08, 2018 10:46 pm
Country: -

Re: Problem with 9XR, XJT and XM+

Post by marhub » Thu Feb 08, 2018 10:48 pm

@crashex have you resolved problem with your radio ? Flashing to new firmware helps ?
I have same exact problem ...
Radios working, rx working, they are binding but no comunication in betaflight...

Post Reply

Return to “Turnigy 9XR radio”