Another Flash Issue

General Help and support for the Taranis Radio.
Post Reply
GordonB
Posts: 3
Joined: Fri Jan 06, 2017 8:43 pm
Country: -

Another Flash Issue

Post by GordonB » Fri Jan 06, 2017 8:58 pm

Hello everyone, I hope someone can help.
My Stepson has brought me his Tranis - Plus to try to get working again.
Apparently he tried to flash the firmware, I'm not certain which method he used but the end result is that when powered on there's a femal voice saying "Welcome to open TX" - then she says a word I can't understand followed by warning, so that's;
??????? Warning
Also while this is going on there's a strange WHOOOOOO noise from the device.
I've downloaded and installed Open TX Companion 2.0, followed the instructions here;
http://open-txu.org/home/special-intere ... d-taranis/
Got the correct driver etc downloaded the needed firmware and tried to write to the Taranis, only to get a message saying;
Firmware check failied.
New firmware is not compatible with one currently installed.
This is where I am, stuck. :?
Any help much appreciated.

User avatar
Kilrah
Posts: 8908
Joined: Sat Feb 18, 2012 6:56 pm
Country: United Arab Emirates

Re: Another Flash Issue

Post by Kilrah » Fri Jan 06, 2017 9:53 pm

Make sure you're not mixing Taranis and Taranis Plus, and using the right firmware.

GordonB
Posts: 3
Joined: Fri Jan 06, 2017 8:43 pm
Country: -

Re: Another Flash Issue

Post by GordonB » Sat Jan 07, 2017 12:14 am

Thanks for your input.
The unit Has TARANIS - plus on the lower front.
The firmware I'm trying to use is, opentx-taranisplus-en.bin, latest one just downloaded today.
It's late now there's probably more info I can give if needed so I'll come back tomorrow.

User avatar
Kilrah
Posts: 8908
Joined: Sat Feb 18, 2012 6:56 pm
Country: United Arab Emirates

Re: Another Flash Issue

Post by Kilrah » Sat Jan 07, 2017 7:52 am

Then it's all good, ignore the warning and flash anyway (or disable the check). If FrSky-supplied firmware is currently installed it will give you a false warning.

GordonB
Posts: 3
Joined: Fri Jan 06, 2017 8:43 pm
Country: -

Re: Another Flash Issue

Post by GordonB » Sat Jan 07, 2017 1:19 pm

Absolutely superb!! :D
Worked like a dream, did it without the unit switched on, which from what I've been reading seems to be the preffered method.
My step son now thinks I'm a genius ;)
Thanks loads.


Keithbaskerville
Posts: 3
Joined: Sun Jan 08, 2017 3:29 pm
Country: -

Re: Yet!! Another Flash Issue

Post by Keithbaskerville » Wed Jan 11, 2017 5:42 pm

New taranis plus delivered, first quad built, flashed updated firmware (big mistake). one site said taranis plus was only for programmers and to use taranis. Now just got fierce vibration and blank screen. been trying for weeks following advise being given to dozens of people on opentx and rc forums with the same problem as me but all of their happy outcomes have not worked for me.I suspect I'm now well beyond my comfort/knowledge zone. Is there a Taranis guru in the Cheshire UK, area who might be able to help me. Happy to pay for education.
Thanks Keith
Last edited by Keithbaskerville on Thu Jan 12, 2017 8:53 am, edited 1 time in total.

User avatar
MikeB
9x Developer
Posts: 14019
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset

Re: Another Flash Issue

Post by MikeB » Wed Jan 11, 2017 6:41 pm

If you have a Taranis Plus, then you must flash firmware for the Plus, not the standard Taranis.
Do you have Companion installed on your PC?

As a check some things are still working, hold both horizontal trim switches towards the centre, then power on. Do you get into the bootloader?

Mike.
ersky9x/er9x developer

User avatar
Kilrah
Posts: 8908
Joined: Sat Feb 18, 2012 6:56 pm
Country: United Arab Emirates

Re: Another Flash Issue

Post by Kilrah » Wed Jan 11, 2017 6:45 pm

Just download the right firmware and flash it the exact same way you did for the wrong one.

User avatar
jhsa
Posts: 15997
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Another Flash Issue

Post by jhsa » Wed Jan 11, 2017 6:52 pm

I believe it is not a good idea to publish your phone number on a public place.. I would edit the post.. :)
Welcome to the forum by the way :D

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Keithbaskerville
Posts: 3
Joined: Sun Jan 08, 2017 3:29 pm
Country: -

Re:yet Another Flash Issue

Post by Keithbaskerville » Thu Jan 12, 2017 4:27 pm

I have OpenTX companion installed on my pc and have faithfully followed "clearing bricked Taranis", both with battery in and out. Ticked "offer to write FW to TX after download, pressed OK, no reaction. Pressed icon to download, window reads file downloaded successfully. No valid DFU suffix signature. Warning file has no DFU suffix. Safety eject STM boot loader, no other items showing to eject. Still no change after 3 finger power on.
I have read on some blogs that editing the micro SD card direct by deleting the files in the Firmare file and reloading may work. Has anybody done it this way?. I would be grateful for some guidance before disappearing down this rabbit hole.
Regards Keith

User avatar
Kilrah
Posts: 8908
Joined: Sat Feb 18, 2012 6:56 pm
Country: United Arab Emirates

Re: Another Flash Issue

Post by Kilrah » Thu Jan 12, 2017 7:01 pm

SD card has nothing to do with firmware.
Please say exactly what name the file you're flashing has, it's still likely the wrong one.

Keithbaskerville
Posts: 3
Joined: Sun Jan 08, 2017 3:29 pm
Country: -

Re: Another Flash Issue

Post by Keithbaskerville » Fri Jan 13, 2017 7:55 pm

Dear Kilrah, thank you for your reply, and patience. In settings I pick Frsky Taranis plus, will not load automatically on OK. I press icon write firmware to radio, I change file from Taranis-en-2.0.2.0 bin to Taranisplus-en-2.0.2.0 bin, press write to TX.
Message - firmware check failed - new firmware is not compatible with one currently installed.
If I go into downloads in companion it shows firmware as OpenTX-x9d+-en. If I go into write models and settings to radio - OpenTX-taranisplus-en-2.0.2.0.bin, message comes up, error - invalid model and settings file
Regards. Keith

Post Reply

Return to “General help (FrSky Taranis radio)”

Who is online

Users browsing this forum: No registered users and 1 guest