LUA Scripts "Broken" with OpenTX 2.2 "upgrade"..

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
oldgazer
Posts: 1
Joined: Thu Dec 01, 2016 11:27 pm
Country: -

LUA Scripts "Broken" with OpenTX 2.2 "upgrade"..

Post by oldgazer » Fri Dec 02, 2016 1:06 am

I know 2.2 is beta, and I know there will be issues, so please be gentle.

Here is the background:

Taranis X9E.

Two aircraft, #1 is a hexacopter with a Pixhawk running AC3.4.2 #2 is a quad with an APM 2.6 running AC3.2.1. Receivers are X8R's

To get telemetry from the APM I am using a Teensy and Scottflys' Telemetry scripts.

To get telemetry from the Pixhawk I am using Craft and Theory's Flilght Deck 3.03 interface and scripts.

The reason I flashed the radio with 2.2 is two fold. First, support for the C&T hardware was added to AC3.4. Previously one had to flash the Pixhawk with a firmware that had been modified by C&T. Second, the latest version of Flight Deck will only run under OpenTX 2.2..

The problem I have is that although Flight Deck works, Scottflys' does not and OpenTX throws syntax errors. In addition the New Model Wizard hangs.

I have been in touch with C&T, and they tell me the only difference between the 'old' an 'new' scripts is the 'new' scripts are compiled to save space..

So, what I'm wondering is, can this problem be resolved by compiling the 'old' scripts?

User avatar
Kilrah
Posts: 9020
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: LUA Scripts "Broken" with OpenTX 2.2 "upgrade"..

Post by Kilrah » Fri Dec 02, 2016 7:11 am

"Scottfly" might be using functions that have changed between 2.1 and 2.2 while C&T weren't, he (or someone else) will have to review and adapt the scripts.

The 2.2 Lua documentation is being worked on these days.
https://opentx.gitbooks.io/opentx-2-2-l ... e/content/

Post Reply

Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests