If you are trying to install arduino mission planner on suse/centos, you''l need this

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
wuzamarine
Posts: 30
Joined: Tue Oct 18, 2016 5:52 pm
Country: -

If you are trying to install arduino mission planner on suse/centos, you''l need this

Post by wuzamarine » Mon Nov 21, 2016 4:45 am

I just got mission planner compiled for Linux.

It was a little painful because my Qt5 installation was bare.
There are a few modules you need to install that are not on the list in their documentation.

Here is a repo dump and rpm query for Qt5 packages. It will save somebody a lot of time.


# zypper lr
# | Alias | Name | Enabled | GPG Check | Refresh
---+-------------------------------------+-----------------------------------------+---------+-----------+--------
1 | CrossToolchain:avr | CrossToolchain:avr | No | ---- | Yes
2 | devel:languages:perl | devel:languages:perl | Yes | (r ) Yes | Yes
3 | http-download.opensuse.org-40671ab2 | X11:Utilities | Yes | (r ) Yes | Yes
4 | http-download.opensuse.org-572f090b | home:dnh | Yes | (r ) Yes | Yes
5 | http-download.opensuse.org-8ab5f5fd | CrossToolchain:avr | Yes | (r ) Yes | Yes
6 | openSUSE-42.1-0 | openSUSE-42.1-0 | No | ---- | No
7 | repo-debug | openSUSE-Leap-42.1-Debug | No | ---- | Yes
8 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss | No | ---- | Yes
9 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug | No | ---- | Yes
10 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No | ---- | Yes
11 | repo-non-oss | openSUSE-Leap-42.1-Non-Oss | No | ---- | Yes
12 | repo-oss | openSUSE-Leap-42.1-Oss | Yes | (r ) Yes | Yes
13 | repo-source | openSUSE-Leap-42.1-Source | No | ---- | Yes
14 | repo-update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | Yes
15 | repo-update-non-oss | openSUSE-Leap-42.1-Update-Non-Oss | No | ---- | Yes


# rpm -qa|grep qt
libmygpo-qt1-1.0.7-5.1.x86_64
libqt4-linguist-4.8.6-13.1.x86_64
libmarblewidget-qt5-23-15.12.3-15.5.x86_64
bluez-qt-udev-5.21.0-12.1.x86_64
libqt5-qtscript-devel-5.5.1-3.2.x86_64
qt4-qtscript-0.2.0-11.7.x86_64
libpoppler-qt5-1-0.24.4-12.1.x86_64
libqt4-4.8.6-13.1.x86_64
libtelepathy-qt4-2-0.9.5-2.3.x86_64
libqt4-sql-4.8.6-13.1.x86_64
libastro-qt5-1-15.12.3-15.5.x86_64
libqt5-qttools-devel-5.5.1-3.2.x86_64
libdbusmenu-qt2-0.9.2+14.04.20131209-3.11.x86_64
libqt5-qtsensors-devel-5.5.1-3.1.x86_64
libsignon-qt5-1-8.57-5.1.x86_64
libqt5-qtsvg-devel-5.5.1-3.1.x86_64
sni-qt-0.2.6-6.2.x86_64
libyui-qt7-2.46.21-1.1.x86_64
libqt5-qtdeclarative-devel-5.5.1-9.1.x86_64
libqt5-qtgraphicaleffects-5.5.1-3.1.x86_64
libqt4-sql-mysql-4.8.6-13.1.x86_64
libqt4-devel-doc-4.8.6-13.3.x86_64
libpoppler-qt4-4-0.24.4-12.1.x86_64
phonon4qt5-backend-gstreamer-4.8.2-2.4.x86_64
yast2-qt-branding-openSUSE-42.1-6.2.noarch
libqt5-qttools-5.5.1-3.2.x86_64
libpolkit-qt5-1-1-0.112.0-4.2.x86_64
libqt5-qtbase-platformtheme-gtk2-5.5.1-10.1.x86_64
libqt5-qtquick1-devel-5.5.1-3.2.x86_64
bluez-qt-imports-5.21.0-12.1.x86_64
libqca-qt5-plugins-2.1.1-1.1.x86_64
pinentry-qt4-0.8.3-3.3.x86_64
libqt4-x11-4.8.6-13.1.x86_64
libqt5-linguist-5.5.1-3.2.x86_64
libqt5-qtwayland-5.5.1-3.3.x86_64
libyui-qt-graph7-2.44.5-1.3.x86_64
libqt5-qtdeclarative-tools-5.5.1-9.1.x86_64
libyui-qt-pkg7-2.45.5-1.2.x86_64
libmarblewidget-qt5-22-15.08.3-3.2.x86_64
libqt4-qt3support-4.8.6-13.1.x86_64
libqt5-qtquickcontrols-5.5.1-3.1.x86_64
libqt4-devel-doc-data-4.8.6-13.3.noarch
libqt5-qtbase-common-devel-5.5.1-10.1.x86_64
gstreamer-plugins-qt-1.2.0-3.2.x86_64
libaccounts-qt5-1-1.13-3.1.x86_64
libqt5-qtwayland-devel-5.5.1-3.3.x86_64
yast2-control-center-qt-3.1.5-2.5.x86_64
libdbusmenu-qt5-2-0.9.3+15.10.20150604-3.11.x86_64
libphonon4qt5-4.8.3-4.11.x86_64
libqt5-qtimageformats-5.5.1-3.1.x86_64
libqca-qt5-2.1.1-1.1.x86_64
libqt5-qtserialport-devel-5.5.1-3.1.x86_64
libpackagekitqt5-0-0.9.5-2.4.x86_64
qt-creator-3.2.2-4.10.x86_64
libpolkit-qt-1-1-0.103.0-5.1.x86_64
libqt5-linguist-devel-5.5.1-3.2.x86_64
libqt4-sql-sqlite-4.8.6-13.1.x86_64


# cat /etc/*-release
NAME="openSUSE Leap"
VERSION="42.1"
VERSION_ID="42.1"
PRETTY_NAME="openSUSE Leap 42.1 (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:42.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://opensuse.org/"
ID_LIKE="suse"
openSUSE 42.1 (x86_64)
VERSION = 42.1
CODENAME = Malachite

User avatar
kalle123
Posts: 634
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: If you are trying to install arduino mission planner on suse/centos, you''l need this

Post by kalle123 » Mon Nov 21, 2016 6:50 am

What is a "arduino mission planner"?
Link please.

br KH

wuzamarine
Posts: 30
Joined: Tue Oct 18, 2016 5:52 pm
Country: -

Re: If you are trying to install arduino mission planner on suse/centos, you''l need this

Post by wuzamarine » Wed Nov 23, 2016 2:46 pm

kalle123 wrote:What is a "arduino mission planner"?
Link please.

br KH

Ah, yes
https://github.com/ArduPilot/apm_planner

my bad..

User avatar
kalle123
Posts: 634
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: If you are trying to install arduino mission planner on suse/centos, you''l need this

Post by kalle123 » Wed Nov 23, 2016 4:34 pm

:mrgreen: can happen ...

Post Reply

Return to “Software”

Who is online

Users browsing this forum: darozas and 1 guest