Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Sat Jul 15, 2017 3:21 pm

I have a Taranis X9DP v2.0.20 OTX, kept existing OTXC 2.0.20 and installed OTXC 2.1.9. Stored "opentx-taranisplus-en-2.1.9.bin in a deeply nested file and then navigated OTXC 2.1.9 Firmware Update path to this deeply nested file. Get error message "Executable D:..path, opentx-taranisplus-en-2.1.9.bin could not be found. So I stored the opentx-taranisplus-en-2.1.9.bin on my desktop and tried again navigating this time to the .bin file on my desktop but I still get the same error!?

acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Sat Jul 15, 2017 5:42 pm

Found the solution, Kilrah once again provided the answer. With 2.0.20 I should have powered up the x9d+ rather than try this with power off via the previous FW load method.

acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Mon Jul 17, 2017 4:21 pm

I do want to reopen this question. I should be able to connect my x9d+ (powered off state) via USB to my computer, launch OTXC v2.1.9, select write firmware icon, navigate to the location where my "opentx-taranisplus-en-2.1.9" is stored and write the FW and new bootloader to my x9d+.

I am not able to do this I get the following error:
Executable D:/##ACS R&D/FrSky Taranis X9D Tx/FrSky_OpenTxCompanion 2.1.xx version June 2017/OpenTxCompanion 2.1.9/opentx-taranisplus-en-2.1.9.bin not found. Even if I put the opentx-taranisplus-en-2.1.9.bin on my desktop and navigate to it I still get the same error.

User avatar
Kilrah
Posts: 9058
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by Kilrah » Mon Jul 17, 2017 8:15 pm

acsrandd wrote:
Mon Jul 17, 2017 4:21 pm
Executable
You have somehow set the path to dfu-util.exe in "configure communications" to the firmware to flash.

Set it back correctly to dfu-util.exe in the directory companion is installed in.

acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Tue Jul 18, 2017 12:19 am

Kilrah, thanks that gets me closer to resolving this issue.

Now I get the error "could not check firmware from radio" (radio off, USB connected, profile set to FrSky Taranis 9XD+) and the firmware update process automatically ends. I am able to update the FW via the three finger solute but of course that leaves the old ver. of the bootloader i.e. 2.0.20 boot loader. I know I can leave the old boot loader but I really want the same rev. for the BL as the FW.


User avatar
Kilrah
Posts: 9058
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by Kilrah » Tue Jul 18, 2017 10:29 pm

Put the firmware file on the radio's SD card and update bootloader from the radio if you really want to.

acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Wed Jul 19, 2017 2:25 pm

Kilrah, any idea why the power off update does not work and I am forced to the SD card route?

User avatar
Kilrah
Posts: 9058
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by Kilrah » Wed Jul 19, 2017 5:58 pm

SD card route is the recommended one. Power off requires installing specific drivers, and that's best avoided. Power off is meant to be for recovery only if all else fails.

acsrandd
Posts: 23
Joined: Thu Sep 10, 2015 4:31 pm
Country: -

Re: Tried to upgrade OTX 2.0.20 to 2.1.9 error finding .bin file

Post by acsrandd » Fri Jul 21, 2017 5:55 pm

Kilrah, thanks.

Also, I asked you about the S2/S3 issue on the X9D+ TX (a different thread - viewtopic.php?f=97&t=7122&p=98153&hilit ... ent#p98153) any comments, suggestions?

Post Reply

Return to “Software”

Who is online

Users browsing this forum: No registered users and 3 guests