Time in log file

Post Reply
mpjf01
Posts: 367
Joined: Thu Jul 26, 2012 3:07 am
Country: -
Location: Adelaide, Australia

Time in log file

Post by mpjf01 » Mon Jan 29, 2018 12:11 am

What is the "time" entry in the log file displaying please? Is there a relationship between the logged time and the time of day shown on the Tx? The log file time seems to be affected by the timezone and can show values >24 (presumed) hours so it's obviously not meant to be time of day.

User avatar
Kilrah
Posts: 9518
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Time in log file

Post by Kilrah » Mon Jan 29, 2018 8:23 am

It's supposed to be the radio date/time if the radio has an RTC.

Now you didn't mention either radio type or version, so...

mpjf01
Posts: 367
Joined: Thu Jul 26, 2012 3:07 am
Country: -
Location: Adelaide, Australia

Re: Time in log file

Post by mpjf01 » Mon Jan 29, 2018 9:35 am

The date in the log file is correct.

I checked both my X9D and my X9D+. OTX 2.2.1. The actual date and time on the radio screen are correct and maintained during power off so I assume there's a RTC. There's a battery on the main board. I note that there's a tick box titled "adjust RTC" which I haven't changed from what it was set to by default (it's not ticked). Maybe that's a factor. Or maybe the time zone (0).

jtaylor
Posts: 129
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Time in log file

Post by jtaylor » Mon Jan 29, 2018 5:33 pm

My openTX 2.2.1 X9D logs the same time of day as shown on the transmitter with the exception of adding decimal seconds in the format HH:MM:SS.SSS (15:26:18.090). I think Adjust RTC is only used if you have a GPS and want to set/correct the RTC using GPS time in which case the time zone is needed to correct it from UTC to local time. With Adjust RTC unchecked and time zone 0 my time is logged correctly.

mpjf01
Posts: 367
Joined: Thu Jul 26, 2012 3:07 am
Country: -
Location: Adelaide, Australia

Re: Time in log file

Post by mpjf01 » Mon Jan 29, 2018 11:31 pm

I have attached an example of a log file from my X9D+. The time data doesn't seem to be as you describe so I'm wondering what I am doing wrong?
Attachments
Log 25 jan 2018.zip
(177.92 KiB) Downloaded 19 times


jtaylor
Posts: 129
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Time in log file

Post by jtaylor » Tue Jan 30, 2018 12:08 am

The time format looks good to me (see my screen shot of your log). You have many invalid records. Everything after 10:29:39.910 is invalid. Did you change something with telemetry or sensor logging during that session? The log becomes invalid if the number of logged items changes during a log period, which is one day. Everything from a day goes into one log and the items must match the heading created when the file is created or things become invalid. If you are going to change logging during the day you need to go in and rename the log file so a new one is created.
Attachments
logview.PNG

User avatar
Kilrah
Posts: 9518
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Time in log file

Post by Kilrah » Tue Jan 30, 2018 7:32 am

Yup, if you open the file in a text editor you'll find date/time in the first colums is always correct.

Companion 2.2.1 actually pops a warning about invalid lines.

You did indeed change the number of logged items several times.

Post Reply

Return to “openTx for FrSky radios”