OpenXsensor Configurator

Development & General Chat for the superb openxvario project.

Moderator: rainer

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Sun Aug 24, 2014 9:04 pm

KAL wrote:The output offset for bidirectional current sensors has to be set at about half of Vcc.
Can/should this be managed by the configurator or is it sufficient to mention that in the future documentation?
João did answered for the mV and I would add that I had put the directional setting at first but it would complicate things...
To set the offset of a current sensor, either bidirectional or not, just measure (voltmeter) its output when consumption = 0 and put the value in mV in the offset field, just as simple as that.
I'll detail all this in a future wiki.

Good night.

User avatar
KAL
Posts: 540
Joined: Thu Oct 10, 2013 4:36 pm
Country: Germany
Location: somewhere near Rothenburg ob der Tauber

Re: OpenXsensor Configurator

Post by KAL » Sun Aug 24, 2014 9:18 pm

Thanks for explanations.

It's not that problem for me with this parameters :) .
I thought of all the people who are not firm with reading data sheets etc. ;)

Klaus
( TH9X / er9x / M2561 / FrSky DHT / Spektrum / RotEnc / Megasound )
( TH9X / 9XTreme / FrSky DHT / Spektrum / RotEnc )
( 9XR PRO / erSKY9x  / FrSky DHT / Spektrum / RotEnc / P3 as Slider )

User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Sun Aug 24, 2014 9:23 pm

Yes, but if you don't set the offset in mV, what do you think it should be?? That's what I don't understand :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
KAL
Posts: 540
Joined: Thu Oct 10, 2013 4:36 pm
Country: Germany
Location: somewhere near Rothenburg ob der Tauber

Re: OpenXsensor Configurator

Post by KAL » Mon Aug 25, 2014 5:27 am

e.g if the telemetry shows 200mA when there is no current (open circuit) I want to correct this 200mA.

IMHO this is how Joe Average thinks ;)

Klaus
( TH9X / er9x / M2561 / FrSky DHT / Spektrum / RotEnc / Megasound )
( TH9X / 9XTreme / FrSky DHT / Spektrum / RotEnc )
( 9XR PRO / erSKY9x  / FrSky DHT / Spektrum / RotEnc / P3 as Slider )

User avatar
Kilrah
Posts: 9093
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: OpenXsensor Configurator

Post by Kilrah » Mon Aug 25, 2014 7:22 am

The problem with that approach is that with a bidirectional sensor that current might well be beyond what the radio can display.
So flash oxs without offset, turn on, see (big current value), you have to enter that (big current value) in the configurator, reflash, re-power on, note error again, add that error to the one you already have in the configurator, reflash...

Other solution is to have both. You set mv offset as specified in the datasheet, flash, and if there's still an error then you enter that current error in another correction field.


User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Mon Aug 25, 2014 10:12 am

That is a good idea as it would fine tune it better, avoiding us to go back and forwards trying to find the right value. It's like an offset over an offset, right?
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
KAL
Posts: 540
Joined: Thu Oct 10, 2013 4:36 pm
Country: Germany
Location: somewhere near Rothenburg ob der Tauber

Re: OpenXsensor Configurator

Post by KAL » Mon Aug 25, 2014 10:24 am

Seems to be a good idea.
First a coarse setting according to a table in the wiki for the most common sensors (or even data sheets)
and then fine tuning.

Klaus
( TH9X / er9x / M2561 / FrSky DHT / Spektrum / RotEnc / Megasound )
( TH9X / 9XTreme / FrSky DHT / Spektrum / RotEnc )
( 9XR PRO / erSKY9x  / FrSky DHT / Spektrum / RotEnc / P3 as Slider )

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Mon Aug 25, 2014 11:18 am

Hi,
KAL wrote: I thought of all the people who are not firm with reading data sheets etc. ;)
There's absolutely no way to DIY without reading data sheet so...
e.g if the telemetry shows 200mA when there is no current (open circuit) I want to correct this 200mA.
As Kilrah said above, the right way is to know the offset in advance (by measuring) so you don't have to go back and forth flashing OXS, but...
Kilrah wrote:Other solution is to have both.
...that's what I've planned, 2 linked fields, mV and mA offsets.
jhsa wrote: It's like an offset over an offset, right?
Not exactly, it will be the same offset but expressed in different units, it will be less confusing than 2 offsets in different units that add themselves.

Bye.

User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Mon Aug 25, 2014 11:49 am

Good that we all agree then :mrgreen:

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
KAL
Posts: 540
Joined: Thu Oct 10, 2013 4:36 pm
Country: Germany
Location: somewhere near Rothenburg ob der Tauber

Re: OpenXsensor Configurator

Post by KAL » Mon Aug 25, 2014 3:14 pm

grouphug.gif
grouphug.gif (19.05 KiB) Viewed 3073 times
drinkingcheers.gif
drinkingcheers.gif (2.21 KiB) Viewed 3073 times
( TH9X / er9x / M2561 / FrSky DHT / Spektrum / RotEnc / Megasound )
( TH9X / 9XTreme / FrSky DHT / Spektrum / RotEnc )
( 9XR PRO / erSKY9x  / FrSky DHT / Spektrum / RotEnc / P3 as Slider )

User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Mon Aug 25, 2014 3:47 pm

yeah, beer... hhhmmmmm ;) :D
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Mon Aug 25, 2014 4:14 pm

:mrgreen: :mrgreen:

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Tue Aug 26, 2014 10:46 am

Small issue with the gui ...

Could be location or rights on folder OXS_Configurator_v1.0_linux

br KH
Attachments
Bildschirmfoto71.jpeg

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Tue Aug 26, 2014 12:00 pm

Hi,
kalle123 wrote:Small issue with the gui ...
Could be location or rights on folder OXS_Configurator_v1.0_linux
br KH
I need more information to understand what the problem is:
- Did you download OpenXsensor v1.0 ?
- Where did you put openxsensor code ?
- What did you enter in the directory field ?

Bye.

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Tue Aug 26, 2014 12:18 pm

Hi davx.

I reloaded OXS_Configurator_v1.0_linux.tar.gz just 5 min ago again from here https://code.google.com/p/openxsensor/wiki/OXS_Index

Unpacked it to /home/kalle/Anwendungen/OXS_Configurator_v1.0_linux

My arduino ide is also in that folder /home/kalle/Anwendungen

/home/kalle/Anwendungen/arduino-1.0.5

as well as the arduino sketchbook with oxs sketch files

/home/kalle/Anwendungen/sketchbook/openxsensor

Same warning. See directory path in pic attached.

br KH
Attachments
Bildschirmfoto74.jpeg
Bildschirmfoto73.jpeg

User avatar
KAL
Posts: 540
Joined: Thu Oct 10, 2013 4:36 pm
Country: Germany
Location: somewhere near Rothenburg ob der Tauber

Re: OpenXsensor Configurator

Post by KAL » Tue Aug 26, 2014 2:51 pm

Hi Kalle,

this thing puzzeled me a few days ago. Then I realized that the sources of OXS have moved and got an additional file.
Also the main file has changed a bit concerning the #DEFINEs for debugging.

If you load the newest OpenXSensor files from the page where you loaded the Configurator
you will find that there is a new file named "version.oxs".
Copy this to the directory you want write the oxs_config.h to and you will feel fine.

Klaus
( TH9X / er9x / M2561 / FrSky DHT / Spektrum / RotEnc / Megasound )
( TH9X / 9XTreme / FrSky DHT / Spektrum / RotEnc )
( 9XR PRO / erSKY9x  / FrSky DHT / Spektrum / RotEnc / P3 as Slider )

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Tue Aug 26, 2014 3:50 pm

OMG - stupid me!

Thanx Klaus. I am getting to old for this :D

Anything else has changed in OpenXSensor files? I checked myself, oxs_config.h is stamped 18.8.2014

cu KH

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Tue Aug 26, 2014 4:56 pm

I've added some new doc in the wiki: https://code.google.com/p/openxsensor/w ... figuration
The navigation side bar is not working very well for the moment...
kalle123 wrote:I reloaded OXS_Configurator_v1.0_linux.tar.gz just 5 min ago again from here https://code.google.com/p/openxsensor/wiki/OXS_Index
I was talking about OpenxSensor v1.0 downloading, not OXS Configurator, and Klaus did already answer ;)
kalle123 wrote:Anything else has changed in OpenXSensor files? I checked myself, oxs_config.h is stamped 18.8.2014
I've made the download section just for that you don't have to guess, these are the latest OXS and OXS Configurator compatible version: https://code.google.com/p/openxsensor/w ... #Downloads

Bye.

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Sun Aug 31, 2014 7:16 pm

Hi,

New doc on the wiki: Vario settings

And the sidebar should work as expected !

Bye.

Fischi
Posts: 3
Joined: Thu Sep 04, 2014 1:56 pm
Country: -

Re: OpenXsensor Configurator

Post by Fischi » Thu Sep 04, 2014 2:20 pm

Hi!
I tried to set up an oxs as a voltagesensor without the vario features using the configurator.
When triing to compile the sketch, i get the following errors:

"oxs_ms5611.cpp: In member function 'void OXS_MS5611::readSensor()':
oxs_ms5611.cpp:292: error: 'SENSITIVITY_MIN' was not declared in this scope
oxs_ms5611.cpp:292: error: 'VSPEED_MIN' was not declared in this scope
oxs_ms5611.cpp:292: error: 'VSPEED_MAX' was not declared in this scope
oxs_ms5611.cpp:296: error: 'SENSITIVITY_MAX' was not declared in this scope
oxs_ms5611.cpp:308: error: 'VARIOHYSTERESIS' was not declared in this scope"

Did i mess something up in the code, or is it bug in the code?

Stefan

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Fri Sep 05, 2014 6:07 am

I can confirm that. OXS configurator does not like voltage sensor only.

Errors in arduino ide.

br KH

mstrens
Posts: 1066
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: OpenXsensor Configurator

Post by mstrens » Fri Sep 05, 2014 6:17 am

Fischi wrote:Hi!
I tried to set up an oxs as a voltagesensor without the vario features using the configurator.
When triing to compile the sketch, i get the following errors:

"oxs_ms5611.cpp: In member function 'void OXS_MS5611::readSensor()':
oxs_ms5611.cpp:292: error: 'SENSITIVITY_MIN' was not declared in this scope
oxs_ms5611.cpp:292: error: 'VSPEED_MIN' was not declared in this scope
oxs_ms5611.cpp:292: error: 'VSPEED_MAX' was not declared in this scope
oxs_ms5611.cpp:296: error: 'SENSITIVITY_MAX' was not declared in this scope
oxs_ms5611.cpp:308: error: 'VARIOHYSTERESIS' was not declared in this scope"

Did i mess something up in the code, or is it bug in the code?

Stefan
The current version of OXS requests some parameters even if they are not really used.
This will be fixed in a next version.
The configurator omits currently to generate those parameters.
The easier is to add them manually in the generated config.h file.

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Fri Sep 05, 2014 7:09 am

Hi,
Fischi wrote:I tried to set up an oxs as a voltagesensor without the vario features using the configurator.
When triing to compile the sketch, i get the following errors:
Thanks for the report, this error will be corrected quickly ;)
kalle123 wrote:I can confirm that. OXS configurator does not like voltage sensor only.
Please, if you find bugs or problems, you can comment in this thread or you can create an issue there: https://code.google.com/p/openxsensor/issues/list

Bye.

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Fri Sep 05, 2014 12:07 pm

Hi davx.

I am trying to replicate the voltage sensor, which Stefan aka Fischi is using.

Found an new issue in oxs configurator and added that point in the issue list ...

(Had to put a divider factor of 13.99 in, but max. allowed value is 10!

br KH

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Fri Sep 05, 2014 5:13 pm

New OXS Configurator v1.1 to download: https://code.google.com/p/openxsensor/w ... _Downloads
Fischi wrote:I tried to set up an oxs as a voltagesensor without the vario features using the configurator.
When triing to compile the sketch, i get the following errors...
Fixed
kalle123 wrote: Found an new issue in oxs configurator and added that point in the issue list ...
Had to put a divider factor of 13.99 in, but max. allowed value is 10!
The divider factor (in the voltage tab) can now take a maximum value of 99.99, hope it will enough :)

Bye.

User avatar
kalle123
Posts: 684
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: OpenXsensor Configurator

Post by kalle123 » Fri Sep 05, 2014 7:33 pm

davx wrote:New OXS Configurator v1.1 to download: https://code.google.com/p/openxsensor/w ... _Downloads
Fischi wrote:I tried to set up an oxs as a voltagesensor without the vario features using the configurator.
When triing to compile the sketch, i get the following errors...
Fixed
kalle123 wrote: Found an new issue in oxs configurator and added that point in the issue list ...
Had to put a divider factor of 13.99 in, but max. allowed value is 10!
The divider factor (in the voltage tab) can now take a maximum value of 99.99, hope it will enough :)

Bye.
Both issues fixed. Thank you for the good work. 99.99 will do :D

br

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Wed Nov 05, 2014 10:37 pm

Hi,

New wiki: DATA sent

Bye.

User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Wed Nov 05, 2014 10:41 pm

Thank You..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

davx
Posts: 210
Joined: Sun Sep 15, 2013 7:01 am
Country: -

Re: OpenXsensor Configurator

Post by davx » Sun Nov 30, 2014 7:08 pm

Hi,

As you can see in the News there is a new OXS Configurator v2.0 ! ;)

It's now compatible with openXsensor v2.5 ! :)

Bye.

User avatar
jhsa
Posts: 16670
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: OpenXsensor Configurator

Post by jhsa » Sun Nov 30, 2014 7:29 pm

Nice, thank you..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “OpenXVario - an open source vario supported by the open source firmwares!!”

Who is online

Users browsing this forum: No registered users and 8 guests