SKY9x Ver 3.0

ersky9x is a port of er9x for use on the sky9x board.
User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Tue Mar 06, 2018 4:18 pm

From where are you trying to get the download? On www.er9x.com, the download is eePeInstall.exe. This downloads fine on my W10 PC with Kaspersky anti-virus.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Tue Mar 06, 2018 5:13 pm

Yes, er9x.com right click on windows version 422, save as, eepskye.exe or r422eepskye.exe, save, windows defender come up with red and file not saved because of the message I posed already.
On my w7 machine, Avast did the same thing. I was able to turn Avast off and download and install 422, but as I posted originally, it won’t download models and give a error warning and then closes the pgm?

I know, What’s with that?
I believe I have saved eepskye v421 somewhere before it was installed and I’ll maybe try that on my w7 machine to verify it installs and I can download as before.
This is a bother but the fact that 421 is installed already and working on my w10 laptop is good for now. I’m leaving that alone. It’s allowing me to do what I want with my 2 skyboard and I pro tx’s, and I’ll try my 9xtreme also.
I’ll use my w7 as a 422 test computer with anything to try.

Oh, I submitted 422 to Avast and it came back approved. I’m assuming it won’t block it as a download now. It still is a run issue however?
Sorry to cause you concern.




Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Tue Mar 06, 2018 6:21 pm

If you have downloaded eePeInstall.exe (best saved as that), you could just copy that from one PC to another, and then run it to install r422 on the other PC.

On the W7 machine, please try using the Burn menu and try "Read EEPROM memory to file", and see if that works. If it does, try opening the files that gets saved (should be 512K in size).

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Tue Mar 06, 2018 6:29 pm

I’ve used up my play time today mike. Long days with other issues lately.
Don’t fret on this as I will sort it out. It is strange but not critical for me.
I know you’re wondering however and I will give it a try and report back ASAP.



Sent from my iPhone using Tapatalk Pro

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Fri Mar 09, 2018 6:24 am

MikeB wrote:If you have downloaded eePeInstall.exe (best saved as that), you could just copy that from one PC to another, and then run it to install r422 on the other PC.

On the W7 machine, please try using the Burn menu and try "Read EEPROM memory to file", and see if that works. If it does, try opening the files that gets saved (should be 512K in size).

Mike
I have one w7 enterprise computer that’s using free Avast vs.
422 download ok with just a minor warning abut trusting it.
It also installed eepe and eepskye ok. It does work ok and I can download my pro models and fw without issues as should be. Trims center at power on, usb working and connecting displayed on the pro screen.
Copying that same 422 eepskye .exe to a thumb drive and installing it on the w7 pro desktop, give the same error message when I click download models or firmware and the program closes?
I’ve tried it with Avast turned off.
In the morning I’ll try the w10 laptop again with this pgm from my thumb drive.
I haven’t had time, but I’ll try a older eepskye I think I have to see if it runs ok. That may give a clue?
I do have a 421 and a 422 running ok between 2 computers so I’m not held up.


User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Fri Mar 09, 2018 9:38 am

On the W7 desktop, please try:
Run eepskye and create a new file. Save this as a .bin file, close the child window, then try opening the file you saved.

Next on the w7 enterprise computer, read the EEPROM from the 'PRO and save that to a .bin file on your thumb drive. Now try reading that file into eepskye on the w7 desktop.

On the w7 desktop, connect the 'PRO (in bootloader mode), over USB. You should see two hard drives, the SD card and the FIRMWARE/EEPROM. Go to the FIRMWARE/EEPROM drive and try copying the file ERSKY9X.BIN to the computer. If that copies OK, try opening that file in eepskye.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Fri Mar 09, 2018 7:58 pm

MikeB wrote:On the W7 desktop, please try:
Run eepskye and create a new file. Save this as a .bin file, close the child window, then try opening the file you saved.

Next on the w7 enterprise computer, read the EEPROM from the 'PRO and save that to a .bin file on your thumb drive. Now try reading that file into eepskye on the w7 desktop.

On the w7 desktop, connect the 'PRO (in bootloader mode), over USB. You should see two hard drives, the SD card and the FIRMWARE/EEPROM. Go to the FIRMWARE/EEPROM drive and try copying the file ERSKY9X.BIN to the computer. If that copies OK, try opening that file in eepskye.

Mike
Yes to saving and opening a models.bin on the desktop w7 pro also one from the w7 enterprise comp.
I saved a ersky9x.bin file to the sd card and on the desktop w7,
No to saving or loading a fw file created on the w7 desktop
or one from the sd card or w7 enterprise computer.

I have found saved older eepskye exe programs like 419 I saved.

I’m thinking of loading an older version to try.
419 is running ok on my (yes another computer) old atom msi computer also using w7.

I hope I’ve answered your questions? I’m getting confused with what computers will run ok ha ha.






Sent from my iPhone using Tapatalk Pro

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Fri Mar 09, 2018 11:34 pm

I just loaded a eepskye.exe v 420 I found saved. It installed 100% and works great on the w7 (pro) desktop 422 doesn’t.
No crashes or error messages.
More texting but tx battery needs charging now.


User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SKY9x Ver 3.0

Post by jhsa » Sat Mar 10, 2018 12:35 am

I have just tried Eepskye 423 on a w7 pro desktop. Read my Ar9x radio's eeprom without any problem.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 1:26 am

Strange but it’s working on 1 computer running w7 enterprise and not on a w7 pro or w10 home?
I’ve turned the virus scanners off?
Tried right click and administrator mode also.
Funny also is that the two computers with issues both have download warnings and wouldn’t save the eepskye.exe file?
One being a new fresh install of w10 home on a acer quad core laptop.
The only thing common to both the w7 and w10 computer with these issues, is they both have a new solid state hard drive, the other doesn’t that didn’t complain and runs 422 without issues?
Is that possibly a clue?
Trying a new install of the older 420 eepskye loads and runs as your 422 does on your computer?
The sshdd is on a external removable tray and I could insert a working platter hdd easily. It’s the one I cloned to this new sshdd several months ago.

It is strange that both computer fire off a file warning and won’t download 422 in the first place. It’s not the usual warning about the author not being know and asking if it’s ok to download.
This isn’t operator error, it’s something more complicated?

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SKY9x Ver 3.0

Post by jhsa » Sat Mar 10, 2018 2:19 am

Sent you an email.. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 2:34 am

Got it, will do it after dinner.



Sent from my iPhone using Tapatalk Pro

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 3:27 pm

jhsa wrote:Sent you an email..

João
I sent you an email with the results. Same issue.

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 3:30 pm

I edited the path for posting but hopefully it give a clue.
Microsoft (w7) error files generated

Files that help describe the problem:
C:\Users\AppData\Local\Temp\WER4874.tmp.WERInternalMetadata.xml
C:\Users\AppData\Local\Temp\WER5428.tmp.appcompat.txt
C:\Users\AppData\Local\Temp\WER5458.tmp.mdmp



User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 6:06 pm

I just installed a platter 500mb hdd I cloned to a new sshdd in June 2015 in the w7 pro computer. I installed 422 from my thumb drive that works on the w7 enterprise computer.
It acts the same way, Error message when trying to download models or fw and then exits.
420 does work still however.
This hdd hasn’t been updated since 2015 so no new programs or updates have been made that may conflict.
It also eliminates the solid state hdd theory I was thinking about.
The computer mb is a asus p7p55D Deluxe. 8 gig of ram.
Can’t remember the video card in case it’s a conflict there?
It’s pointing to hardware I’m thinking but then again, the w10 laptop is acting the same way?
Were there any changes in the code between 420 and 422 Mike?
I’m still liking fir a 421 to try.
Is it possible to add a few older versions to the Er9x.com site I could try downloading as a test there as well as running them?
Downloading 422 also wasn’t happening on those two computers involved?





Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Sat Mar 10, 2018 6:31 pm

OK, just checking for exact details of what does, or doesn't work.

1. Try running eepskye (422) without the Tx connected, and try to read the EEPROM. You should see a box saying "Tx Disc not Mounted".

2. With the Tx connected, trying to read the EEPROM should open a window that displays:
"Starting
Opened source file
Opened destination file"
then the progress bar at the top should move across as the EEPROM is read.

So, with 1, does that message appear?
With 2, does the window appear, and does it contain any of those messages?

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 6:52 pm

MikeB wrote:OK, just checking for exact details of what does, or doesn't work.

1. Try running eepskye (422) without the Tx connected, and try to read the EEPROM. You should see a box saying "Tx Disc not Mounted".

2. With the Tx connected, trying to read the EEPROM should open a window that displays:
"Starting
Opened source file
Opened destination file"
then the progress bar at the top should move across as the EEPROM is read.

So, with 1, does that message appear?
With 2, does the window appear, and does it contain any of those messages?

Mike
Yes, no tx connected and doing a read of memory from tx that I’m assuming is the eeprom, I see tx disk not mounted.
Trying it with the tx connected, display showing “connecting..” and 2 drives showing up, I get
“Eepskye has stoped working” windows is collecting more info on the problem.
Then a second box asking if I want to send it to Microsoft.
I posted the info it collected earlier.

Image


I’m actually running eepskye 423 that Joao sent me but it’s the same for 422

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 7:05 pm

I just uninstalled and delegated all eepe folders and did a fresh download from er9x.com of eepskye.exe 422. It did complain about not being a verified publisher but did download on the w7 pro computer ok. A fresh install however has the same issues when trying to read the models (eeprom).
No registry items were deleted.

Has there been any changes in the code since 420 Mike? And chance you could put a few older versions back up I could do a test download and install from the site? It would help with the w10 “defender” keeping me from downloading 422 issue also.

User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Sat Mar 10, 2018 7:28 pm

I'll look into building a special version of eepskye that reports what it is doing, to try to pin down where it is getting "stuck".

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sat Mar 10, 2018 7:58 pm

Yes, I too would like to know what’s going on. For now I’m good to go with what does work and it can wait until you have time. I had hoped several others would have joined us to see if anyone else has seen this. Joao doesn’t have it happening.
Can it be a video card issue? In the past I had programs crash and it required a video drive update.
The w10 422 download blocking and eeprom save error message did surprise me being it has been hardly used and I just added the sshdd and w10. I had an older eepskye on it from a month or two ago that works ok. 419 or 420 I think.
Ok, when you get time Mike.
Sorry for always finding things needing solutions.

User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Sat Mar 10, 2018 10:41 pm

I can see a possible problem. When I scan for the Tx discs, I'm only storing the first 8 drives, and don't have a catch to prevent running past the array size.
A test you can do is to try to read the EEPROM WITHOUT the Tx connected, getting the "not mounted" message, then look at the Burn|Review output menu option. This will display all the drives (volumes) found. If more than 6 names appear, then there will likely be a problem when the Tx is connected.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

SKY9x Ver 3.0

Post by ShowMaster » Sun Mar 11, 2018 12:29 am

BINGO Mike!
The desktop as being used had 6 drives showing up before plugging in the tx, then another 2!
I have 3 internal drives, 1 external usb 1tb, as well as a usb hub with thumb drives in it. One thumb drive was the one I’m using to import files from the w7 enterprise computer.
That computer has only 2 internal drives and a usb hub that usually has only one thumb drive.

So maybe add a note in the startup about the max drives/thumb drives allowed? My situation may be out of the norm box for computer owners. Not as many large hdd when I built up this one.
What was the max allowed in v420?

Next I’ll focus on the newly updated to w10 5 yr old, but hardly used acer quad core laptop.
It only has one drive, a new sshdd but windows defender blocked me downloading v422 and I think crashed like the desktop? Too much going on so I’ll revisit it.
Fun stuff ha ha.

I’m sure this max drive limit is good news for us and Joao that’s been trying to help.


User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

SKY9x Ver 3.0

Post by ShowMaster » Sun Mar 11, 2018 1:48 am

Wow, I have 422 working on my w10 laptop and all my computers now with only one remaining issue to overcome.

I tried another download from er9x.com 422 install and as before, “windows screen defender” blocked the download. I don’t know how to go around it so I submitted the exe file to be approved.

I then used the same 422 on the thumb drive I downloaded with the w7 enterprise computer.
That installed eepe and ersky9x ok and I get no crashes when I read my 9xr pro. I’m assuming it’ll be ok for the sky boards also.
With all the things going on, the w10 issue was/is a eepskye.exe download issue, not a running one.
So all that’s left is to find a way to go around w10 windows screen defender to download 422 and it’s solved. Maybe the submitted file will be approved and passed on soon?
Turning it off is my next task.
However, if that’s required for future download versions, how to turn it off may be a required tip.
Like I said before Mike, sorry for always finding things to complicate simple tasks.
I guess I’m an unofficial beta tester.



Sent from my iPhone using Tapatalk Pro

User avatar
MikeB
9x Developer
Posts: 15562
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: SKY9x Ver 3.0

Post by MikeB » Sun Mar 11, 2018 11:35 am

I just need to remove the code! I think it was only put in when I was using eepskye with an openTx bootloader on the radio and needed to find out what name was being returned by the radio. It is ony used to report the names read!

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sun Mar 11, 2018 2:35 pm

Let me know when you do and I’ll try it.
Today as time permits, I’ll see about a work around for windows10 defender blocking a 422 download. There must be a way I can list file in a permissions window to allow custom files to not be blocked?
I read about a setting that warns you and I’m used to that, but after it warns you, it block it anyway.
I like the idea of blocking unknown files, but not without options.
Glad the w7 issue worked out with a simple answer of to many hdd’s.

User avatar
Kilrah
Posts: 9495
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: SKY9x Ver 3.0

Post by Kilrah » Sun Mar 11, 2018 5:03 pm

On the left of the button is a "link" (more details or something), click that and that shows you the option to allow anyway.

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Sun Mar 11, 2018 5:51 pm

Thanks Kilrah.
I’ll check out your suggestion.
I actually just solved it. Basically what you’ve suggested. When it blocks it it gives me the option of seeing the downloads. Going there I see in all red text that the file wasn’t downloaded. Right clicking on the red text gives me the option of downloading it anyway and I did.
I’ve barely used this laptop and w10 since the upgrade. It’s not a touchscreen laptop and still challenging to use with the touchpad. So much different than w7.
I’ll be using it more however for hobby and RC field projects so this was a good learning exorcise.

For the moment all issues have been solved and I can get back to updating my sky and pro tx’s that started all this.
Thanks to Mike, Joao, and now you Kilrah for your help.

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SKY9x Ver 3.0

Post by jhsa » Sun Mar 11, 2018 8:28 pm

Nice that is working.. :) Well done ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
ShowMaster
Posts: 4313
Joined: Thu Dec 29, 2011 3:44 am
Country: -
Location: Los Angeles, CA USA

Re: SKY9x Ver 3.0

Post by ShowMaster » Mon Mar 12, 2018 6:34 pm

New audio and sd card for v221fw?
I downloaded the new audio zip file on er9x.com and after extracting the files I get a voice folder and in it a system and a user folder. How should these be saved on a fat32 sd card to play the hello message and other?
Thanks

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: SKY9x Ver 3.0

Post by jhsa » Tue Mar 13, 2018 11:01 am

Just rename your current voice folder if you have one on the card, and then extract the voice folder from the zip you've downloaded to the root directory of the card. That's it.
The voice folder should have 3 folders inside. "system, user, and modelNames"
Leave system alone, do not change anything in it.
User is where you put your own voice files.
ModelNames is self explanatory :)

By the way, this is not new in 221. It was already there in 220. You might have had an extremely old version of Ersky9x installed on your radio ;) :) At least 2 years old? ;)

Time to check the new goodies in Ersky9x. :mrgreen:

João

Sent from my BLN-L21 using Tapatalk


My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “ersky9x”