sky9x rev. B1 power issue

Support & Help for the sky9x upgrade board
User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 5:01 pm

Hi,

i'm taking back my modified T9X radio after 2 years of break and it doesn't power on very well.

The 2S LiPo is good (fully charged, 8.4V measured at output), i can hear the beep from the FrSky module, but the radio does not power on.
I have to switch it off and on again, then it powers up.

See it on video :
https://www.youtube.com/watch?v=HtRQxxunySU

When powered up, the radio is working well.

Is there any capacitor that i could change to see if it solve the problem ? (I'm OK with soldering)

(The T9x is modified with a sky9x rev. B1 board + Optrex LCD + Aurora gimbals)
Attachments
IMG_1915.jpg
Last edited by capitaineflam25 on Wed Nov 08, 2017 7:24 pm, edited 1 time in total.

User avatar
jhsa
Posts: 17812
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: sky9x rev. B1 power issue

Post by jhsa » Wed Nov 08, 2017 6:09 pm

What firmware do you have installed? I don't recognize that screen, and the splash screen looks all wrong as well. It looks like a firmware issue. It seems that the LCD or the backlight flashed just before you turned it off. That means the processor is probably powered..
I suggest you install the latest Ersky9x firmware.. you find it at www.er9x.com
Then see if the problem is still there..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
bob195558
Posts: 1852
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Sky9x Board Rev. B1, power up issue

Post by bob195558 » Wed Nov 08, 2017 6:12 pm

Hi capitaineflam25,
I have a suggestion that may be a cause.
Do you have the on-board CR2032 Lithium Battery and what is its voltage (3.3v) ?
Low Battery Sky9x Radio rev. B1.jpg
Low Battery Sky9x Radio rev. B1 board
Some Sky9x board info: (http://openrcforums.com/wiki/index.php/ ... rd_Upgrade).

-------------------------------------------------------------------------
I have one of the last Sky9x Rev 3.0 Mainboards which has a on-board 3.3v battery.
Sky9x rev3 Board_a.jpg
last Sky9x rev 3.0 board with on-board 3.3v battery
Bob B.
Last edited by bob195558 on Wed Nov 08, 2017 9:41 pm, edited 1 time in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 6:22 pm

Hi Joao,

thanks for your answer.

it's OpenTX 2.2 for sky9x boards.
The screen you see is the checklist display page.

Previously it was flashed with a late 2012 version of ersky9x, but the problem was already there.
2 years ago, before i make a break in the hobby, i never faced this issue, that's why i was guessing it was a component aging issue.

So i flashed the radio with this recent OpenTx to see if it changes something at startup but unfortunately no.
Once i get it powered on, and sometimes it can take several times, i don't face any issue with the radio and the firmware.

Regards

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 6:27 pm

Thanks for the hint bob195558 that could make sense.

i don't think i have a the RTC module on it. Was it an option with the sky9x rev. B1 ?


User avatar
bob195558
Posts: 1852
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Sky9x Board Rev. B1, power up issue

Post by bob195558 » Wed Nov 08, 2017 6:36 pm

I believe RTC module is an option for the B1, though it would be mounted externally from the mainboard.
Sky9x board BatteryBackup RTC .jpg
Sky9x board Battery Backup RTC
Sky9x board Battery Backup RTC _b.jpg
Sky9x board RTC Battery Backup
Click on photo to zoom in.
See here for more info: (http://openrcforums.com/wiki/index.php/ ... rd_Upgrade).
I also use erSky9x firmware on all my radios and like it a lot, which may fix your problem like João suggest.
Find here ersky9x and the newest PC eeprom editor "eePSkye": (http://www.er9x.com/).

Bob B.
Last edited by bob195558 on Wed Nov 08, 2017 9:40 pm, edited 1 time in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Wed Nov 08, 2017 7:08 pm

Does it power on reliably if you start in "bootloader" mode (both horizontal trims held inwards at power on)?

The SKY board (all variants) includes a co-processor that provides the RTC function, and some I/O expansion.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 7:39 pm

Yes same behaviour:
i press the 2 trims inwards then switch on the power, i hear the module beep, but the LCD remains blank.

I switch it off (keeping my 2 fingers on the trims) then switch it on, then the bootloader (v1.9) screen shows.

What is the normal behaviour when connected to my computer USB ?
Actually i have this :
- i plug the radio with USB, the screen lights up but remains blank
- i switch on the radio, the module beeps immediately. After some seconds (about 10) the bootloader shows up in "Connect mode"
- then everything is functionnal (SD Card drive mount and Sam-Ba transfer)

This 10 second delay is normal ? it's not a problem at all, i was just wondering if it could be linked to my issue.

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 8:26 pm

Here is the video with ersky9x, the part i slide the power switch for the first time is missing.

By the way it says that i need to update the co-processor, i'm looking forward to dot it.

https://youtu.be/xnf4rSmH60s

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Wed Nov 08, 2017 10:08 pm

Bootloader and co-processor updated (No incidence on the issue)

User avatar
bob195558
Posts: 1852
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: sky9x rev. B1 power issue

Post by bob195558 » Wed Nov 08, 2017 11:13 pm

So updating Bootloader and co-processor fixed the symptoms ! :)
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Thu Nov 09, 2017 5:01 am

bob195558 wrote:
Wed Nov 08, 2017 11:13 pm
So updating Bootloader and co-processor fixed the symptoms ! :)
Unfortunately no, the issue remains. It may confirm that this is a hardware problem ?

User avatar
jhsa
Posts: 17812
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: sky9x rev. B1 power issue

Post by jhsa » Thu Nov 09, 2017 10:20 am

It confirms that it is a weird problem :D
That black splash screen when you turn the radio on is not normal, right?

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Thu Nov 09, 2017 10:53 am

jhsa wrote:
Thu Nov 09, 2017 10:20 am
That black splash screen when you turn the radio on is not normal, right?
This strange screen is an OpenTX issue with sky9x board as far as i remember, ersky9x does not have this issue (2nd video)

My radio is still useable once i managed to power it up, i hope the problem won't get worst and lead to a powerdown while flying :lol:

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Thu Nov 09, 2017 11:47 am

The 10 second delay with the bootloader is not normal.
What happens if you power the radio on, then wait at least 10 seconds, does it then start.
Also please try:
1. Plug in the USB to the PC.
2. Power on holding the TRN switch ON.
The display should show "USB" (maybe with bad contrast), and the SAM-BA bootloader should appear on the PC within a second or so.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Thu Nov 09, 2017 1:26 pm

MikeB wrote:
Thu Nov 09, 2017 11:47 am
What happens if you power the radio on, then wait at least 10 seconds, does it then start.
No, i can leave the radio like that for minutes, it won't power on, until i switch it off/on again.

The 2nd test is OK : i get the "USB" screen, the SD Card is not mounted and the COM port is accessible

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Thu Nov 09, 2017 2:30 pm

Please try, if you haven't already done so, powering on without the SD card in.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Thu Nov 09, 2017 2:49 pm

MikeB wrote:
Thu Nov 09, 2017 2:30 pm
Please try, if you haven't already done so, powering on without the SD card in.
Good idea, i didn't tried that. Unfortunately the result is the same. :?

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Thu Nov 09, 2017 5:01 pm

If that "USB" test with the TRN switch power up and responds to the PC quickly, where everything else either takes 10 seconds (bootloader) or needs a power off and on, then it narrows down areas to look at.
I'll see if I can build a special version of ersky9x that might help locate what is happening, just need a bit of time to sort it out.

Mike.
Edit: Also, please describe exactly what happens when start in bootloader mode (trims in) while waiting for the 10 seconds.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Thu Nov 09, 2017 6:38 pm

I've posted a special test version of ersky9x for you (here: viewtopic.php?f=7&t=4676&p=65894#p65894). (File to flash is ersky9xs_rom.bin, the 's' is for small so it fits on the SKY board processor!).

As soon as the main code runs (if it gets that far) it turns the backlight on full, initialises the lcd, then keeps writing a character at the top left of the display to show where the code as reached.
This may not work at all of course, if the problem is occuring before this code gets to run, but if it does run, the character displayed may help see what is happening if it stops updating.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Fri Nov 10, 2017 8:41 am

Thanks a lot.
After many tests and considering your remarks here is the situation.

I can observe 3 differents situations at startup, they all happens with differents firmwares (old erksy9x, latest ersky9x, boot-test ersky9x, latest OpenTx)

1. The module beeps but the radio never power On, even after waiting 1 minute or more. I may say that this situation happens the most when the radio has been powered off after many minutes.
2. The module beeps, the radio powers on after at least 10 seconds (You can see that on the following video with your test firmware) But this is the most rare situation, i managed to reproduce it a few time only. It may not be very clear on the video but i only push on once the power switch at the beginning of the video.
3. The radio powers on "normally"

Once the radio has powered on normally, it is more likely that it will power normaly the next time if i don't wait too much. That's why i was thinking about a capacitor issue on the power circuit (if they are any ?)

Once plugged to the USB, after powering On, i always have to wait 10 seconds or more before the bootloader shows. But in this situation, it always shows.

https://youtu.be/QjZQBKuZZkU

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Fri Nov 10, 2017 10:58 am

The interesting thing on that video is it stops with '8' displayed, then the screen goes blank. It should carry on to show '9'.
I'll do another test version to see if I can pin where this happens more accurately.
My current idea is there is a problem with the PLL. There is a 12 Mhz crystal, then there is an internal PLL that generates the main 64 MHz clock from that. It is possible the 10 second wait happens waiting for the PLL to stabilise. I'll see if a test version I do can also detect that, but may take just a little longer.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Fri Nov 10, 2017 4:40 pm

OK, I've posted a new test version for you. All I can easily do is to flash the backlight early on in the code as the 'C' environment isn't set up.
So, as the main code starts, it turns the backlight on, then flashes it off and on. As the code proceeds, it repeats flashing the backlight off and on. When the clock changes from 12 MHz to 64MHz, the flashes become faster.

See if you get any backlight response. If you do, please count how many time the backlight flashes off.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Fri Nov 10, 2017 5:26 pm

Thanks a lot, here it is :

I will say 5 flash ? (depending if you count the first one when switching on)

https://www.youtube.com/watch?v=eL_B6pNb9PY&feature=share

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Fri Nov 10, 2017 5:33 pm

I'm not sure why you get the Bad EEPROM data screen, but other than that, the radio started correctly.
Does this happen every time?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Sat Nov 11, 2017 9:49 am

MikeB wrote:
Fri Nov 10, 2017 5:33 pm
I'm not sure why you get the Bad EEPROM data screen, but other than that, the radio started correctly.
This is "normal", i previously flashed it with OpenTX before this test.

If you're unsure about the oscillator, maybe i can replace it if it is cheap, i don't take a huge risk i guess ?

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Sat Nov 11, 2017 10:57 am

The PLL is in the processor itself!

In your video, the radio did start OK, with the backlight flashes, getting to the Bad EEPROM screen. Does it start like this every time with the backlight flashing?
If you clear the Bad EEPROM, does the radio then continue with starting every time?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Sun Nov 12, 2017 12:22 pm

OK thanks.
On the video it starts OK but the issue still occurs, in this situation we don't see the screen flashing, it remains off.

After a few flying session, i realise that i lost the audio on the radio after a few minutes (i've tested with different firmwares, differents SD cards)
Maybe it's the end of my radio, i may look forward to buy a Taranis X7 as a replacement :(

User avatar
MikeB
9x Developer
Posts: 15613
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: sky9x rev. B1 power issue

Post by MikeB » Sun Nov 12, 2017 7:24 pm

Please repeat the test described here: viewtopic.php?f=67&t=10624&p=133366#p133295.
Does this start OK every time, with the PC detecting the radio within a second or so?

You updated the bootloader. What revision does the bootloader report (when it runs!).

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
capitaineflam25
Posts: 107
Joined: Wed Jan 11, 2012 7:54 pm
Country: -
Location: Vence, France

Re: sky9x rev. B1 power issue

Post by capitaineflam25 » Mon Nov 13, 2017 2:17 pm

The bootloader is 2.1

When connecting to the PC through USB, the scenario is stable : the radio screen always shows the bootloader with "Connecting" after about 10 secs. (There is no "random" behaviour like there is when the radio is powered by the 2S LiPo)

Thanks a lot for your help, but the audio issue i'm facing is now blocking for me, i think i will recycle this beloved remote to "slave" remote for my son who i'm learning to fly.

Post Reply

Return to “sky9x upgrade board”