Audio (voice) - Stock 9X PCB

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
NvdGoorbergh
Posts: 29
Joined: Fri Dec 04, 2015 3:03 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by NvdGoorbergh » Mon Dec 07, 2015 12:34 pm

Wow!
Would love to hear my turnigy 9x talk.
Is it still possible to do? due to the fact that the sdcard changed etc.
Im not sure where to start. :shock: Haha.
Do I need the telemetry mod for this? Or is the frsky dht good enough to have?

User avatar
bob195558
Posts: 1836
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Audio (voice) - Stock 9X PCB

Post by bob195558 » Mon Dec 07, 2015 1:21 pm

See here for this option: (viewtopic.php?f=95&t=7182).
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

andrewju
Posts: 713
Joined: Tue Aug 21, 2012 7:29 am
Country: Russian Federation
Location: Moscow

Re: Audio (voice) - Stock 9X PCB

Post by andrewju » Wed Dec 30, 2015 9:16 pm

I have one Serial Voice module behaving strangely. The module was built following my 'PowerSound' schematic by another guy. But he never managed to get it to work, so he brought it to me...

The module almost works:
- The serial communication works, as the left vertical trim (connected to the voice module) works fine.
- The amplifier circuit and the speaker are also Ok, as beeps are working fine, too.
- But voice files are not played at all. I.e. there's no "welcome to er9x" message, and model name is not played back, too.

When I am in 'General' model settings screen, I select a file number to be played as the model name and press 'Menu'. Then the highlight of the number starts to flash, but there is no sound... Strange thing is that it is flashing for an indefinite amount of time. As far as I recall, the flashing should stop as soon as the file playback is completed (but I may be wrong about this one).

The guy used my PCB, so that's tested and proven to be working. I also checked the elements he used - chips and resistors are the same as I normally use. The capacitors have no marking, so these are a bit more difficult to check. I also replaced the SD-card socket to the one I know to work fine - just to be sure. And I tried multiple SD-cards (including the one proven to work in other modules). Still no luck...
The Atmega is flashed with the 'combined' MegaSound Serial firmware (I reflashed it myself, to be sure) - also tested on my other modules and known to be working fine.

I'm running out of ideas... What can be causing such a behavior?

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Audio (voice) - Stock 9X PCB

Post by MikeB » Wed Dec 30, 2015 9:48 pm

Does 'backup/restore" work? This would test the SD card.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Dec 30, 2015 9:56 pm

Is "Megasound" selected as sound source in the AudioHaptic menu?
Can you backup and restore models to/from the SD Card?


João

EDIT: oops Mike was faster :)
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


andrewju
Posts: 713
Joined: Tue Aug 21, 2012 7:29 am
Country: Russian Federation
Location: Moscow

Re: Audio (voice) - Stock 9X PCB

Post by andrewju » Wed Dec 30, 2015 10:08 pm

I'm using this module on an m64 radio that previously worked with my own PowerSound board. No changes to the radio since then - so the radio side is fine.

Just tested: Backup & Restore do not work. Backup operation just stays at the 'BACKUP' progress bar (until I cancel it by pressing 'Exit').

I'm quite sure this has nothing to do with the SD-card itself, as I tried all SD-cards I have, including the one that was working fine in other modules (4Gb SanDisk formatted in FAT32).

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Audio (voice) - Stock 9X PCB

Post by MikeB » Wed Dec 30, 2015 10:17 pm

Serial FROM the sound board TO the M64 is working, as the trims work, but this doesn't prove serial TO the sound board FROM the M64 is working. I'd investigate that.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Dec 30, 2015 10:21 pm

Check if there isn't a diode soldered inverted on the powersound RX line..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

andrewju
Posts: 713
Joined: Tue Aug 21, 2012 7:29 am
Country: Russian Federation
Location: Moscow

Re: Audio (voice) - Stock 9X PCB

Post by andrewju » Thu Dec 31, 2015 12:52 pm

I rechecked that line - the diode is there and polarity is fine. Heck, I still replaced the diode with the one I normally use. Still no luck...
There are no other components involved, and I checked all the tracks and connections with a multimeter...

I guess the Atmega on the sound module is the likely cause of this issue. Does this look like it?

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Thu Dec 31, 2015 1:21 pm

how did you connect the serial to the atmega in the radio? did you remove the resistors on pins 27 and 28? if you didn't, maybe try to remove the capacitors on those pins..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

andrewju
Posts: 713
Joined: Tue Aug 21, 2012 7:29 am
Country: Russian Federation
Location: Moscow

Re: Audio (voice) - Stock 9X PCB

Post by andrewju » Thu Dec 31, 2015 1:35 pm

Resistors are still there on the mainboard. The thing is that this 9x mainboard "as is" worked fine with all other PowerSound modules that I built.

It's only this specific PowerSound that is having problems... :-(
I think I'll go ahead and swap the Atmega. Probably next year already... :)

Happy New Year!!!

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Thu Dec 31, 2015 1:51 pm

If all the rest is really ok, that could indeed be the problem..
Looking forward to read the results next year then ;)
Happy New Year..
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Audio (voice) - Stock 9X PCB

Post by MikeB » Thu Dec 31, 2015 5:07 pm

If you compile the firmware for the voice board, with the #define TESTING uncommented, then the board should play file 0040.wav repeatedly. There is also data sent out over the serial and it should respond to a character from 0 to 9 sent in over serial.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

andrewju
Posts: 713
Joined: Tue Aug 21, 2012 7:29 am
Country: Russian Federation
Location: Moscow

Re: Audio (voice) - Stock 9X PCB

Post by andrewju » Fri Jan 01, 2016 7:44 pm

I just swapped the Atmega, and the sound worked!
So the serial 'RX' line was somehow faulty in the old chip. :-(
Good to have it all working!

Thanks a lot for your help!!!

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Fri Jan 01, 2016 9:06 pm

Great ;) :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Mon Jun 05, 2017 8:35 pm

Hi,

http://openrcforums.com/wiki/index.php/9xVoice_Mod
Site links are down. Any news?

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Mon Jun 05, 2017 9:35 pm

Everything seems to work here.. :)
Just checked
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

modrzej
Posts: 3
Joined: Sat Jul 25, 2015 1:35 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by modrzej » Sun Jun 11, 2017 1:56 pm

mhotar wrote:
Wed Dec 24, 2014 1:29 pm
Hello All,
here are my source files. I used kicad software to design this board layout. It is opensource, so you can use it to open the project and change it or export. Firmware version in the archive had bootloader problems (sometimes did not run the main app at startup), so I did not used bootloader at all. I think Mike fixed this in later versions already, but I never used serial connection as there is AVR_ISP header on the board and the SD is easily accessible.
AudiomegaV2MH_kicad.zip
Hello
Two years ago I bought all the elements needed to build a layout.
Unfortunately, somehow the topic of construction died. Finally, I took this project (in the meantime it was a serial, but hardly).
In the end I managed to put everything together and run.
Unfortunately, when I start the transmitter, I only have backlight and sound. No picture.
What could be wrong?
Sometimes it is possible to turn on the transmitter so that it will show the image.

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Sun Jun 11, 2017 8:45 pm

What transmitter? it looks like you might be loading the LCD lines somehow, and preventing the LCD from working.
What circuit did you build? link please?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

AlexLmm
Posts: 34
Joined: Mon Oct 03, 2016 11:28 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by AlexLmm » Sat Sep 09, 2017 2:19 pm

Can we use some of these modules directly controlled from main CPU? And why?

https://www.banggood.com/DFPlayer-Mini- ... 69191.html
https://www.banggood.com/Voice-Playback ... otproducts

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Tue Oct 17, 2017 2:14 am

AlexLmm wrote:
Sat Sep 09, 2017 2:19 pm
Can we use some of these modules directly controlled from main CPU? And why?

https://www.banggood.com/DFPlayer-Mini- ... 69191.html
https://www.banggood.com/Voice-Playback ... otproducts
Only
http://www.ebay.com/itm/MP3-Sound-Modul ... 0535073165

and

http://openrcforums.com/wiki/index.php/ ... Voice)_Mod

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Wed Oct 25, 2017 2:43 am

Hi1

I have two bugs.
1- My transmitter says "one minutes" and not "one minute".
2-I have 3, 4gb SDcard, two work perfectly (older).
Today I bought a 4GB SD Card, I formatted it in FAT32. The transmitter does not say the welcome message and the model name after power on, but I can hear the countdown, in "voice alarm" I can hear all the audio files. I can save and restore the models on the SD card

Have you been through this?

I use 9xvoice(adapted mike version 16MHZ, 5V atmega328p), arduvoice firmware SERIAL SDcard module.
ER9X 820 for 2561,MOD: FRSKY 2561

Tks!!!
Marco.

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Oct 25, 2017 8:33 am

Strange problems.
I didn't mess with my er9x radio for a while but I think the cards should be as small as possible. That would explain why the smaller cards work.
But it is still strange that all other voices work..

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Wed Oct 25, 2017 11:59 am

jhsa wrote:
Wed Oct 25, 2017 8:33 am
Strange problems.
I didn't mess with my er9x radio for a while but I think the cards should be as small as possible. That would explain why the smaller cards work.
But it is still strange that all other voices work..

João

Sent from my BLN-L21 using Tapatalk
Hi,
The sounds when you turn on the transmitter are not heard, but it seems to work fine once it's turned on. I think the SD card should be fake.
See this video. BUG

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Oct 25, 2017 12:27 pm

Try formatting the SD Card using this program.. it is free,

https://www.sdcard.org/downloads/formatter_4/

Do not use windows to format your cards.. it is rubbish. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Wed Oct 25, 2017 1:21 pm

jhsa wrote:
Wed Oct 25, 2017 12:27 pm
Try formatting the SD Card using this program.. it is free,

https://www.sdcard.org/downloads/formatter_4/

Do not use windows to format your cards.. it is rubbish. :)

João
I already used version 5 of this program, and nothing worked. I used Windows. :?

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Oct 25, 2017 1:33 pm

Well, it looks like it is the card.. what happens if you format in FAT only? not FAT32?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kmargos
Posts: 76
Joined: Mon Jun 05, 2017 7:54 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by kmargos » Wed Oct 25, 2017 2:28 pm

I'll try Diskpart and EaseUS ...

I have the source code and I can compile .... can I change a parameter?

ReSt
Posts: 1451
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Audio (voice) - Stock 9X PCB

Post by ReSt » Wed Oct 25, 2017 2:32 pm

I once had a similar problem, but with openTx, that the welcome message some times was played and sometimes not.
This was due to the initialisation of the sound module needed more time to get ready before it was able to play the message.
I had to increase the initialisation delay in the code so that the welcome message was played a little bit later - and that worked.

Reinhard

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Audio (voice) - Stock 9X PCB

Post by jhsa » Wed Oct 25, 2017 2:38 pm

Reinhard, the difference is that he has some cards that work. Only that one doesn't..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “er9x”