Zero Alt doesn't work

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
Post Reply
AlexLmm
Posts: 34
Joined: Mon Oct 03, 2016 11:28 pm
Country: -

Zero Alt doesn't work

Post by AlexLmm » Mon Sep 04, 2017 9:37 pm

Hi,
I have er9x-pr820 frsky 128 V1.647

When I get 3D fix I see Galt at the screen become 29.0, then I press Zero Alt from pop up menu but Galt keeps the same value as before.
How can this be fixed?

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Zero Alt doesn't work

Post by MikeB » Mon Sep 04, 2017 10:10 pm

At present, assuming you wish to use the GPS alt. rather than the barometric alt., go to the telemetry menu and set GpsAltMain to on (ticked). This uses the GPS alt. value as the Alt value. The "Zero Alt" option should then zero the displayed Alt value.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

AlexLmm
Posts: 34
Joined: Mon Oct 03, 2016 11:28 pm
Country: -

Re: Zero Alt doesn't work

Post by AlexLmm » Mon Sep 04, 2017 10:22 pm

Hi Mike! Yes, it was always ticked. Can be some other reason?

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Zero Alt doesn't work

Post by MikeB » Tue Sep 05, 2017 9:05 am

The Galt value won't appear as zero, but the "ordinary" Alt value should.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

AlexLmm
Posts: 34
Joined: Mon Oct 03, 2016 11:28 pm
Country: -

Re: Zero Alt doesn't work

Post by AlexLmm » Tue Sep 05, 2017 10:27 am

When I changed GAlt to Alt at the telemetry screen it show 0 from the beginning. GpsAltMain ticked. Is that correct behavior? I can't fly the drone right now to check alt change.


User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Zero Alt doesn't work

Post by MikeB » Tue Sep 05, 2017 1:59 pm

It sounds correct. The code "auto-zeroes" when it first receives an Alt value.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

AlexLmm
Posts: 34
Joined: Mon Oct 03, 2016 11:28 pm
Country: -

Re: Zero Alt doesn't work

Post by AlexLmm » Tue Sep 05, 2017 2:54 pm

Thank you Mike as always. Sorry for wasting your time, but I couldn't figure it all out from the manual, and it was so simple. I wish the manual would be more detailed, but it requires some more community efforts to do that.

Post Reply

Return to “er9x”