TGY 9X + XJT + X4R-SB + SmartPort

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
Post Reply
m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Sun Sep 03, 2017 10:27 am

Hi all,

I'm a new user and this is my first post because I've a problem, maybe is just an already answered question, and I'm sorry for open a new topic, so you can address me to the solution.

My setup is this:
TGY 9X stock board M64
THR e AIL mod done (2 res 220k to pin 41 and 42)
Telemetry mod done (? pin5 to inverter made with B337 and 2 resistors to MOSI)
XJT module
X4R-SB rx (smartport telemetry mod no inversion)
FC Omnibus F4 (uart6 set to smartport)
ER9X v.1.743-Mike r820 FRSKY NT

whit all this setup I can get SWR and RSSI (also send back to OSD via SC1)
I can't read A1 and A2 (set to 13.2v) -maybe these are analog telemetry and I've not connected port AIN on X4R-SB?- but this is not a problem because I want to get telemetry from SmartPort and get things like Cvolt Ctot and so on...

The question is this: is this setup (with smartport) supposed to work?

Thanks again.

User avatar
jhsa
Posts: 17722
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by jhsa » Sun Sep 03, 2017 11:16 am

m3rcur10 wrote:
Sun Sep 03, 2017 10:27 am

My setup is this:
TGY 9X stock board M64
THR e AIL mod done (2 res 220k to pin 41 and 42)
Do you mean 220 Ohm, not 220 Kilo Ohm, right?

Telemetry mod done (? pin5 to inverter made with B337 and 2 resistors to MOSI)
Not sure about this. Where did you see this mod?

whit all this setup I can get SWR and RSSI (also send back to OSD via SC1)
If you get RSSI, then you have telemetry working..
I can't read A1 and A2 (set to 13.2v) -maybe these are analog telemetry and I've not connected port AIN on X4R-SB?
Those are analog ports.. You need some sensors (voltage dividers) connected there.. DO NOT CONNECT THE BATTERY DIRECTLY THERE..
but this is not a problem because I want to get telemetry from SmartPort and get things like Cvolt Ctot and so on...
You need a smartport sensor then
The question is this: is this setup (with smartport) supposed to work?
If you are getting telemetry, then it should work..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Sun Sep 03, 2017 5:08 pm

jhsa wrote:
Sun Sep 03, 2017 11:16 am
You need a smartport sensor then
FC Omnibus F4 (uart6 set to smartport)

User avatar
bob195558
Posts: 1836
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by bob195558 » Sun Sep 03, 2017 7:26 pm

m3rcur10 wrote:
Sun Sep 03, 2017 5:08 pm
jhsa wrote:
Sun Sep 03, 2017 11:16 am
You need a smartport sensor then
FC Omnibus F4 (uart6 set to smartport)
X-Series Smart Port Sensors
FrSky SP-FLVS - Smart Port Lipo Voltage Sensor: (https://alofthobbies.com/radio/sensors/ ... nsors.html).
See manual under download here: (https://www.frsky-rc.com/product/flvss/).
Last edited by bob195558 on Sun Sep 03, 2017 7:35 pm, edited 1 time in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Sun Sep 03, 2017 7:35 pm

bob195558 wrote:
Sun Sep 03, 2017 7:26 pm
FrSky SP-FLVS - Smart Port Lipo Voltage Sensor: (https://alofthobbies.com/radio/sensors/ ... nsors.html).
See manual under download here: (https://www.frsky-rc.com/product/flvss/).
https://github.com/cleanflight/cleanfli ... lemetry.md


User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by MikeB » Sun Sep 03, 2017 8:07 pm

The SPort signal is inverted serial data. Does the FC send inverted data?
Your FrSky setup should work. Since you are seeing RSSI and SWR, the Tx end is fine and all working. If you are not seeing SPort data from the FC, then, almost certainy, there is a problem with the FC or its settings.
I don't know that FC (or any others come to that), so a link to its manual may help see what might be wrong.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
bob195558
Posts: 1836
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by bob195558 » Sun Sep 03, 2017 8:57 pm

I have never used this FC,
but I found this youtube video that may help: (https://www.youtube.com/watch?v=8sqivY8deT0).
It shows how to mod for SPort signal inverted serial data (using BetaFlight).
There are many versions of this FC out there too.

Bob B.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Sun Sep 03, 2017 9:46 pm

MikeB wrote:
Sun Sep 03, 2017 8:07 pm
The SPort signal is inverted serial data. Does the FC send inverted data?
No, F4 chip doesn't have an inverter, so you have to connect directly an UART TX (in my case uart6) to A port on X4R-SB

http://cdna3.zoeysite.com/Adzpo594RQGDp ... -39_pm.jpg

(Next week I'll try with a Taranis and see if discovery new sensors work, just to check connections.)
MikeB wrote:
Sun Sep 03, 2017 8:07 pm
Your FrSky setup should work. Since you are seeing RSSI and SWR, the Tx end is fine and all working.
I can get also RxV, I think I can get all the sensors sent by RX itselves, but I need A4 and Cvolt Ctot that are sent from FC to RX via S.Port.

Thanks.

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Sun Sep 03, 2017 9:48 pm

bob195558 wrote:
Sun Sep 03, 2017 8:57 pm
I have never used this FC
Is the most used in quads
bob195558 wrote:
Sun Sep 03, 2017 8:57 pm
but I found this youtube video that may help: (https://www.youtube.com/watch?v=8sqivY8deT0).
I know well the good soul JB... RX is slightly different, but is exactly my case. I can't do discovery on 9X, and I don't see A4 and Cbat value

User avatar
bob195558
Posts: 1836
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: TGY 9X + XJT + X4R-SB + SmartPort (AR9x upgrade)

Post by bob195558 » Sun Sep 03, 2017 10:50 pm

m3rcur10 wrote:
Sun Sep 03, 2017 9:46 pm
(Next week I'll try with a Taranis and see if discovery new sensors work, just to check connections.)
Hi m3rcur10,
You may want to consider upgrading your TGY 9X with the upgrade AR9x Rev. B board: (http://www.ar9x.net/).
This would increase your 9x capabilities a lot.
ErSky9x firmware: (http://www.er9x.com/). I believe more trouble shooting abilities.

Ar9x is most effective & Simplest upgrade of your Th9x or Turnigy 9x controller.
Support Telemetry of DJT and S.port of XJT 2.4 GHz RF module and more.
Compatible to latest Companion, OpenTx and Ersky9x firmware
No ISP required, No cutting, No drilling required.

AR9x Specification & Features
32-bit ARM Cortex M3 processor, 100 pin
512kBytes Flash, 64kBytes SRAM
COM1,2 Rx,Tx TR buffered, S.port support
COM3 ready for Bluetooth Module Interface
I2C bus pin header ready
7 ways Rotary Encoder & All key buttons, 3 ways button pin headers ready,
LCD back light controller (*back light not included)
Powerful Haptic controller (*vibration motor not included)
PPM2, Batt. PWR, GND connection ready for secondary RF module.
All IOs are ready in 2.54mm(100mil) standard pin header.
Software power off delay
3W Audio Amplifier embedded, 2W 8 Ohm Speaker included
Micro SDCard slot (*sdcard not include)
micro USB
Batt. Reverse Protection
Operation Voltage from 7.6~14V (*varies depends on attached external devices)
low power consumption 80mA @ 12V
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
(http://openrcforums.com/forum/viewtopic.php?f=95&t=7182).
CR10 3D Printer: (http://openrcforums.com/forum/viewtopic.php?f=85&t=10702)

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by MikeB » Sun Sep 03, 2017 11:01 pm

Double checking here, but you have connected the UART6 signal to the SPort (non-inverted) place rather than the SBUS connection, haven't you?

As a test, please configure the custom telemetry display and select one of the items as "TmOK", then power up the receiver. TmOK will show as 0 when no telemetry is being received, 1 if just telemetry is being received from the receiver (RSSI and RxV), and 2 if SPort data is also being received.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Mon Sep 04, 2017 7:53 am

MikeB wrote:
Sun Sep 03, 2017 11:01 pm
Double checking here, but you have connected the UART6 signal to the SPort (non-inverted) place rather than the SBUS connection, haven't you?
Thanks Mike for your help.
I've connected the TX of UART6 (configured in Betaflight as Smartport) of my FC, an F4 board that doesn't do inversion to the A port (not-inverted) of the RX X4R-SB, so I've not-inverted->not-inverted
https://www.dropbox.com/s/0srtur18kx9xp ... .46.23.jpg
MikeB wrote:
Sun Sep 03, 2017 11:01 pm
As a test, please configure the custom telemetry display and select one of the items as "TmOK", then power up the receiver. TmOK will show as 0 when no telemetry is being received, 1 if just telemetry is being received from the receiver (RSSI and RxV), and 2 if SPort data is also being received.
I've tested and I have TmOK=1

As soon as I can I'll try with a Taranis to check if connection FC-RX is working properly.

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by MikeB » Mon Sep 04, 2017 8:15 am

That's my point. That is the SBUS (servo output) signal from the Rx, not the SPort (telemetry input) signal. The telemetry input looks to be a point on a 3-pin component from something I found on the web.

TmOK = 1 indicates there is no SPort telemetry arriving at the Rx, which is correct if you have connected to the SBUS signal.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Mon Sep 04, 2017 8:27 am

MikeB wrote:
Mon Sep 04, 2017 8:15 am
That's my point. That is the SBUS (servo output) signal from the Rx, not the SPort (telemetry input) signal. The telemetry input looks to be a point on a 3-pin component from something I found on the web.
I'll check at home and keep you posted, maybe I've confused picture!

This was my resource: https://oscarliang.com/uninverted-sbus- ... receivers/

Thanks again Mike!

User avatar
MikeB
9x Developer
Posts: 15561
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by MikeB » Mon Sep 04, 2017 10:34 am

Yes I saw that. I believe the 'A' on the 4 pads is NOT the pad a referred to in the text.
Make sure you distinguish between SBUS and SPort, they are completely different signals, you need SPort.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

m3rcur10
Posts: 8
Joined: Sun Sep 03, 2017 10:02 am
Country: -

Re: TGY 9X + XJT + X4R-SB + SmartPort

Post by m3rcur10 » Mon Sep 04, 2017 6:26 pm

MikeB wrote:
Mon Sep 04, 2017 10:34 am
Yes I saw that. I believe the 'A' on the 4 pads is NOT the pad a referred to in the text.
SOLVED

thanks Mike again, I've checked and reflow the solder joint on the X4R pin (on the back side) that come loose pheraphs with too many hits or wasn't good from the beginning, and now fixed with hot glue.

It happens, if I'had checked at the beginning maybe I didn't had this issue.

Now I have A4 and TmOK=2

Post Reply

Return to “er9x”