RX8R-Pro Binding Problem

openTx has introduced a range of new features, ideas and bling. It is fast becoming the firmware of choice for many users. openTx will run on ALL current hardware platforms, including the gruvin9x and sky9x boards. Work has already started to support the new FrSky X9D radio!
Post Reply
dwoolridge2000
Posts: 4
Joined: Mon May 28, 2018 7:12 pm
Country: -

RX8R-Pro Binding Problem

Post by dwoolridge2000 » Mon May 28, 2018 7:28 pm

What I'm trying to do:
  • Bind one RX8R-Pro with telemetry On, outputting Ch1-8 on the servo PWM pins, and outputting Ch1-16 on S.BUS
  • Bind second RX8R-Pro with telemetry Off, outputting Ch9-16 on the servo PWM pins, and outputting Ch1-16 on S.BUS
I have this working in 2 airplanes using "Non-pro" versions of the RX8R.

Binding receiver "one" works fine. The problem is that the second receiver always binds with Telemetry On and outputs Ch1-8 on the PWM pins.

What I've tried:
1) Selecting "Telemetry On, Ch9-16" on the Transmitter when binding the RX8R-Pro
2) Bind with Jumpers on Ch1&Ch2 (like the non-pro XR8R) and also selecting Telemetry On, Ch9-16 on the Tx
3) Every other variation I can think of.
4) Selected Ch9-16 on the Tx--but then I don't get Ch1-16 out on S.Bus, just Ch9-16
5) Bind with Tx & Rx right next to each other, also binding them about 5-6 feet apart
6) Tried same binding processes with the other RX8R-pro receiver

I would have expected the RX8R "Pro" version to have the same functionality as the regular RX8R. Any ideas??

Taranis X9D-Plus
Tx Firmware: 2.2.1 (cca71808) EEPR: 218
RX8R Firmware: FCC171009
RX8R-Pro Firmware: FCC180223



Thanks,

Doug

dwoolridge2000
Posts: 4
Joined: Mon May 28, 2018 7:12 pm
Country: -

Re: RX8R-Pro Binding Problem

Post by dwoolridge2000 » Tue May 29, 2018 1:45 am

UPDATE:
I just discovered that the transmitter's internal XJT module has firmware that can be updated. I couldn't find a way to see what version was installed before.

Updated my Taranis X9D-Plus XJT firmware (internal module) to version 170317.

Here's what I now get when I bind to the RX8R-Pro:

Telemetry On, Ch1-8: Works as expected (didn't check S.Bus)
Telemetry Off, Ch1-8: Works as expected (didn't check S.Bus) -- Confirmed Telemetry is OFF
Telemetry On, Ch9-16: Telemetry is on, but no signals output on any of the 8 PWM servo connections (servo buzzed and got hot--all 8 connections) (didn't check S.Bus)
Telemetry Off, Ch9-16: Telemetry is off, but no signals output on any of the 8 PWM servo connections (servo buzzed and got hot--all 8 connections) (didn't check S.Bus)


Tx Firmware: 2.2.1 (cca71808) EEPR: 218
XJT Internal Module Firmware: 170317
RX8R Firmware: FCC171009
RX8R-Pro Firmware: FCC180223

User avatar
Kilrah
Posts: 9561
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: RX8R-Pro Binding Problem

Post by Kilrah » Tue May 29, 2018 7:28 am

When your servos buzz and get hot the receiver is likely putting out a fast signal, that is great for digital servos but analog ones can't be used in this case.
The receiver manual includes something about how to use fast or normal mode.

Yes for binding options in the menu to work both the internal RF module and receiver must be on recent enough firmware.

Helle
Posts: 572
Joined: Sat Jul 21, 2012 7:08 am
Country: -

Re: RX8R-Pro Binding Problem

Post by Helle » Tue May 29, 2018 8:03 am

You need D16 Mode (18ms) not 9ms or D8 Mode
then select
Ch 1-8 Telem ON
Ch 9-16 Telem OFF

User avatar
Kilrah
Posts: 9561
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: RX8R-Pro Binding Problem

Post by Kilrah » Tue May 29, 2018 9:18 am

The selection on the radio does NOT alter PWM output frequency at the receiver.


dwoolridge2000
Posts: 4
Joined: Mon May 28, 2018 7:12 pm
Country: -

Re: RX8R-Pro Binding Problem

Post by dwoolridge2000 » Tue May 29, 2018 3:45 pm

Clarifying...

Kilrah, Per the manual:
"Servo High-speed mode only operates when the signal pins of CH5&CH6 are jumped before bind." I did not use any jumpers when binding... and Ch1-Ch8 worked fine.

Helle:
Thanks for the reminder. I must shamefully admit, that was it! With all the messing around I had done, I had left the setting as Ch1-8 (9ms) and forgotten to check that.

dwoolridge2000
Posts: 4
Joined: Mon May 28, 2018 7:12 pm
Country: -

SOLVED!!

Post by dwoolridge2000 » Tue May 29, 2018 3:49 pm

SOLVED!!

The keys to the solution for me were:
1) Upgrading Taranis X9D-Plus firmware (2.2.1)
2) Upgrading the internal XJT transmitter firmware to version 170317
3) Making sure the transmitter settings were:
  • Mode: D16
  • Channel Range: CH1-16 (16ms)
  • Bind using option: Ch9-16 Telem OFF
The RX8R-Pro can now have Telemetry OFF, Output Ch9-16 on the PWM Servo outputs, and Ch1-16 out on S.Bus

Post Reply

Return to “openTx”